VLC Player only shows black screen for video playback on FP1

Dear all,

Does someone have the same problem that VLC Player only shows the playback controls and at the place where the video should be shown, it only presents me with a black screen?

Thankfully,

~Robert

I have a similar problem with VLC and some video codecs.

  • audio is playing
  • subtitles displaying
  • time running

but no video - except: When I change the phone’s orientation from landscape to portrait, the video appears for a fragment of a second. Very strange!

@orschiro & @Arnd: Which versions of VLC are you using? There is a recent VLC version (1.9) in f-droid and several others in the play store. Is there an example video you could link to? Or can you say what codecs are involved?

There is a tool called “mediainfo”. Maybe you can post what it says about your video files that do not work well with vlc.

1 Like

It’s VLC 1.9.0 from the F-Droid repository.

This is one video that shows the described problem with VLC:

  • .avi Format
  • Codec: MPEG 4 Video (DX50)

Another one:

  • .avi
  • Codec: MPEG 4 Video (XVID)

One that works fine:

  • .mp4
  • Codec: H264 MPEG-4 AVC (part 10) (avc1)

Information taken from desktop VLC player, which shows no problem with any file.

Thanks!

1 Like

I would recommend to convert the videos for the FP1 to the MPEG4AVC video format if that is possible for you. Maybe due to patent issues … the codecs for DX50 and Xvid video where removed? You might have to check that.

Update: I had a look at their forum. I wasn’t able to find anything there about deactivated codecs for Android …

Or be bold and try the dev versions :slight_smile:

1 Like

I’ll try that!

Thx, Arnd

1 Like

@orschiro @Arnd I’ve had this problem and could solve it by disabling HW overlays in Settings > Developer options. Unfortunately I cannot find the source anymore.

In the latest VLC 1.9.0 on my FP1 with #kitkat I don’t experience any problems.

5 Likes

Thanks @Stefan!

In Settings > Developer I only have one setting called Advanced hardware decoder with the following checkbox entries:

  • Automatic
  • iomx
  • iomx-dr
  • mediacodec
  • mediacodec-dr

So, nothing to disable really. I am also using VLC 1.9.0 but on Jelly Bean 4.2.2.

Your upgrade to Kitkat was not an official one, correct?

~Robert

Excellent, that did the trick.

Thanks a lot!

Arnd

@orschiro, Stefan is referring to the phone’s developer settings, not VLC’s.

4 Likes

It’s seems to be a mix (VLC allows it, but has to be switch off at Android level for the Android app). So it seems to be a gfx issue on the FP1 not a codec one. Good to know. Thanks Stefan!

https://forum.videolan.org/viewtopic.php?t=53218
https://android.stackexchange.com/questions/81529/can-anyone-explain-all-these-developer-options

1 Like

That was the trick. Thank you! :smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.