Viking Mobile Data doesn'T work on FP1

Hey everyone,
i just recently got a Viking Mobile Simcard for my time in Belgium. While calling and texts work fine with my FP1, even though following the guidelines on how to activate the mobile data i cannot get it to work.
I also read through the dutch thread on the topic but couldn’t find anything that would solve my problem there either.
Any ideas on how to get this solved?
thx in advance for your help!

That description sounds like you could have wrong APN settings.
Try to find the proper APN settings from your provider, and check if they are correctly entered on your phone. should be in settings --> more (in the data section) --> cellular network settings --> access points.

i used the guidelines for setting up the APN on the viking homepage. also sent them screenshots of the various settings to be sure i didn’t miss something (they were all right). and changed the 3G service to viking… but nothing worked.
as suggested in the other thread, i also tried by switching the Simcard slots… didn’t help either…
and now i’m kind of running out of ideas (i do know that both simcardslots should work, i used them both when being in georgia, also had a local simcard there)
therefore i have no idea what it is with this one…

Not sure if this may help with FP1 (I have read though a couple of times that it worked on FP2): Some users reported that they had to delete the original APN and create a new entry with the appropriate settings. Modifying the existing did not help. Could be worth a try.

Note that only one of the two SIM slots support 3G at a time. If 3G is activated for your home SIM you have to manually activate it on the second SIM slot.

Here are instructions on how to active 3G for your Viking SIM card:

i changed the 3g settings to viking already, but unfortunately it still doesn’t work :frowning:

you mean when the APN (in my case viking) is suggested and i tick it it might not work?
viking interstingly never should up as possible APNs only Base Mobile Internet and Base MMS which is why i set up a new APN with the settings they suggest on their homepage for viking.
but it didn’t get me anywhere either.

or do you mean i would have to delate those automatically suggested APNs? how would i do that… it doesnt give me the option to delete with these…

If you really don’t find a way to delete APNs, you could try to follow this tutorial:

Luckily the FP1 is already rooted, so you can skip step I.1.

i guess this was a good hint on how to get rid of th other APNs… but unfortunately even after deleting them all and adding a new one for viking, there is still no mobile data… :sweat:

Random question:
How did you check there is no data? Are there any symbols in the signal status icons at the top of the screen? (or just the signal bars?)

1 Like

there is only signal bars but no data signs (H, 3G…) etc…
and i checked it by trying functions which would need internet access… but i always get the message that there is no connection and how i would have to turn on a mobile network or wifi (while the mobile data is activated)

Ok, then it’s definitely not connecting to the data network (I’ve seen some cases where something in the system was blocking data use - hence my paranoid question). I’m also assuming nothing shows up whatsoever in Settings > Data Usage > [Relevant SIM] except that Mobile Data is On?

jupp. exactly. its really weird. i just tried the simcard in another phone and it worked fine… so its definately “me” or my phone that causes the problem (i also used to simcards in georgia and the local simcard there worked just fine)

Like you, I’m running out of ideas. One assumption that I had was that MVNO issues would cause the signal status bar to show an R, but perhaps not. Does turning data roaming on help?
Other than that, double-check what the APN settings are of phone that does connect to the network (at least of it’s a similar android phone - iPhones sometimes have different settings)

i also thought of that which is why i turned it on already. but it didn’t help either.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.