Enable 3g on both sims?

Don’t think 1st and 2nd generations differ hardwarewise (if so, the shift from 2G only to 3G for 2nd SIM is such a big change that it ought to have been announced).
So maybe it’s just a matter of activating 3G:
System Settings > Wireless & Networks - More… > Mobile Networks > 3G service > Enable 3G > Tap on your provider’s name so that you get a blue dot to the right.