Video capture losing focus: Broken camera?

Whether it’s hardware or software it would be nice to have some official comment from Fairphone on this. It seems clear from the thread that this is a widespread issue.

I have a similar problem. Nearly for every second video I’m capturing the camera loses focus after a few seconds for approximately half a second. This happens then several times when I’m recording.
This is off topic. But my phone also suffers from ramdom reboots.

Same for me.
I work around it by using opencamera, setting the focus and selecting “lock focus” (keylock icon). Then I can shoot the video. But can’t wait for a real fix.

Thanks for the suggestion Jaymanu, I downloaded Open Camera recently so will try that.


i am having the same problem wit my FP2.
It is not possible to take a sharp video with my FP2 at all.
i havent tried other than the default camera app up to now.
The recent firmware update (Fairphone OS 1.2.8) unfortunately was no help.
I am a big fan of fairphones philosophy, but this problem is really a no-go.
I already talked to other people who were interested in the fairphone 2 but i could not recommend the FP2 any more, having a nearly unusable camera (video, but also bad picture quality) .
Why is no fairphone employee giving some hints or tipps here on this forum post?

Joe wrote here:

Hey there dear owners of fairphones
I’m having the same problem with my camera loosing focus during video capture. I was wondering if somebody has received an answer from the fairphone support yet?
If not, I will also write them.
I can’t believe that this is a hardware issue, it really should be possible to fix this by software update! (I mean, I hope so :stuck_out_tongue: )
If the camera manages to keep focus, the quality is amazing! Only the quality of the built-in microphone is very poor. At least if you record a rock concert…

To me this seems pretty much a problem with the default camera app that appears to not be able to autofocus.
Since a while I am using now “A better camera” as standard camera app. Since I have set the video camera modus to “continuous focus”, the camera is able to focus.
Nonetheless, I cannot select the region of the focus (it always focuses on the center), and the focus correction (when distance changes) seems pretty slow. However, since I switched the camera app and changed the focus method, videos are in focus.

I am the one who opened this thread, but I cannot edit it any more, so here is my last update:

I got a replacement phone and the video capture worked OK, even with the default camera app. If it was a bug in the app, then all phones would have the same problem, wouldn’t they?

However, the second phone was terribly frustrating because of the frequent random reboots. This was fixed by the OS update, so now I have a perfectly working fairphone. :sunglasses:

My advice to anyone who has the video focus problem: Try different camera apps: “A better camera” was mentioned, I am using “Open camera”, maybe there are others. If you are still not happy with the results, then contact the support team, be patient, and follow their instructions.

1 Like

same problem here, focus becomes blurry when I start filming. Any possibility this will be fixed by an update soon?

Did you try with an camera app that you can set to continuous focus? Does it focus properly when making photos?

I agree with @dkonto’s suggestion, I’d also try a couple of different apps and settings (I got satisfying results with another app where I could set the focus to continuous), and if it always remains blurry, then it might be best to contact support (in order to get a camera replacement).

See also:

Sometimes i carefully set the focus in advance.
Then I press the record button.

At this very instant, the focus wildly jumps back to blurry position.
I then need a very strong amount self control to resist throw away this fair***** ! Yes, 6 months of patience and 525€, i shamelessly dream of crashing it and his modules on the floor !!

More seriously, are there any reports of people replacing the camera module and then having it working perfectly ? I would be interested in knowing that. But I’m more suspecting a driver issue, faulty blob or API.

I had these video problems (fotos work well with any app) with Open Camera, too. But with Camera MX it works well.

Might be possible.
I am pretty sure that most camera problems relate to software issues. Also with the default camera, I can basically focus manually, but the camera tries to refocus a couple of seconds after the manual focus worked. This can be quite annoying …

Hi, I have the same problem. I initially thought it was only in low light, but it’s happening all the time.

I haven’t really taken any videos with the FP2 but just tried it and can confirm the focus problems with the stock app and Open Camera. I’ve replaced my camera module because of the broken focus which fixed the initial focus problem but this one still occurs.

I’m using FPOpenOS with the stock camera. The photo-focus works well, but I can confirm that the back-camera-video-auto-focus always stops at a blurry position… -so it’s impossible to capture sharp videos…
So I played around and found a interesting thing… -When I open the back-video-camera and switch just to the front-video-camera and then back again to the back-video-camera, -the back-video-camera-focus works well!!! -don´t know why, -but I tested it now many times, -and it works… :slight_smile:

-But anyway, I think I switch to a camera app with manual focus… :wink:



I also have the “jumping video focus” issue with the default camera app. Photos are fine. Based on your feedback, I may investigate other apps. @freibadschwimmer what app are using ?

For me OpenCamera can not focus to far away things in video mode.
Only “macro” things in the nearer surrounding are focused properly in videos.

For still images everything is fine, also with the stock app “Camera” sharp video recording is possible.

Is a bug in OpenCamera or a in FPOS possible?

I moved your post here as I belive the issue you describe is very similiar. It seems to be an issue with some FP2s.

1 Like