Video capture losing focus: Broken camera?

Joe wrote here:

Hey there dear owners of fairphones
I’m having the same problem with my camera loosing focus during video capture. I was wondering if somebody has received an answer from the fairphone support yet?
If not, I will also write them.
I can’t believe that this is a hardware issue, it really should be possible to fix this by software update! (I mean, I hope so :stuck_out_tongue: )
If the camera manages to keep focus, the quality is amazing! Only the quality of the built-in microphone is very poor. At least if you record a rock concert…

To me this seems pretty much a problem with the default camera app that appears to not be able to autofocus.
Since a while I am using now “A better camera” as standard camera app. Since I have set the video camera modus to “continuous focus”, the camera is able to focus.
Nonetheless, I cannot select the region of the focus (it always focuses on the center), and the focus correction (when distance changes) seems pretty slow. However, since I switched the camera app and changed the focus method, videos are in focus.

I am the one who opened this thread, but I cannot edit it any more, so here is my last update:

I got a replacement phone and the video capture worked OK, even with the default camera app. If it was a bug in the app, then all phones would have the same problem, wouldn’t they?

However, the second phone was terribly frustrating because of the frequent random reboots. This was fixed by the OS update, so now I have a perfectly working fairphone. :sunglasses:

My advice to anyone who has the video focus problem: Try different camera apps: “A better camera” was mentioned, I am using “Open camera”, maybe there are others. If you are still not happy with the results, then contact the support team, be patient, and follow their instructions.

1 Like

same problem here, focus becomes blurry when I start filming. Any possibility this will be fixed by an update soon?

Did you try with an camera app that you can set to continuous focus? Does it focus properly when making photos?

I agree with @dkonto’s suggestion, I’d also try a couple of different apps and settings (I got satisfying results with another app where I could set the focus to continuous), and if it always remains blurry, then it might be best to contact support (in order to get a camera replacement).

See also:

Sometimes i carefully set the focus in advance.
Then I press the record button.

At this very instant, the focus wildly jumps back to blurry position.
I then need a very strong amount self control to resist throw away this fair***** ! Yes, 6 months of patience and 525€, i shamelessly dream of crashing it and his modules on the floor !!

More seriously, are there any reports of people replacing the camera module and then having it working perfectly ? I would be interested in knowing that. But I’m more suspecting a driver issue, faulty blob or API.

I had these video problems (fotos work well with any app) with Open Camera, too. But with Camera MX it works well.

Might be possible.
I am pretty sure that most camera problems relate to software issues. Also with the default camera, I can basically focus manually, but the camera tries to refocus a couple of seconds after the manual focus worked. This can be quite annoying …

Hi, I have the same problem. I initially thought it was only in low light, but it’s happening all the time.

I haven’t really taken any videos with the FP2 but just tried it and can confirm the focus problems with the stock app and Open Camera. I’ve replaced my camera module because of the broken focus which fixed the initial focus problem but this one still occurs.

I’m using FPOpenOS with the stock camera. The photo-focus works well, but I can confirm that the back-camera-video-auto-focus always stops at a blurry position… -so it’s impossible to capture sharp videos…
So I played around and found a interesting thing… -When I open the back-video-camera and switch just to the front-video-camera and then back again to the back-video-camera, -the back-video-camera-focus works well!!! -don´t know why, -but I tested it now many times, -and it works… :slight_smile:

-But anyway, I think I switch to a camera app with manual focus… :wink:



I also have the “jumping video focus” issue with the default camera app. Photos are fine. Based on your feedback, I may investigate other apps. @freibadschwimmer what app are using ?

For me OpenCamera can not focus to far away things in video mode.
Only “macro” things in the nearer surrounding are focused properly in videos.

For still images everything is fine, also with the stock app “Camera” sharp video recording is possible.

Is a bug in OpenCamera or a in FPOS possible?

I moved your post here as I belive the issue you describe is very similiar. It seems to be an issue with some FP2s.

1 Like

Thanks Ahne, video works fine now with your solution !

1 Like

Can you guys who have this issue check whether the DIY fix for the “general camera can’t focus issue” also works here?

1 Like

Same problem here. I’m using the open os and it doesn’t matter which software i use. None of them can focus automatically. The switch to front camera doesn’t work for me.

When I contacted the FP support, there replied me this :

This is an issue that we are aware of and is unfortunately a software bug. We are working on fixing this and it is high on our list of priorities. Right now we suggest that those suffering from this issue try using a separate video recording app like “open camera”. The issue tends to solve itself or at least partially resolve itself when using a different app.

So it seems the only real solution we have is to wait … ? Wait for what exactly … Update ? It would be really nice to have some additional informations from the support but i don’t know how to get any since this forum is not linked to any FP support.

I also have the problem with videos. When taking photos, everything is fine, but when switching to video the image gets blurry. I can basically not record video of anything further than ~1m away without the video image going blurry. If I try to refocus, the picture is fine for a few frames and than goes back. Nearby shots work. I tried different camera apps (Open Camera), same problem. Any solution to this? Is this a software or a hardware issue? Has anyone experience with Fairphone support on this issue?

I had the same problem. Open camera did not fix it but CameraMX did. I still get a blur at the start but I can edit it out afterwards.