Very basic questions about connecting FP3 to Mac

Hi,

Sorry I feel very stupid asking these things. I am trying to unbrick a fairphone that I bought last year, based on the advice here:

Original issue is described here:

Basically I have only just found the time now to try and fix this, but have come up against my total lack of knowledge of programming. I can put my phone into fastboot with power and volume down buttons and I’ve downloaded ADB and fastboot, but I’m not sure that I’m installing/opening them correctly on my Mac and when I type “./adb devices” there is no device listed, which I assume means my phone is not connected to my laptop.

Can someone point me in the direction of a very basic level tutorial of how to connect my phone to my mac and load ADB/fastboot? I’ve tried searching for this both on this forum and elsewhere but it seems too complex for my inexperienced brain! After that I then need to work out how to flash the file in the first link above, which again is not something I have any understanding of, so if anyone could point me in the direction of a basic tutorial that would be amazing.

I’m so sorry to ask all this simple stuff, I have a feeling that if I could get the right information this might not be so complicated, but it feels like a totally alien language and I’m worried me messing in Terminal without any knowledge might just make things worse.

Thanks in advance,

Donald

Just as a further update I have tried this workaround:

I can see the device on system information and tried what it suggests about using the vendor ID in terminal, however still when I then input ./adb devices there are no devices listed as being connected. This seems to be my first (but I’m sure not only) issue. If anyone has a workaround or any tips I would hugely appreciate it.

Thanks

Donald

Just to be sure, because it isn’t clear to me when you try this … the adb command doesn’t do anything with the phone in fastboot mode, the fastboot command does.

When you have the phone in fastboot mode, does ./fastboot devices say anything?

2 Likes

Okay that’s very helpful information!

With the phone in fastboot mode I typed ./fastboot and it says:
A209FNHS0201 fastboot

(sorry, I can’t emphasise enough how embarrasingly basic my understanding of all of this is).

However, I think I might now be cooking with gas! After your helpful advice I used the fastboot command followed by this:

And I think it worked! Unlocked the bootloader, now I need to work out the next step to getting the phone working which I think is something to do with “flashing”, another concept I don’t understand but this feels like a bit step forward. Thank you AnotherElk!

@D00nad
You don’t say whether wanting to re-install Fairphone OS or different OS, but for Fairphone this resource may be of help: https://support.fairphone.com/hc/en-us/articles/18896094650513-Installing-Fairphone-OS-Manually. I am a Mac user and have both flashed Fairphone OS and iodéOS in the past.

1 Like

I’ve now had some excellent progress, managed to install fairphone OS using the directions you sent and looking into now instead installing e/OS to get away from Google…

Thank you again to both of you for your advice!

D

2 Likes