Valid SIM card doesn't connect

I got my FP2 in May/June. During the last month or so it shut itself down about once per day, but that was more or less okay. But a couple of weeks ago it suddenly started sending out emergency text messages every 5 minutes with my GPS coordinates to three pre-selected numbers. This was an old app I had on my FP1 and haven’t installed on FP2, so it was a bit strange. To halt this spree, I removed the SIM card and inserted it into an old phone instead. When I put it back into the FP2 one or two days later, it briefly connected to the operator (and started sending emergency texts again), but then lost connection. The SIM card itself is fine – when I insert it into an old Nokia it works. I also got a new SIM card from the operator and it still doesn’t work in the FP2. Wi-fi still works. Does anyone have advice or do I have to mail this beauty to Holland for support or replacement?

Also, I tested switching the SIM card to the second slot. No change unfortunately.

Not sure which emergency app it was (since, again, it wasn’t even ever installed on my FP2), but it might have been

If you used the same Google account for both phones, you may have copied app settings to your new phone, at least the Play Store should show all your old phone’s apps in “My Apps”. Here you can see the emergency texting app and make sure that it’s noy installed.

In which country are you using the phone and from which operator is the SIM card?

Hi Albert, thanks for replying. You were right, I had an app named something like Panic Button. I’ve uninstalled it now.

The phone still doesn’t connect however. Like before Wifi works but not the connection to the phone network.

It does recognise that the SIM card comes from Telia, so that’s something… The information says “No service - Telia”. But, again, the card works fine using my old Nokia X1-01.

I’m in Sweden, using the largest operator Telia.

Getting ready to mail the phone to the workshop.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.