Using Sailfish OS on the FP2 - Experiences and Issues

Yipppiiieee!!! mal and explit, you are great! :slight_smile: Thanks a lot for your kind help!

Flashing the file

system.img

in addition brought the solution to me! Now I can boot into Fairphone Open without any problems! I’m very happy that I didn’t damage my mobilephone, because I thought that I could kill the ROM by flashing a faulty image of the system…

Right now, I flashed the Sailfish-*.img-files and Sailfish is installing correct! I’m extremely relieved now, how can I thank you! :slight_smile:

1 Like

Okay, I did it all again for training-purposes… :slight_smile: User mal is fully right: You only need the file

system.img

from the official Fairphone Open-OS to install Sailfish OS afterwards. I don’t understand why both manuals describe the other files boot.img and userdata.img also as necessary for the flash…

For all beginners like me: The fastest workaround to get Sailfish OS on Fairphone (via Fastboot) could be the following:

  1. Install Fastboot on your computer (hint: Linux-Fastboot is even more comfortable! :slight_smile: )

  2. Boot your Fairphone 2 into the Fastboot-mode (push power-on-button and volume-down-button the same time)

  3. Connect your Fairphone 2 to the computer by plugging the USB-cord

  4. Check out that the program Fastboot correctly detects your Fairphone 2 (in Fastboot-mode) by entering the command

fastboot devices

  1. A number should be displayed, followed by the word fastboot, e. g.:

a080d3f2      fastboot

  1. Now you can start the flashing-progress. In first, delete all the remaining data on the phone by entering the command

fastboot -w

  1. Next, install the file

system.img

      from the official Fairphone Open-OS by using the command

fastboot flash system /directory_of_fairphone_os/system.msg

      I was using the system.msg-file from the Fairphone Open-version 16.10 and did not
      run into any problems.

  1. Next, you can flash the two required Sailfish OS-files by the commands

fastboot flash userdata /directory_of_sailfish_os/userdata.img
and
fastboot flash boot /directory_of_sailfish_os/boot.img

  1. At least, you have to restart your phone and boot into Sailfish OS by the command

fastboot reboot

This worked completely fine for me! :slight_smile: Until now, I didn’t recognize any problems when using Sailfish - we’ll see…

2 Likes

Great it has worked!

fastboot -w is a very agressive command, which will delete all userdata. in most cases it is not needed.

You can always upgrade your Fairphone Open Android Base to a higher Version to get the newest Android Security patches.

Very importand is to flash all the files from the Fairphone Open Package
but without

fastboot -w
fastboot flash boot boot.img
fastboot flash userdata userdata,img

This commands will DELETE YOUR SAILFISH INSTALLATION !!!
Be careful to comment them out of the script flash.sh - flash.bat

Any other fastboot images like modem fw, system.img and recovery.img can be flashed without problems.

2 Likes

The wiki page https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2#Installation_steps does not tell you to install boot.img and userdata.img from Android, those refer to files from Sailfish fastboot zip. The whole installation instruction assumes that you have Fairphone Open Source Android installed, it only mentions which version is recommended and doesn’t give instructions how to install the Android base image because those instructions are already available on Fairphone website. However in the Sailfish OS OTA update instructions on that wiki page the instructions for updating the base Android system.img are given in case that is needed.

2 Likes

Yes mal-, i only want to point out, if Sailfish is alredy installed on top of Fairphone Open, Fairphone Open could be updated easily to the newer Version,
when the user don’t flash the images
boot.img and userdata.img

Of course your manual is the first thing which a person should read, before installing Sailfish OS on the Fairphone.
Thank you again for your work on porting and for helping others here on the forum!

You are completely right - that was a big mistake from my side! I thought it is the same thing like the described progress for installing Sailfish OS… I’m very happy about this great work of the developers! Thank you very much! :slight_smile:

One other question:

Do you also lose nearly all of your installed applications if you switch of the developers mode? Furthermore, I can’t find the system-settings anymore after disabling the developers mode. Is that a bug?

There has been some issues with disabling developer mode in Sailfish OS community ports and a general rule has been not to disable developer mode. It’s sometimes problematic to get it back. It should be possible to manually install it back via telnet (ip: 192.168.2.15, port: 2323) using the command zypper in jolla-developer-mode. However I just tested and I could disable and re-enable developer mode from settings on my FP2 with 2.0.4.14 Sailfish OS. I believe it should work if Jolla account is set.

1 Like

mal, thank you very much for your great help! Why do you know all those things? It seems that you are working for the community? :slight_smile:

I’m still using the common Sailfish OS 2.0.1.11 alpha2 together with an Jolla account. Probably that bug was not yet fixed in this version… No worries, I easily reinstalled Sailfish and everything is fine now. :slight_smile:

Thanks, it worked ! I realised I was typing it wrong and that’s why it never worked :flushed: I’m fine now :slight_smile:

Let me anwer for Mal-!
Mal- is not only working for the community, he is a main SailfishOS on the Fairphone 2 Porter. Without his work we wouldn’t see any running SailfishOS Builds on the FP2.
It is very complicated to do all the work alone, but Mal- still do it. He is a SuperDev in my eyes! :wink:

7 Likes

not juste in your eyes. I want another says thank to mal

1 Like

Mal- is not only working for the community, he is a main SailfishOS on the Fairphone 2 Porter. Without his work we wouldn’t see any running SailfishOS Builds on the FP2.

Wow, I already expected something like that… :open_mouth:

I want to donate a little money to him because of his great work and his kind support inside the forum! Maybe we can crowdfund a little bit? Just to say thank you, because such an amount of work of course is not self-evident…

5 Likes

There are many people who want support Mal- with a donation (including me)

As far i know Mal- don’t use PayPal (maybe it will change in the future)
Well, i’m not familiar with other donation tools like Flattr or something else…

I asked Mal- many times how the community could help / donate / support him.
But i didn’t got an answer :frowning:

I also think its a huge amount of work. i’m very happy that Mal- is such enthusiastical and and perfectionist person.
Lets hope his enthusiasmus will last for a while!

6 Likes

Hi all,
I also tried to install Sailfish OS 2.0.1.11 alpha 2 on my new Fairphone 2 using fastboot.
I am stuck at:
fastboot flash userdata userdata.img
I get the error: FAILED (remote: Bogus size sparse and chunk header)
finished. total time: 27.525s

When I first started my phone I updated to Fairphone OS 1.8.1 using the updater app. Then I installed Fairphone Open 16.10.0 using the updater app ass well. This all went fine without any problem and the phone also worked nicely with the opensource OS.
I put my phone in fastboot mode and tried to install Sailfish OS 20.01.11-alpha2 following the steps described in https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2#Installation_steps
My phone was recognized by fastboot, but at fastboot flash userdata userdata.img I got the error.

Now I reinstalled Fairphone open again, but this time using fastboot. No problem.
When installing Sailfish again I got the same error.
Then I went back to the normal Fairphone OS 1.8.1 and tried the procedure described by @Bobbel. Still the same error. There seems to be a problem flashing userdata.img because other files can be flashed without a problem.

I already searched the forum for a solution, but unfortunately I could not figure it out.
Does anyone have any idea what I am doing wrong?
I am using fastboot on a Mac.

Thanks a lot for your help!

Why are you using the fastboot method when you could install Sailfish from TWRP recovery using the other zip file mentioned in the wiki? I have also noticed that the fastboot method sometimes fails, not sure if it happens when you have too new Android installed on the device, I need to investigate what is causing that. I consider the recovery installation as the preferred method.

I had the same issue with the fastboot install route when I tried this for the EFCT16 Software workshop. In that case I first downgraded from 1.5.1 to Open 16.06 (which is listed on the wiki as having been tested). So it’s not directly related to the version, though it could be that something was changed when 1.5.1. was installed that is not undone by flashing Open 16.06.

The TWRP route worked perfectly well.

Thanks for the replies!
Actually the reason I used the fastboot method was that I didn’t know what TWRP was and how to use it. The fastboot method seemed quite straight foreward. I will try the TWRP method.

IT worked! I managed to install Sailfish OS using TWRP. Very easy actually :slight_smile: Thanks for the suggestion!

Could it be that adb/fastboot is generally (somewhat) unreliable on FP2? The dev of the magic-device-tool mentions this in the comments-section of this video about the tool: https://www.youtube.com/watch?v=lhKLfmBWE9w

and this lack of reliability seems to be the main reason, why the UBports community port of Ubuntu Touch for FP2 does not work properly atm… (?)

I don’t recall encountering any other issues with adb/fastboot when I was playing around with it on the community Fairphone, it was just the Sailfish image which failed twice. Then again, I didn’t do that much adb/fastboot stuff, so I can’t rule out random failure either.