Using Sailfish OS on the FP2 - Experiences and Issues

Yup saw the latest on merproject but didn’t change that one. I thought it was jolla store that asked for user/password but I may have looked wrong.

Anyway upgraded now to latest_armv7hl repo. Thanks for clarify.

Btw. I have found some issues with BT on FP2 SFOS (all versions). If headset is disconnecting (when go out of range) I sometimes have to re-pair headset? Anyone seen similar issues?

Does anybody know what i am doing wrong?

I want to update to the latest_armv7hl but there is a problem with the repositories.
The adaption0 and extra repositories are correct, but there is a problem with the apps, hotfix and jolla repository.

Please help me!

Using Comic Sans as a system font seems plenty wrong to me (just kidding)


What I can see is that with the adaptation0 you are in the testing repo; for latest versions you need to change to the devel repo.
See mal’s post, 2 posts above yours.

There’s the same problem. Now is instead of 'testing:" “devel:”, but at apps, hotfixes and jolla aren’t any changes

I just switched back to Open OS yesterday, so I can’t check, but I am pretty sure that I had these in the releases.jolla repos as well and no problems to update. Latest version I had installed was
I only changed the adaption0 & extra.

Did you update the repos after the change (ssu ur) before initiating the update (version --dup)?

At the command devel-su zypper ref -f:

the problem is solved:

the adaption0 and common repos must be on ‘latest_armv7hl’ and the apps, hotfixes and jolla repos on

thanks to mal-


I’m sorry, but if the update to worked great, I can’t do the update to the version because they ask me my password. I read all your posts above but I don’t really understand…

I tried to change adaptation0 to, but it didn’t happen (with ssu ar adapation0 wich I believe is the command to do so, but there’s no man pages). The same for the extra repo (with …/common/sailfish_latest_armv7hl/).

What did I do wrong and can someone help me ?

You have to change adaption0 with these command:

devel-su sed -i -e 's#^adaptation=.*$#adaptation=' /usr/share/ssu/repos.ini

1 Like

you need to run the sed-command after each software-update, because it will always resetted back to the Jolla-Settings (Jolla adaptation0) repository which we can’t use on FP2. Until we get official Sailfish OS Support.

is it me or is the orientation sensor is completely broken in 2.0.4 release? Phone is not switching to landscape mode and flip-to-silent feature is not working either =(

it is the same at my phone, theres no solution at that time

ok, i did zypper up and now everything seems to be alright. Can switch to landscape and flip-to silent also is working

Update to the last Adaptaion
It seems, that mal- has bugfixed the problem

1 Like

A quick question: How much time does it take to install the outdated and required Fairphone-Open-version to get the possibilty for installing Sailfish OS subsequent?

In first, I try to install the Fairphone-Open-system via Fastboot using the following commands:

fastboot devices                                                        (checking if the phone is in fastboot-mode)
fastboot -w                                                                 (erasing the cache and userdata-files)
fastboot flash userdata files/userdata.img           (flashing userdata.img)
fastboot flash boot files/boot.img                          (flashing boot.img)

Everything worked fine until now, but the next step seems to cause some problems:

fastboot reboot

Since the reboot-command, I’m already waiting around 5 minutes for a change of the display-signal. Unfortunately, the bootup-screen with “Fairphone - powered by android” is still shown without any operating-system-information…

Is it usual to wait such a long time? I thought that first bootup into Fairphone-Open should be more quick? I’m asking, because I still want to install Sailfish OS afterwards…

… in the meanwhile, I’m waiting since 35 minutes! :frowning: That can’t be true?

I gave up… :frowning: The brand new phone is not usable anymore. What went wrong? Also the “reset to factory defaults” doesn’t work…

Here is the log of my work:

user@User:~$ fastboot flash userdata /home/user/Desktop/Handy/userdata.img
target reported max download size of 536870912 bytes
erasing ‘userdata’…
OKAY [ 2.933s]
sending sparse ‘userdata’ (524284 KB)…
OKAY [ 16.504s]
writing ‘userdata’…
OKAY [ 5.501s]
sending sparse ‘userdata’ (524284 KB)…
OKAY [ 16.500s]
writing ‘userdata’…
OKAY [ 5.463s]
sending sparse ‘userdata’ (166116 KB)…
OKAY [ 5.228s]
writing ‘userdata’…
OKAY [ 1.748s]
finished. total time: 53.876s
user@User:~$ fastboot flash boot /home/user/Desktop/Handy/boot.img
target reported max download size of 536870912 bytes
sending ‘boot’ (11246 KB)…
OKAY [ 0.354s]
writing ‘boot’…
OKAY [ 0.132s]
finished. total time: 0.487s
user@User:~$ fastboot reboot

finished. total time: 0.001s

The phone still stucks in the bootup-screen “Fairphone powered by android”, and the reset to factory defaults doesn’t solute anything… :frowning:

If you are trying change the Android version you also need to flash the system.img from the android fastboot zip. Actually that system.img is the only thing needed before installing Sailfish. If you are planning on updating to latest Sailfish right after that you can just install the latest Open Source version of Fairphone Android and then install Sailfish and update it via the instructions earlier in this thread. In case you use the latest Android version I suggest you install also the recovery.img included in the Android zip after which you can install Sailfish OTA zip from the recovery instead of using fastboot


As mal- alredy said, first step is to install Fairphone Open.
Second Step is install sailfish from Mals- manual.

Just install Fairphone open from the Fairphone Open Manual File

You should be able to boot to Fairphone Open.

Afterwards you go to fastboot mode again and flash Sailfish

Luckily Fairphone is very open and it can always be very fast reflashed with fastboot.
So don’t panic !

1 Like