English

Using Sailfish OS on the FP2 - Experiences and Issues

sailfish
Tags: #<Tag:0x00007fefc8c6ed68>

#363

As far as I know, this is the latest available version: Sailfish OS 2.2.0.29 beta1 release


#364

Thank you Ingo.
In another topic, Theofruitrouge give me a link to have the current statement of SFOS on FP2 :

https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2


#365

During the last UBports Q&A, the information was shared that the developer of Anbox was able to help them to fix Anbox on devices with Adreno GPUs.
Could this help making it work in SFOS?
https://ubports.com/de_DE/blog/ubports-blog-1/post/ubuntu-touch-q-a-34-164


#366

Next Sailfish OS release for FP2 will be available quite soon after the next official Sailfish OS version is released. I think that should not take too long. I will have to check the latest Anbox changes and see of those help with FP2.


#367

The new Sailfish OS version (2.2.1.18) was released this week for official devices and the build target is now available so I can build it for FP2 and start testing this weekend and if everything goes well we might get a new Sailfish OS release for FP2 next week.


#368

And as a quite early christmas surprise you will present Anbox on top, right? :wink:

No, honestly: thanks mal for all your great work on this port!


#369

I have now built and started testing of Sailfish OS 3.0.0.8 on FP2. So far all features seem to work as before so shouldn’t take much more testing before I can prepare a new release.


#370

Woaw, a major release soon available ! Good job @mal :smiley:


#371

Hello
I flashed this 3.0.0.8 version for my first flash with the FP2 and I love it ! Thank you so much !!

I just can’t turn off the FP2, I’m sorry if you answered this before.


#372

Activate the flashlight before shutting down.
Make sure the phone is not connected to USB or a charger, or the flashlight workaround might not work.
Maybe turn off Bluetooth, too.


#373

Fun workaround :smiley:

It didn’t worked for me, all radios were off, only the flashlight was on (and phone was disconnected from charger as you said). Thanks for the really quick answer anyway !


#374

Too bad.
In this case, you can reboot into TWRP (keep Volume + pressed while rebooting until TWRP is shown), and then shut down from there.


#375

Oh :frowning:
Ok, and I’ll wait for a fix. I suppose it worked with Sailfish OS v2 and doesn’t work since v3.
Thank you !

Do we have a way to list installed apps and reinstall them from the list ? To help with developpement versions, I don’t care crashing the system because my contacts and calendards are synced from CardDav/CalDav, the only time costing thing is finding the apps that were installed


#376

The inability to shutdown the device is not related to Sailfish OS but instead it’s caused by the new main camera module and occurs even in Android. In Android the workaround mentioned in one of the earlier posts does work but not sure why it doesn’t work in Sailfish OS, maybe the shutdown procedure in Sailfish OS is so different from Android that it cannot work. There is a bug about that in Fairphone bug tracker https://bugtracker.fairphone.com/project/fairphone-android-7/issue/7.


#377

Ok ! Sorry for incriminating your sailfish port. I’ll watch this :slight_smile:


#378

Initial testing of Sailfish OS 3.0.1.11 for FP2 hasn’t shown any new issues so if everything goes well it shouldn’t take long before I can make the release. Unfortunately this release is still built on top of Android 6 base because the Android 7 sources are not yet available.


#379

This is really cool :slight_smile:
May I ask if you have made any progress in the integration of Anbox?
That would make the FP2 with your great port the absolute winner :slight_smile:


#380

I looks like we might be able stop using the old firmware partition soon in Sailfish OS for FP2. If all goes well reworked proximity sensor handling is soon going to be available in Sailfish OS which allows proximity sensor to be used only when needed and it makes it possible to for FP2 to suspend normally. This wasn’t available before because normally the power consumption of proximity sensor is so small that it was easier to have it on all the time. I have tested the work-in-progress code on my device and it seems to work but it needs more testing.


#381

That’s good news @mal :slight_smile: Great !


#382

Hi everyone, I just received my Fairphone 2 and wanted to avoid Android if possible. I just installed Ubuntu Touch on it, it looks nice but definitely isn’t polished enough for a primary device. So I’d like to try Sailfish 3. Is there a tuto how to flash it on my phone? What’s the current status of it? I upgraded my phone to 19.02 on Android before removing it so I think all firmware should be up-to-date, shouldn’t they?

Edit: I found this wiki page which seems up-to-date, however, it talks about Android 18.04 when I had 19.02 on my phone, and now I have Ubuntu Touch 16.04. Do I need to reflash it with Android before flashing it to sailfish? Does Android have to be version 18.04?