English

Using Sailfish OS on the FP2 - Experiences and Issues

sailfish
Tags: #<Tag:0x00007fefbd0811f0>

#243

Yeah, it’s been working great.

Really looking forward to the new lock screen camera in 2.1.1 tho :slight_smile:


#244

@mal, I have a problem with the vibrator effect that is very weak.
I know that in the past this problem was solve (and work on my FP2).
After that I try Ubuntu, and after I install SFOS alpha3 and upgrade to 2.1.1.24 (who work great since one day).
The fix is no more on devel repo?
Can I fix that with install something?


#245

sorry after 2 reboor, the vibrator work


#246

I received my FP2 today and wanted to give Sailfish a try… unfortunately I end up with either bluescreen or an endless loading screen.

Apparently I cannot use any old Fairphone OS (I tried 16.10, 16.11, 17.04) and as mentioned before, all Marshmallow based versions are not compatible with Sailfish…

Is there anything else I can try? Flashing something on my phone is no problem, but recompiling an OS is beyond my capabilities…

My phone is from the latest batch and I understand there are some minor changes in the hardware, which seem to break compatibility with the old Android versions…?
Is there any hope for a Marshmallow based Sailfish OS might be released?


#247

Hello @Azimoth :slight_smile:
How did you try to flash these older Fairphone OS version ?
And, did you check https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2 ?


#248

Would suggest that you also read “Bug free installation” at foot of resource upon explit’s site, you can always use “Google Translate” if German an issue:
http://sailfishmods.de/2017/02/fairphone-2-sailfish-os-installieren/


#249

That sounds a lot like the problem with LineageOS and a Fairphone 2 of the new batch over here.

Keeping in mind the following …

@mal perhaps Sailfish OS for the Fairphone 2 needs some work to be done to function on the new slightly modified Fairphone 2 hardware?


#250

ced117:
I used fastboot (called from the flash.sh script. I even tried flashing only the system partition in a second attempt for each version).
Yes, I looked there and it says “start using version 16.10” (Which does not run on my FP)

aspergerguy:
Yes, I read that as well (German’s not an issue :wink: ) and it says “start using version 16.11” (Which does not run on my FP)

AnotherElk:
That what I meant. Hence I asked here…

So the SF version done by @mal is the only one available so far?
(I know that @explit works on creating a flashable image, so I thought maybe he also updated/added some parts, which might be available independently from the image, and I did not find the result via Google)


#251

Alright. Thats just strange that you cant flash that on your new FP2, maybe this new memory chip is in cause or something ?
I even didnt know that the memory chip was changed in the newer FP2.
Have you any info about why they changed that @AnotherElk ?

Yes, he’s the main porter :slight_smile:


#252

No.
Hooray for speculation :slight_smile: … They mentioned they identified need for improvement with the first Fairphone 2 batch, it could be related to that … or the memory chips used in the first batch just weren’t available anymore, stuff gets discontinued all the time …

I guess as long as Fairphone don’t give us any details on this, we won’t know.


#253

Alright @AnotherElk :slight_smile:
But yes, the problem could be related to that new memory chip… :neutral_face:


#254

If there really is some hardware change that causes only Android 6 to work on certain hardware revisions then I probably have to move the Sailfish OS port to also use Android 6 as the base. This will require patching the needed repos again and rebuilding the whole adaptation. This will of course cause some problems for OTA updates in Sailfish OS since the users will have to remember to flash the new base Android right after updating Sailfish OS since that won’t work until base Android is correct. Changing the Android base used on FP2 port of Sailfish OS was planned but not a very high priority but maybe I need to move that to higher priority now.


#255

@mal
I would highly appreciate it :slight_smile:

If it is of any use, I would keep my current phone for a while, so I could use my FP as test unit until the build stabilizes…


#256

@mal
I have no idea about the time needed for rebuilding all of SF. Are we talking weeks here or months rather?


#257

That depends on what kind of problems I encounter but with good luck it might be a week but with bad luck maybe a month. I patched the Android 6 repos already but currently I cannot get those to compile successfully, Maybe I’m missing something because the Android 6 manifest for FP2 has not been pushed to gerrit yet so I had to make one myself, it looks like some dependency issue so either I disabled some important repo or forgot add it in the first place.


#258

Just a small status update on the process of moving to use the Android 6 base for Sailfish OS. Currently only remaining issue compared to previous Android 5 based release are broken video recording and the old issue with battery drain, I need to see if Android 6 base can work with the old firmware so that can be solved temporarily while I investigate an alternative way of fixing the issue. Also the release of Sailfish OS 2.1.1 has been delayed so hopefully I get the image in working state by the time that happens.


Sailfish OS: Technical reason for older firmware
#259

Hi everybody. It’s been a few days now that I was using sailfish os thanks to Explit and his “solutions for noob” which cannot be more appropriate for me.
But because of the 2 apps hat I use the most don’t work with sailfish, I’ll go back to android for now.

BUT how ? factory reset ? re-running the Explit’s script and stopping it at fairphone OS step ?
can somebody tell me please.
Thanks a lot everyone for this very helpful thread


#260

You can install Fairphone Open OS back via recovery (by holding volume up button, usinng OTA zip) or fastboot (using “manual” zip), the images can be found from here https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html. To get back to Fairphone OS you can follow these instructions https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2


#261

thanks a lot, I was going to do this.


#262

I can’t resist and ordered the new camera modules - is it worth to wait a few more days for a new Sailfish update or will I have to flash Lineage to test them and have to return to Sailfish in a few weeks … thanks