English

Using Sailfish OS on the FP2 - Experiences and Issues

sailfish
Tags: #<Tag:0x00007fefc10ee558>

#223

Thanks a lot, I got it! :slight_smile:


#224

Hi!

Has anyone tried the latest SailfishOS on fp2-sibon-17.06.4?

I cannot find the “manual” download anywhere so I don’t know if it’s possible to upgrade
the Fairphone Open Android Base without loosing your SailfishOS -anyone know if it’s
possible to accomplish this by using the fp2-sibon-17.06.4-ota-userdebug.zip or
fp2-sibon-17.06.4-ota_from_gms-userdebug.zip?

I tried installing first fp2-sibon-17.06.4-ota-userdebug.zip from TWRP and then restoring
the Data and Boot from a backup but that didn’t work… Any ideas?

Btw, is there any way to calibrate the approximity sensor on Sailfish or do I have to run
Android to do that?

Also, after upgrading to 2.1.0.11 as @explit described above the store doesn’t work anymore
-how do I fix that?

Thanx!


#225

Sailfish on the Fairphone is Android 5.1 based. To use the Android 6.0 as base - Sailfish need to be rebuild.
Mal- said (maybe) he will do it some time


#226

Hi!

Ok, so the latest 5.1 based download must be fp2-sibon-17.04.0-manual-userdebug?

I got this sorted out -the data connection didn’t work because the SIM2 was somehow enabled
after the upgrade even if it is empty -disabling it brought the connectivity and the Jolla Store back
to life! :smiley:


#227

Yes, the last system.img (Android Base) image working with Sailfish is 17.04. But if you want working camera and video - you should take 16.10
Mal- fixed all the kernel-vulnerabilities from Fairphone Open 16.11 - 17.04 in his Sailfish Kernel, so 17.04 will not bring any advantage over 16.10, WHEN you using SailfishOS


#228

Hey guys!
I wanted to try out sailfish today. I came from FPOOS 17.06.4 (Android 6).
I did everything just as described here (https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2) under “installation steps”, including the battery drain fix.
Fastboot showed no errors. However, the phone wouldn’t boot into 16.10, I got the “loading…”-screen, but it got stuck there. Did wipe the phone with TWRP, but it still stuck on the “loading”-screen.
Any ideas?


#229

Hello @madguitar
That loading screen you are talking about, it’s when Android is loading or what ?

And, where did you stop exactly in the how-to ? Just before the “Sailfish OS installation” part ?


#230

Exactly, my last commands were
fastboot flash system system.img
fastboot flash recovery recovery.img
fastboot reboot
got no errors from fastboot, device rebooted, but it didn’t boot into Android 16.10, it hung on the loading screen for several minutes, until I gave up.


#231

@madguitar Just ignore that issue and continue the “Sailfish OS installation” section.


#232

It works. Thank you very much!


#233

@madguitar No problem, have fun with SailfishOS :wink:


#234

I added the long overdue release of Sailfish OS 2.1.0.11 alpha4 to wiki https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2. This is an OTA-only release so no new installation zip this time. In addition to the fix of the LED regression seen in alpha3 this release only consists of the new Sailfish OS version and some kernel security fixes.


#235

Thanks for all your work to port Sailfish OS to the FP2 :slight_smile:

I am using Sailfish OS on my Jolla tablet and I really like it. It would be great to have the same on my FP2, including the possibility to install Android apps (where no appropriate app is available on the Jolla store or warehouse).

So I was hoping for official Jolla support for the FP2. As this doesn’t seem to happen, I wonder how are the chances to get Anbox working on sailfish OS?


#236

There is currently some issue in the Sailfish OS port of Anbox with all devices using kernel version 3.4 which makes it fail and that needs to be fixed. Probably some missing container feature or some other missing patch from the kernel. But in general it might be possible.


#237

Hi @mal. thanck you for all your work on SFOS porting.
I have two questions :

  • what’s your project for the futur, will you still work on SFOS for FP2? Or like other (for exemple @explit ) will you go on xperia, or other?
  • I still have the issue of crash of screen after a call, the tactile function of the screen is deactivated after a call (in french :la fonction tactile de l’écran est désactivée après un appel). Is it normal?

#238

I have no plans to stop maintaining the port Sailfish OS for FP2 any time soon. The loss of touch control after calls is in my opinion a problem with the proximity sensor, have you tried calibrating it?


#239

Well, Thanks Mal, that gives us hope. You are a very good guy, and you do a monster-job developing and maintaining the fp2-sibon SailfishOS Port. But you are alone. And this makes me very sad.
I know you are very active in the sailfish-porters channel on Telegram / IRC. And i hope you guys (who is familiar with SailfishOS Porting) will help each other…

Lets hope things are not getting worse. This is my only hope…


#240

Thank you it’s good to heard.
Ok I will try to install Android, calibrat proximity sensor and install SFOS.
Should I install FP2-gms59-1.5.1-manual befor calibrating?

Another question to @mal Did you use Halium or will you use halium in futur for SFOS port?
It is useful?


#241

Proximity sensor calibration requires newer Android and firmware files, you should install at least 16.10 or even newer and after reinstalling (or if you do not format data you can only reinstall sailfish boot.img to get Sailfish back) you need to install back those old firmware partitions from 1.5.1.

About Halium, I haven’t decided if I will at some point move to Halium or not. So far nobody has used that with Sailfish but it shouldn’t be impossible but might require some modification of the Sailfish boot scripts.


#242

I just updated today to OTA-alpha4 successfully :slight_smile:
I followed the wiki instructions; I had to remove (ssu rr) adaptation0, extra (not necessary since adaptation-community and adaptation-community-common) and store (‘not found’ message)
Thank you for your work, @mal !

Also, I configured successfully CalDAV/CardDAV synchonisation with my ownCloud server.
For future memories, here is the procedure (owncloud 9.1):

  • Settings > Accounts > Add account > CalDAV and CardDAV
  • Login and password of the owncloud instance
  • URL: https:// my-instance-of-owncloud /remote.php/dav/ (it wasn’t working without the remote.php…)

EDIT: and I also flashed the SailfishOS splash screen of @explit :grin: