Using Sailfish OS on the FP2 - Experiences and Issues

not juste in your eyes. I want another says thank to mal

1 Like

Mal- is not only working for the community, he is a main SailfishOS on the Fairphone 2 Porter. Without his work we wouldn’t see any running SailfishOS Builds on the FP2.

Wow, I already expected something like that… :open_mouth:

I want to donate a little money to him because of his great work and his kind support inside the forum! Maybe we can crowdfund a little bit? Just to say thank you, because such an amount of work of course is not self-evident…


There are many people who want support Mal- with a donation (including me)

As far i know Mal- don’t use PayPal (maybe it will change in the future)
Well, i’m not familiar with other donation tools like Flattr or something else…

I asked Mal- many times how the community could help / donate / support him.
But i didn’t got an answer :frowning:

I also think its a huge amount of work. i’m very happy that Mal- is such enthusiastical and and perfectionist person.
Lets hope his enthusiasmus will last for a while!


Hi all,
I also tried to install Sailfish OS alpha 2 on my new Fairphone 2 using fastboot.
I am stuck at:
fastboot flash userdata userdata.img
I get the error: FAILED (remote: Bogus size sparse and chunk header)
finished. total time: 27.525s

When I first started my phone I updated to Fairphone OS 1.8.1 using the updater app. Then I installed Fairphone Open 16.10.0 using the updater app ass well. This all went fine without any problem and the phone also worked nicely with the opensource OS.
I put my phone in fastboot mode and tried to install Sailfish OS 20.01.11-alpha2 following the steps described in
My phone was recognized by fastboot, but at fastboot flash userdata userdata.img I got the error.

Now I reinstalled Fairphone open again, but this time using fastboot. No problem.
When installing Sailfish again I got the same error.
Then I went back to the normal Fairphone OS 1.8.1 and tried the procedure described by @Bobbel. Still the same error. There seems to be a problem flashing userdata.img because other files can be flashed without a problem.

I already searched the forum for a solution, but unfortunately I could not figure it out.
Does anyone have any idea what I am doing wrong?
I am using fastboot on a Mac.

Thanks a lot for your help!

Why are you using the fastboot method when you could install Sailfish from TWRP recovery using the other zip file mentioned in the wiki? I have also noticed that the fastboot method sometimes fails, not sure if it happens when you have too new Android installed on the device, I need to investigate what is causing that. I consider the recovery installation as the preferred method.

I had the same issue with the fastboot install route when I tried this for the EFCT16 Software workshop. In that case I first downgraded from 1.5.1 to Open 16.06 (which is listed on the wiki as having been tested). So it’s not directly related to the version, though it could be that something was changed when 1.5.1. was installed that is not undone by flashing Open 16.06.

The TWRP route worked perfectly well.

Thanks for the replies!
Actually the reason I used the fastboot method was that I didn’t know what TWRP was and how to use it. The fastboot method seemed quite straight foreward. I will try the TWRP method.

IT worked! I managed to install Sailfish OS using TWRP. Very easy actually :slight_smile: Thanks for the suggestion!

Could it be that adb/fastboot is generally (somewhat) unreliable on FP2? The dev of the magic-device-tool mentions this in the comments-section of this video about the tool:

and this lack of reliability seems to be the main reason, why the UBports community port of Ubuntu Touch for FP2 does not work properly atm… (?)

I don’t recall encountering any other issues with adb/fastboot when I was playing around with it on the community Fairphone, it was just the Sailfish image which failed twice. Then again, I didn’t do that much adb/fastboot stuff, so I can’t rule out random failure either.


it’s great to see that SailfishOS is actually used.
I would like to know if SailfishOS for fp2 is still in active developing, because the status on Merproject hasn’t changed awhile.
I’ve a strong interested in dual-SIM support, therefore I’m waiting for the next release.
Does anybody know if there’s any hope for it?

Thank you in advance!


I will hopefully have time to make a new release soon, if no blocking issues are found or other delays happen then next week would be possible. It’s already possible to use the latest version (which includes dual-sim support among other things) by updating using devel repos.


Hello ! Yesterday I tested the SailfishOS alpha2 on my FP2, with the TWRP installation (on top of FPOpenOS 16.10) and it worked flawlessly, indeed the TWRP installation is really easy :slight_smile:

After that I’d like to update from to the latest version available (a.o. to get dualsim support), but I didn’t completely understood the OTA paragraph in the wiki… There is a list of command-line instructions, should they be typed in Sailfish’s terminal, or on my computer with the FP2 connected? From what I read above, the depo name has to be adapted to sailfish_latest_armv7hl in order to have the good version, correct? Is there a possibility to make a batch file with these instructions?

Thank you for your work!

The commands for the SailfishOS OTA Update should be entered from the Sailfish Terminal.

If you alredy have SailfishOS on your FP2, start it, connect to your Sailfish-FP2 with ssh from your computer, so you can easy copy and paste the commands in the ssh terminal.

if you have Windows PC - you can use the Program Putty to create an ssh-connection to your FP2, if you have MacOS or Linux, you can enter ssh from the Terminal.

Batch file is not possible, but if you write me an email on explit(at) i can send you a good PDF-Manual, which i have created for installing and updating SailfishOS to


Thank you for your fast answer and your work!!

1 Like


I’ve been running SF on top of fp-sibon-16.10.0 for some time now and here are my observations:

  • rear camera not working (front camera does work)
  • sometimes no audio on incoming calls (usually re-dialing helps)
  • random screen lock-ups (sometimes pulling down with three fingers -gesture repeated a few times helps)
  • dual-sim support seems to be available but I haven’t tested it yet

So, not perfect but pretty good overall already! :+1: :grin:

Does anyone know a method for upgrading the Android stuff without wiping and having to re-install SF after?

Keep up the good work!

I hope you used the devel repos (right now also testing repos work as I’m preparing a new release) when updating to Both cameras should work fine. I haven’t heard of any audio problems during calls, if that happens please get output of journalctl -a and /usr/libexec/droid-hybris/system/bin/logcat, same if latest packages from devel or testing repos still have camera issues. Depending on when you updated from devel repos the last time the latest packages in those repos may have many additional fixes. Android base can be updated by downloading the manual installation version of fp2-sibon, extract the files from the zip and flash only the system.img using “fastboot flash system system.img”.


Thanks for the quick reply!

I upgraded to system.img from fp2-sibon-16.11.0-manual-userdebug and also updated the latest packages from the devel repos -now both cameras seem to be working and no issues so far! :relaxed:

Still need to find a way to install sfdroid -any idea how to accomplish that?

That is ok, but you also need to use devel repo and update to the latest adaptation to get all the new stuff, which Mal- has implemented.

Look in the System Settings about the Phone: Which adaptation do you have?

For today, 28.11.2016 the last adaptation
for Sailfish is
for Sailfish is

If you don’t know how to use the devel-repo - please contact me over email (explit at
I will send you the Sailfish maintance manual, which i have created

I have sfos and adaptation
what is wrong?