Using Sailfish OS on the FP2 - Experiences and Issues

New camera module and the display module in the latest FP2 devices need Android 6 base to work. I encountered a very serious bug that is currently preventing me to release the new version. The issue is a kernel panic when initiating Bluetooth scan, but otherwise Bluetooth seemed to work though. Hopefully I can figure out what is causing that.


I do not know if it is relevant, but reboot issues have been reported in Lineage OS especially when Bluetooth is enabled:

A little update for the new year, I managed to work around the kernel panic issue when doing bluetooth scan by using a very old modem firmware from Android 5 base, it seems to be working fine otherwise also, I did encounter a small issue with youtube in web browser (seeking in videos causes browser crash) and I’m currently thinking whether to figure that out before release or not. I will do some testing to see that I don’t notice any other issues.


@mal: From my point of view it would be fine to wait for that fix as seeking it videos will probably affect many users. However, I have a brand new FP2 that I am not using as I am waiting for SF so I could test whatever you have now if you want. Maybe I find more issues you want to tackle before releasing it. :wink:


Hi all!
I try Jolla Sailfish on my FP2, thanks to the work of @explit , and I like the feeling and the gesture philosophy of the OS.
What I don’t like is that I can’t use properly all the apps based on Google Play Services.
Nothing new…
I have tried to install microG but I was not succesufull because I can’t obtain the spoon signature because I can’t access my SF phone with ADB in order to patch framework.jar with needle or tingle.
Did anyone successfully installed microG on a FP2 with SailfishOS? Is it even possible?? I read something about Alien Dalvik VM which could make the patching of framework.jar impossible: is it true?

Thanks so much for your help.

P.S. BTW now I have turned to LineageOS, waiting for help. Also here I have some problem managing microG and I went with openGapps.

You nmght want to try the LineageOS fork incl. microG:

Works fine for me.

1 Like

Up until now it is my understanding that even if on the Fairphone 2 Sailfish OS installs require a certain Android OS version present on the phone, Sailfish OS is not Android, and Android stuff (like any Android App or stuff intended for Android like microG) by simple logic will not run.

However, there’s a commercial product by vendor Myriad called Alien Dalvik that provides an Android environment in Sailfish OS enabling you to install Android stuff and run it.

Catch no. 1: With Alien Dalvik being commercial, somebody has to pay for it. Vendors of Sailfish smartphones do that, and so you get Alien Dalvik and thus Android support on their devices. There is no such support for the Fairphone 2 currently, and Myriad don’t sell to end customers.

Catch no. 2: Alien Dalvik simulates an Android up to version 4.4 and no further, because Dalvik itself is not present from Android 5 on.

If your focus is on microG, then @BeMiGro had the right hint for you.
If your focus is on a non-Android OS perhaps running Android Apps nonetheless, UBports from the 16.04 base on will come with Anbox.


Thank you both for the quick reply.

@BeMiGro: I’ll try the LineageOS version with MicroG and I’ll let you know. Thank you!

@AnotherElk: I’m quite aware that SailfishOS is not an Android OS. Nonetheless, as you said, the @explit version provided here is capable of running Android apps. So I was wondering if anyone succeeded in installing MicroG on Sailfish as showed here and here but not on FP2. As I said in the post before I couldn’t get spooned signature to work.
Due to what you say in no. 1 and to avaibility of Android apps in @explit Sailfish version for FP2, it’s not clear for me if that version support Alien Dalvik. If yes how can I run MicroG on it? If no I can’t understand how Android apps can work.

My goal would be Sailfish with MicroG because I love Sailfish interface, but I need some Android apps. In the meanwhile I think I’ll turn to LineageOS with MicroG.
UBports with Anbox seems to me a good solution but still far to come.

Where does it say that and how would it do that without Alien Dalvik for Android 4.4 Apps or a theoretical (non-existing) Alien ART for Android 5+ Apps?

Perhaps @mal could say something definitive about that, as I definitely lack insight here.

Up until now I took it that the way Sailfish OS is installed on the Fairphone 2, based on an existing Android installation, doesn’t mean that once Sailfish OS is installed you additionally have a fully functional Android somehow in the background or else where you could run Android stuff.

1 Like

hello all!
First: This version is not mine, i packaged it only. Alien Dalvik is an commercial product. It has NEVER exist in this SailfishOSversion, will never exist, and i will not discuss about it in the forum.
So please, stop discussing about a commercial product, for which you have no license.
if somebody of you guys has an aliendalvik in the Sailfish image, its an mistake - please uninstall it with

zypper rm aliendalvik

Otherwise you use illegal Software on your Fairphone 2

By the way, i have no Fairphone 2 anymore, switched to Sony Xperia X with SailfishOS and legal AlienDalvik.
I waited very long for official SailfishOS with Aliendalvik for FP2, but it never came out.

So i don’t maintaine this build anymore. without a device its impossible.

I wrote alredy on another place in this Forum: If the Fairphone Team or community want that i will maintain Sailfish Installation, images, manuals etc. - all they need to is to send me a device.

i hope its clear now.


Hi all,

I’m new here, and i’m planning to buy a fairphone specifically to run SailfishOS on it. I own a Jolla phone now and need a dual-sim phone.

I’m a bit confused with the messages here, does SailfishOS run in the current fairphone model ? I don’t mind a bit of fiddling, but in the end I need a phone that works (call, sms, calendar+caldav, sync, notes are my main apps).

Thanks for all the work so far !

1 Like

Also be aware that Sailfish OS on the Fairphone 2 is a community port and as such doesn’t include (as in: currently no way to get it) Alien Dalvik to run Android Apps.


Thanks for your reply AnotherElk. I don’t care for android at all, it’s one of the main reasons i use SailfishOS :slight_smile:

@mal I’m quite experienced with linux related stuff and made some SailfishOS apps, is there something i can help you with ? (given the fact that i don’t have a fairphone yet).


I am not using SailfishOS myself, but I would like to support @explit and @mal’s efforts. So I would be willing to contribute 10€ to a “crowdfunded” FP2 for @explit. If you are interested too, please send me a personal/direct message. If a few people a interested, I will set up a separate thread for the funding. I would be looking for a used Fairphone offered here in the Forums.


Mi Nickname is “ExPLIT”, not Explicit , btw. :slight_smile:


In the meanwhile I bought an Xperia X and made SailfishX my main phone for time being.

After 3 days, the experience has been quite smooth. It’ll be interesting to see which modern Sony device they will be supporting this year. Maybe it’s not worth it to work on FP2 anymore and just leave it to Android.

1 Like

2 posts were split to a new topic: What is really off topic?

Count me in! Some more people are needed, though :wink:

1 Like

I think some users bought the FP2 because of Sailfish OS. Cancelling the adaptation of an official Sailfish OS will disappoint those users.

We don’t kick out users because they are not using a Fairphone. Maybe they have good reasons not to use a Fairphone.

And when they tell their experience with other devices, we can refine our goals and wishes for FP2 and future Fairphones.


There seems to be nothing official going on anymore as far as I could find.
Sailfish OS on the Fairphone 2 is a community port, and Fairphone and Jolla had talks but didn’t reach an agreement.

… and that was November 2016.

Honestly, I tried Sailfish OS on my Fairphone 2, and it was running very well and was a nice OS and all, but it really finally died as a future option for me personally the moment I found out Alien Dalvik - which isn’t even available with the community port - only would run Android Apps in a simulated Android 4.4 and no further (for understandable technical reasons though).

If I would have to look beyond my current LineageOS installation now, I would certainly look into the UBports (ex Ubuntu Touch) direction instead. But LineageOS is behaving too well for that at the moment :slight_smile: .