Using Sailfish OS on the FP2 - Experiences and Issues


What is the latest and greatest combination of FPOpen + Sailfish images known to work at the moment?

I would go by what this page says, building on that base you are free to experiment :wink: .

Yeah, the wiki is a good starting point.

But where can I see where the latest development is at?

Any chance to already try out Sailfish OS 2.1.0?

Yes, it is possible
i think you should pm @explit and ask him for the sf pdf

1 Like

# Be carefull, make an TWRP-Backup before

cd /usr/share/ssu/features.d/

# Edit the both ini-files

nano adaptation-community.ini

# Change the line adaptation-community

adaptation-community =

nano adaptation-community-common.ini

# Change the line adaptation-community-common

adaptation-community-common =

ssu re
ssu ur
version --dup
zypper ref; zypper up

Note: Some patches or appls may prevent all components beeing updated. If you got the message, that some packets could not be installed, because they would brake dependencies, you need always choose to remove the packets, blocking the update.

Afterwards you can look, how you will install them again.
Iportand thing is, that all packages from are installed.

# I hope, i wrote anything correct here, @mal, please correct me, if something what i wrote is wrong.
Thanks !!


At the moment i have SailfishOS on top of Fairphone Open 16.10
Anything working stable


2 posts were split to a new topic: SailifshOS on the Fairphone 2 - Images for installation

A post was merged into an existing topic: SailifshOS on the Fairphone 2 - Images for installation

Thanks for this! I did the same experience and I would love to use Jolla Sailfish. But without a MS Exchange able mail app it si simply not possible for me. I urgently need this for the next couple of years (including agenda synchronization!!!). I hope some relevant guys read this… Thanks in advance!

Write me an email on explit (at)

Done a week ago, didn’t it arrive? :wink:

I try to answer every request and everybody who write me - i put in the Distribution group. But maybe i missed you somehow. Please send again.

Thanks for this! You asked me earlier to write you an email message, but I actually do not really know, what I should tell you in addition to what I wrote there about Jolla Sailfish, sorry :wink:

I especially miss an email client for MS Exchange. And I also miss F-Droid in the Sailfish store, although it says somewhere it should be there.

Perhaps my message stranded in the junk?.. I will also try to send it from another account.

Thanks, Urs

1 Like

Please check your email.
If you have some questions - please contact me over Telegram (@explit)

Thanks a lot, I got it! :slight_smile:


Has anyone tried the latest SailfishOS on fp2-sibon-17.06.4?

I cannot find the “manual” download anywhere so I don’t know if it’s possible to upgrade
the Fairphone Open Android Base without loosing your SailfishOS -anyone know if it’s
possible to accomplish this by using the or

I tried installing first from TWRP and then restoring
the Data and Boot from a backup but that didn’t work… Any ideas?

Btw, is there any way to calibrate the approximity sensor on Sailfish or do I have to run
Android to do that?

Also, after upgrading to as @explit described above the store doesn’t work anymore
-how do I fix that?


Sailfish on the Fairphone is Android 5.1 based. To use the Android 6.0 as base - Sailfish need to be rebuild.
Mal- said (maybe) he will do it some time



Ok, so the latest 5.1 based download must be fp2-sibon-17.04.0-manual-userdebug?

I got this sorted out -the data connection didn’t work because the SIM2 was somehow enabled
after the upgrade even if it is empty -disabling it brought the connectivity and the Jolla Store back
to life! :smiley:

1 Like

Yes, the last system.img (Android Base) image working with Sailfish is 17.04. But if you want working camera and video - you should take 16.10
Mal- fixed all the kernel-vulnerabilities from Fairphone Open 16.11 - 17.04 in his Sailfish Kernel, so 17.04 will not bring any advantage over 16.10, WHEN you using SailfishOS


Hey guys!
I wanted to try out sailfish today. I came from FPOOS 17.06.4 (Android 6).
I did everything just as described here ( under “installation steps”, including the battery drain fix.
Fastboot showed no errors. However, the phone wouldn’t boot into 16.10, I got the “loading…”-screen, but it got stuck there. Did wipe the phone with TWRP, but it still stuck on the “loading”-screen.
Any ideas?