Using LineageOS on the FP2

5 posts were split to a new topic: Xposed on LineageOS

Is anyone able to get an IPv6 address via tethering? This worked for me in FP Open OS, but seems broken on LineageOS.

My provider offers IPv6 which works fine with the phone itself (after configuring the APN settings to use dual stack), but the devices that connect via tethering cannot get an IPv6 address.

1 Like

Slightly off topic: In Fairphone OS (with GMS) IPv6 tethering once used to work, but is broken since the Android 6 upgrade.

Did this work for you in the Open OS even after the Android 6 upgrade?

1 Like

I’ve been abroad during the summer and could not test it (provider did not support IPv6 on pre-paid plans :sob:). It worked in FP Open with Android 5 though.

So I guess it’s save to assume that this only worked in Android 5 (FPOS / Open OS) and is broken in both Android 6 (FPOS / Open OS) and 7 (LineageOS).

Progress, yeah! :worried:

1 Like

Yeah, it’s still an issue on my phone. I also have the latest October build.

I still also have a big problem with random reboots, especially in the middle of the night because the ticking sound and screen lighting up on the encryption unlock wakes me up. @chrmhoffmann @snevas Is there anything I could look for in the last_kmsg.txt file that would show me the cause of this?


Yes, it’s still the same. Luckily not a very troublesome problem.

I also suffer from reboots during the night. I don’t know what triggers them, (I suspect it could be Telegram delivering a notification, but I am not sure). It happens during the night, without flight mode and not connected to a charger. I am on the latest build from October 4th with modem files from 17.9.3.
Can I provide some helpful logs or so?

Yes, please always attach /proc/last_kmsg to any reboot issue reported. Otherwise we can’t do anything at all.


PS: not sure if we can do anything if there’s last kmsg but without it’s clear we can’t.

1 Like

I’m having the same problem!
Phone is rebooting instead of powering off.

Just got a new Fairphone 2 (new camera modules) and auto-updated to the newest Fairphone OS (FP2-gms-17.10.1), which should get the modem also to a recent version I guess. “Power off” worked fine!

Then I installed twrp-3.1.1-1-fp2.img and from here:

Reboot into recovery (tested with TWRP 3.1.1-1) and choose “Power off” in recovery.

1 Like


I am sorry for my English which is very bad (I am french).

I received my FP2 on October 4th and I installed twrp-3.1.1-1-fp2 and lineage-14.1-20171004-UNOFFICIAL-FP2.

I have the same problem as you:

  • Random reboot (even without using it).
  • The phone restarts when I turn it off.

Concerning the problem of random reboot, for my part, it does not reboot at night with the airplane mode activated.

I can not find the file / proc / last_kmsg with adb:
“adb shell cat / proc / last_kmsg
/system/bin/sh: cat: /: Is a directory
/system/bin/sh: cat: proc: Is a directory
/system/bin/sh: cat: /: Is a directory
/system/bin/sh: cat: last_kmsg: No such file or directory”

It is cat /proc/last_kmsg (with the only space being after cat).

With the spaces, you try to cat / (which is a directory), then proc (which is a directory), then / again (…), then last_kmsg in the current directory (where there is no such file because it is in the proc directory).

Thank you.
Sorry, I’m really bad.
This is: adb shell cat /proc/last_kmsg

The file is attached:

last_kmsg.pdf (166,2 Ko)

No worries …

  • We were all really bad at this computer stuff once.
  • I’m bad with [insert name of poor little plant barely scraping through life in the corner of your room] instead.
  • I can still remember when I was bad with … wait … now I feel old. Sad.
  • Ooooh … a poll!
  • “Who’s BAD?”

0 voters


Have you noticed problems with the focus of the new FP2 camera? Since I switched to the new FP2 camera, I have the feeling that the autofocus does not work optimal.

(14.1-20171016-UNOFFICIAL-FP2, Baseband 4437.1-FP2-0-07)

Problems in general, or in panorama mode?

I think I have a similar problem. Every picture I take seems to be slightly out of focus.

EDIT: The problem seems mainly to occur with ‘OpenCamera’. In the Lineage Camera App the focus works fine and the picture is taken much quicker.

EDIT2: Figured it out… For some reason the scene mode was set to ‘HDR’ (under SCENE MODE… not ‘Photo Mode’). After switching to ‘Auto’, pictures are in focus and taken much faster also in OpenCamera


I think problems in general. Is there any fairphone reference images of the new camera for comparison?

For the poeple watching this topic. See this annoucement:


how can I reliably remove root/su so that I run my banking apps on LineageOS?
Afterwards I will try to install systemless Xposed by means of Magisk as Xposed is now released for Android Nougat.