Using LineageOS on the FP2

Another thing i noticed: in notification settings, advanced, i have the possibility to define a special pulse setting for led notifications per app. I looks like this doesn’t work yet (like LED while charging, but this is known)

Hi François!
I use LineageOS without OpenGApps (I have MicroG), and I confirm: Whatsapp is running well :slight_smile: I installed it with an APK file…

On UbuntuTouch, an app compatible with Whatsapp is developped: Loqui IM. Did you test it already?

2 posts were split to a new topic: Battery life in LineageOS

Today i was riding the train, using mobile data. While entering a tunnel that is providing mobile data also (repeater, provider? Don’t know), ii lost access to it mobile data, and i couldn’t get it back neither switching days off and on, nor entering airplane mode. In the end, only a reboot restored mobile data, and i tried quite some time…


Yesterday I installed Lineage OS on my FP2 for the first time and was disappointed when I realized that Xposed isn’t supported -and I got addicted to GravityBox over the years. So I searched the internet and found this:

and this:

Today I installed both and as of now -5 hours and some testing later- it’s working all fine so far.

This might also be of interest for some:


Hi, I tried to change the DNS servers by longtapping ‘Wifi’ in Settings (following this thread: Living without Google 2.0 - A Google free FP2), but that didn’t work.

Does anybody know how I can change the DNS servers in Lineage?

tnx :slight_smile:

  • Go to Settings > Wi-Fi
  • Longtap your Wi-Fi connection and select Modify network
  • Click Advanced options
  • Scroll down and select IP settings: Static
  • Scroll down and set DNS 1 and DNS 2

Hi @_Chris, tnx!

I must admit that I didn’t read the thread very well :blush:. Still, I can’t change the DNS server. I think I did it right this time, but I couldn’t SAVE the new DNS servers. The possibility to SAVE is changed automatically made impossible when I change the IP tables to ‘Static’.

So, it could be that I did something wrong or it’s something else. I tried to find out what could be the problem. On I found this:

DNS problems
Since Android 6.1.x you only can change the DNS for tether device and nothing else, everything else get ignored, no matter what you set or which app you’re use”

If I understand this well, it’s just impossible to change the DNS on android 7 (exept for tether). That could be an explanation why I couldn’t change the DNS server?

If that’s the case, the only way to use another DNS server is to set the IP-tables in this way (same github thread):

"Or via AFWall+ custom script:

$IPTABLES -t nat -A OUTPUT -p tcp --dport 53 -j DNAT --to-destination || true
$IPTABLES -t nat -A OUTPUT -p udp --dport 53 -j DNAT --to-destination"?

Or is the solution to install another app to change the default DNS?

tnx again!

btw my proxy setting in Wifi Settings is: “None” and my Binaries Preferences Setting/DNS proxy in AfWall+ is: “Disable DNS via netd”.

Did you enter an IP address and Gateway? These DNS settings work only for static IP, so you need to enter your IP address.

On the other hand, the default is to use DHCP instead of static IP, and in this case you cannot set a DNS server address. But as far as I remember (someone may correct me if I am wrong) the DNS server configured on your router is used when DHCP is enabled.

1 Like

One more issue I face: Every now and then, I have no internet connection- Both Wi-Fi and mobile internet. It shows that it is connected , but upon opening a browser or any other program, the internet connection fails. A restart solves the problem. It happens every now and then.
I did reset the Network settings. It did not help.

1 Like

I have this problem aswell. I think it maybe, when I have wifi on, then it disconnects (for whatever reason) and then it does not connect over mobile internet (maybe because I said prefer wifi). So it tries wifi and ignores mobile internet eventhough there is no wifi connection. But this is just a theory.
What I do: either try and get wifi back or restart. Turning wifi off sometimes helps.

1 Like

Xposed not being officially supported is the only reason why I switched back to FP Open OS.
I do need “This App will run without Google” but it looks as it is not supported (yet) …

Coming back to battery usage… I did some experiments.
After reboot, and after an uptime of 4 days, I recorded actual cpu frequency every 10 seconds, while doing basically the same thin (reading text with an elaborated rss reader, which basically is scrolling, text display and internet, with all my background processes untouched).
The script is this:

while :
  s=$(date +%s)
  for i in $(echo /sys/devices/system/cpu/cpu?/cpufreq/cpuinfo_cur_freq)
       echo -n "$s;"
       cat $i
    sleep 10

Which gives up to 4 values per query. Reformatted with a small perl programm I create a csv (available on request, 24lines), which I then import into oocalc for a diagram (phew, quite some complicated massaging… ;-)) Here I can see that

  • cpu generally runs faster
  • more cores are active
    after some days.

After the reboot:

After 4 days of uptime

Additionally, after reboot the charging current varies between 500 and 700 mA, after 4 days I only get a maximum of 400mA…



Was this added? Im still experiencing low microphone volume in some apps (whatsapp and the native recorder for example)


I finally installed lineage OS yesterday. Everything went pretty without problems with the explanation here in the forum. I went by the FP open os way to have twrp! I’m definitely not an expert but this was pretty easy!

After one day using lineage it was definitely a good change! Any problem so far with anything!!

Just that I need g-sevices only because of GPS and signal app is annoying. Last time that I had FP open I tried unified and microg but I didn’t achieve to make it working. So opengapps was the easier option for the moment.

I have one question regarding the battery demand. For me its going down more or less fast… And as before I noticed that somehow WiFi seems to be active all the time (or my suspision is that just the colours are reversed, as it was on for the time its shown white down, and switched off for the green area…)

Any ideas??

Please have a look at this thread.

It seems that using the handsfree works much better. Hopefully it will be fix in the next version.

So I went back to LineageOS.

Somehow network reception in my Fairphone Open OS did manage to regress to the LineageOS level lately, and Fairphone Open OS 17.08.1(.1) introduced random reboots to my phone, which I could fix by flashing 17.06.4 modem files … but anyway.

As a trade-off (I guess) my compass in LineageOS did manage to regress to the Fairphone Open OS level, so I have to calibrate often again.

At least everything is more logical this way.
Now trying 17.08.1 modem files with LineageOS, so let’s see about these random reboots …

Can’t help you with GPS, but you definitely don’t need Google Services for Signal. (I have run Signal w/o Google (or surrogates) for several months now.)

Right, to use Signal on a phone without Google services, just d/l it from here: