Using LineageOS on the FP2

But you have to keep an eye on the modem updates and flash them manually.
Isn’t it possible to include them in the built? Or is that a question of license?
I did not examine, but I think, official LineageOS builts include the modem files,
don’t they?

I bought a used FP2 with lineage os. for the time being, it would like to use it with fairphone os. How do i switch it back?

Boot to TWRP, do a factory reset there and flash the “binary image” from here with fastboot.


I downloaded the to my phone, backed up my data and cache via TWRP, wiped my phone, installed Lineage, and although I get the line “E:unknown command [log]” in succession, rebooting the system and getting Lineage to go worked fine. however, restoring the data in TWRP and rebooting the system gets me stuck in the Lineage booting screen.
can anyone help me with that issue?

Are you trying to use the FPOS data with Lineage? I don’t think this could work.

1 Like

I hope with “the data” you don’t mean your files (pictures, downloads, ringtones etc.) in Internal Storage as TWRP doesn’t backup those, and explicitly states this when backing up … you need other means for backing those up before wiping them, e.g. syncing them to the internet or locally (MyPhoneExplorer works great).

Out of curiosity I’m checking out LineageOS at the moment, so far thumbs up :+1: .

Fairphone Open OS (Android 6) has a stock voice dial App (German: Sprachwahl). That App is gone after installing LineageOS 14.1. It doesn’t matter much to me whether that’s a LineageOS or Android 7 thing,

Edit: Fairphone Open OS (Android 5) had a stock voice dial App (German: Sprachwahl, I just checked with a restored backup and it was gone already in Android 6). I don’t need the App currently, but just in case:

What do you use as an alternative for voice dialing in LineageOS?

1 Like

no, I actually backed up my data to the internal storage, so I am aware of that. with “data” I meant apps, my settings and profiles within them, text messages, and so on. anyways, I’ll go back to FPOS, try MyPhoneExplorer and then do the whole thing again. thanks!

My experience so far:
I have now been using Lineage OS for more than 4 weeks at a stretch ever since I got my display. I am very happy with the OS…

The only things not working for me:

  1. Very loud In-Call volume on the lowest setting (not Lineage related)
  2. Very fast battery drain (only after the latest update, the settings show normal usuage, no particular app using too much battery)
  3. Wi-Fi and LTE have an x sign most of the times, but they still work.
  4. Crazy, hypersensitive touch screen and proximity sensor (also only after the latest update)

Thanks again to the community for making it possible to have an awesome OS on the FP2!


Maybe you could try a few days without gapps installed. I have not such a battery drain.
I have lineageos, f-droid priv and microg flashed. Not much background trouble.
And I have wifi and bluetooth always enabled. I feel, the google services take a lot of
I don’t want to pull you into google-free, it always depends on what you want to do with
your device. I have all my usecases complied. And I call myself a power user.

1 Like

No battery drain with newest Lineageos on my side either. But without Google stuff.

Everything works as far as my demands go.

When the LED notifications (charging state etc.) get fixed next I’ll be totally happy with it.


Thanks mase. I have never had gapps on my FP2 ever since Fairphone Open was released about 1 year and 3 months back. Prior to that I had disabled google services. So, that could not be the case.
I also use the Energy Saving profile under batterie. Wi-Fi is always off when I leave my house. And still, my FP2 lasts half a day. As I said, this is only since the latest update…

Try leaving the battery out for 5 minutes to reset the battery stats and clean your (dalvic) cache through TWRP. Maybe this will help.

Thanks. I did that. Very minor improvement. :frowning:

After the last update the WLAN-search was reactivated. After disabling it (Settings -> Location -> Menu -> Search -> Disable WLAN-Search) my battery drain isn’t that high anymore.

The start post is quite dated as most issues described there are fixed in the OTA release.
Can you update it?

1 Like

Well I don’t think it’s a good idea to maintain two posts/wikis that both list the same stuff, so I edited the post to make it more clear where to look for an updated list of issues. :slight_smile:


Weather provider or settings problem:
When I installed the older build from here I had it quickly configured so that the lock screen displayed the current weather of my user-defined location. I thought that was quite neat.
Now that I’m on the newer OTA build from here, I somehow fail to recreate that.

I once again installed the OpenWeatherMap weather provider for LineageOS, I once again added that to the clock’s Widget settings, I once again added my API key for OpenWeatherMap, waited for it to be verified, and now I’m stuck with a problem:

I can’t enter a user-defined location anymore in the Widget settings.
Everything I enter there almost immediately throws a generic “location could not be determined” (if that is the English localization) message, the same that you get in map Apps still having to fixate your location.
With the older build, when I entered a city, I would be given a choice of locations if there were more than one places matching my input.

Has anybody got anything like this working with the OTA build?

Edit: Never mind, I uninstalled the weather provider, installed it again, and now it works :+1:

Just a quick message: yesterday I did a travel by car with OsmAnd~ navigation and it was a pleasure! The experience was awful in FP Open, with reboots, overheats and incorrect compass. Thank you all for the awesome work, :blush:


Hi all,

three hours ago I started encrypting my phone. It said it would take more or less 1 hour. Now it seems to start up again and again. Is this part of the normal process and should I wait some time more or should I break up the process of encrypting?

tnx :slight_smile: