English

Upgrading LOS for microG to 15.1 (feedback/issues)

I don’t know about 15.1 but on 14.1 you can just grab UNLP backends and Aurora Store from the other included non-material design play store or F-Droid. AFAIK its all this there after 15.1 upgrade. I do get Play Store errors sometimes (since a few months) and still do on 15.1 it seems but that’s about it. The rest all works (on 14.1; not tested 15.1 well enough to say). I’m not sure what I’m missing out on. Google Sync adapters, for example, no idea what that. I don’t want to sync anything with Google. I use DAVDroid instead, and am trying to migrate as much as I can away from Google and other proprietary cloud services and as much as I can from the GPS. If something’s available from F-Droid, I try to use that instead, as long as it doesn’t lag (too much) behind GPS. Clearly failing in some regards (using Netflix and my bank app are both proprietary and Nova Launcher is proprietary as well etc) and sometimes I need root which isn’t cool.

PS: And yeah I’m using the official version from lineage.microg.org, whatever it is called.

I used the zip to flash the fork of the gmscore, because my phone is not rooted and I want to keep it that way. If you have a rooted phone you can replace the gmscore apk in the system folder, I guess.

Indeed you can get the rest from fdroid. :slightly_smiling_face:
cheers

In my experience, that’s not likely to work (although my tampering attempts were trying to replace microG Services Core with UnifiedNlp). So if anyone wants to try, make a backup before!

1 Like

I’m experiencing a little battery drain from network standby.


I searched a bit and I think it might be a general lineage 15.1 issue.
Does anybody else have this problem?

Just upgraded by flashing the LOS for MicroG and suaddon zips from recovery. First boot took about 5 minutes. Works like a charm. Even my custom launcher and all of its settings are still intact. I did not come across any issues as of yet. I installed BlueMail to provide Exchange services (need that for work) and it flawlessly syncs my calendars to the native calendar app.

‘Mobile network standby’ is in my battery usage list (never was on LOS 14) but it only took 3% of the battery (versus 7% for ‘Phone inactive’).

Hi,
I am on 15.1 now! I had to wait the summer to have more time to change from FOopenOS to Lineage 15.1 with microG.
Everything worked fine and it looks pretty nice. Thanks to all who helped make it possible!

Just one thing I forgot: to flash the modem files. On this page, it says that you can flash it before or after Lineage, but what if you forgot to before stating to use Lineage? Can I restart in recovery and flash it now? Do I have to wipe something before?

It doesn’t matter. The modem ZIP doesn’t touch any system partition or anything OS-specific. It just updates the low-level firmware of the modem, so you can flash it whenever you want.

Also note that there’s a 18.04.1 modem.zip release at GitHub (it’s the first reproducible build, furthermore)

Thanks!
I tried to install 18.04.1 following your link, but TWRP answered “invalid zip file format”.
As I already had 18.03.1 on my sd card, I tried to flash this one and it worked. I don’t know if there is something wrong with your file or if something happened while transferring the file on my sd card.

Oops! You’re right, there’s something wrong. I’ll fix it, :+1:

Edit: done.

I had this problem, but seems to be solved by wiping the cache partition (only) in TWRP.

Seems wiping cache /dalvik solved the issue. :+1:

I must come back on my words. After wiping the cache, the battery life was excellent for one day. But today about half (!) of the battery usage is ‘Mobile network standby’. The only real difference between yesterday and today is that yesterday my phone was in an area with excellent mobile reception. And today in an area with very bad reception.
Therefore it looks like 15.1 when it experiences bad reception it uses lots of power to compensate.

Have you tried disabling automatic network selection?
If your provider offers a good network coverage in your country, you will barely need to change network if you don’t travel abroad.
I often disable automatic network selection when I am in areas close to a border, otherwise my phone switches network and it could get expensive!

2 Likes

I finally upgraded today from official Lineage OS 14.1 + my microG installer to Lineage OS for microG 14.1*, and then from that to Lineage OS for microG 15.1. All seems to work well for now (pretty well, in fact!).

Edit: cool easter egg!


(some background)

*= I tried this multiple times in my FP2 in the past and yesterday too. It worked on other devices, including a pair of FP2. But mine, for some reason, didn’t. I blamed my own tinkering testing my microG/UnifiedNlp Installer, but it finally worked today. Magic, :man_shrugging:. I hace a theory, so if someone faces this problem, just ping me by PM.

1 Like

Occasionally I get Google playservices are outdated notifications. Apps threatened me they won’t work without… But they do.
Anyone knows whatsup with this?

I get that all the time, e.g. in the Discord App. Luckily I don’t need that often. And I think I could just use the website.

When I searched for this notification I read somewhere that microG need to up some version number to counter this notification, but this needs to be considered carefully because it could break stuff.
Can’t find the source at the moment though.

1 Like

Yeah, I get those sometimes too, for example on the babyfoon and hmm that’s about it I guess. The notifications in apps are annoying, but the notifications about it from Google Maps or whatever you can actually block. Or get rid of it and use OsmAnd.

@AnotherElk Source for that is somewhere on the microG Github issues tracker

You can just use Discord app in web browser it is nothing more than a wrapper around web browser anyway (probably Electron). Maybe it works with PWA?

microG is a reverse engineering project of the closed Gobble Mobile Services, as you know. Whenever an original part of them changes, things need to be reversed again. It’s a race between the cat and the dog.

In this case, Gobble phased out the Cloud Messaging Service (the API and infrastructure that powers push notifications) in favor of Firebase Cloud Messaging. Reversing and testing this new API takes time, and just changing the version number to avoid these messages could case more harm than good, said @larma.

Source: https://github.com/microg/android_packages_apps_GmsCore/pull/553

2 Likes

On that note … if anyone wants to try Discord in the browser …

1 Like

Well so far fromme the microg forge has worked pretty well. Appart from twitter crashing while opening, and not being able to choose weather provider in the clock widget everything is ok. The twitter thing came from older versions.

But im impressed by the battery performance. Never been better before.

2 Likes