Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Flashed the update via TWRP. Works so far. Thanks a lot.
By the way: Is there a possibility to delete system apps permanent? For example: I dont use the messaging app and i delete the folder in the root directory. But after the update it is still there.
So is there a way to delete the system apps, whithout “coming back” after every update?

1 Like

Could you explain, why it seems there is no solution to fixing the new cam module related bugs?

  • encryption not possible
  • reboot to recovery not possible
  • power off not possible

Was there any official Fairphone comment yet, as they seem to suffer from this also with their Android 7 FPOS.

Same here, updating through the app did not work, flashing went fine.
After the update my bluetooth devices were gone.
I do notice that some apps cannot download stuff: Firefox Focus cannot (where ‘normal’ Firefox can), the app from my provider (MijnSimpel). Anyone else experiencing problems with downloading?

I don’t know enough about the problems as to why they have not been fixed, but I suspect it is a hardware/software config based issue that would require FP to fix and once implemented can be incorporated into lineage.

@chrmhoffmann did indicate he’d got a patch for the bootloader that would resolve the issue of being unable to boot out of the battery charging screen whilst still charging (currently in android 7 (official), lineage 14.1/15.1 rebooting while on charging screen just reboots to the charging screen). So this makes me think (but don’t know) that we’re waiting for FP to implement these fixes.


Trying to flash the one from 13 august with the exact same one also didn’t work for me (not sure if it should but I though it was interesting mentioning it).

Do you think these fixes reside in modem.zip so that @chrmhoffmann can’t implement them in LOS directly?

Do you have a notification sound set? I had none set, as I don’t want to get disturbed when a new mail arrives. I read on GitHub in the K9 repo that it should work, when you set a notification sound. I tried it and indeed LED notification is working.

IMHO a K9 / Oreo related bug…

Depending on the app, you could just “disable” it on their settings screen. From TWRP you could delete files with the included File Manager on every update.

Otherwise, the only possible automated way is making a custom /system/addon.d script which is executed on every update. They are usually used to preserve apps and files (example) but are ready to be used for random operations.

No, I lack the knowledge, but this is a plausible explanation:

Do you use some VPN-based ad blocker like Blokada or DNS66? These cause that apps downloading files through the Android Download Manager fail to do so. Other apps with their own download managers (like full Firefox) work fine.

1 Like

Most likely. The modem.zip flashes firmware, and the bootloader is firmware (although I’m not sure if any of the images we actually provide is the bootloader). If a fix is released by Fairphone, I’m sure we will be able to get it into newer modem.zip releases.

1 Like

Okay, thank you.
The problem with stock SMS app is, that i couldnt be disabled.
But maybe i try the script solution.

As usual you solve this in 3 seconds :rofl:
Is indeed caused by Blokada.

1 Like

Yes, i have, and i guess you’re right that that is Bug

1 Like

last_kmsg file. :slight_smile:

Hi there,
I needed to update TWRP for the LOS 14.1 --> 15.1 Upgrade.
Now I get the message that an update to LOS 15.1 20.08.2018 is available, but trying to update I’m getting the message:

“Hinweis: Diese Funktion erfordert ein kompatibles Recovery-System, anderenfalls muss das Update manuell installiert werden.”

which seems to be a TWRP thing. I darkly remember there’s an adapted TWRP for LOS OTA updates to prevent overwriting something?

What can I do?
Thanks in advance

OTA updates for Lineage OS 15.1 are broken (see above: Upgrading from *official* 14.1 to 15.1 (feedback/issues))

Anyway, your issue seems to be the TWRP recovery is not up-to-date, maybe. Try to update it to latest available (3.2.3 at the moment)


I have since the change constantly wlan aborted. No matter if 2 or 5 GHz. Bluetooth is also always on. :roll_eyes:

Oh. I think that the 15.1 branch does not have the wlan driver rollback that should fix your apple router problem. Damn. Will fix that for next release.



I just recognized that also for me the Bluetooth devices were gone after the update to 15.1.
I could connect my pebble but at trying to find my speaker the phone stuck in the Bluetooth menu. Also tried a reboot without any positive effect.
I can not confirm if that only happened with the build from 20.08. cause I simply did not tried with the older build.
Anyone else experienced that?