Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Mine as well: goes up to 97°C (according to TWRP 3.1.1-1) when doing a backup.
Upgrade went fine.

There was an issue with lineage automatic updates. This will be fixed in next release, meaning that it should work in next-next release (at least for people with old camera).

https://review.lineageos.org/#/c/LineageOS/android_device_fairphone_FP2/+/225529/

Chris

5 Likes

It also runs fine for me…

Yesterday I did a battery swap and my devices were still there. So it is not 1-to-1 related.
Bluetooth on my headphones was acting weird as well: usually the buttons trigger the volume on the phone to change, but yesterday it did not (only on my headphones). This morning (after the swap) it did change volume on my phone again.
And there is Bug 33 and 37.

Major improvement : notification LED is blinking fast when set so in Silence app.

AT LAST !!

Small nostalgic thoughts about :

1 Like

3 posts were split to a new topic: :de: Upgrade von LineageOS 14.1 auf 15.1

Isn’t possible to continue getting the updates for the 14.1 as it appear to be more stable?

3 Likes

I run LOS 15.1 13.08.18. Everytime I restart my phone, it says the SIM cards were changed (I use 2 SIMs).
Also Google Maps and eBay Kleinanzeigen no longer work - do these work for others? I will try and get a logcat for this (have to read into how to do this).

I did a fresh installation of LOS15.1 via TWRP:

  • did a backup of the actual version running (LOS 14.1 )
  • wiped all before (system, cache, data)
  • installed LOS and gapps zip packages
    Now all works fine, LOS-build-in music player works without the problems described here.

Since it wasn’t the same starting position, i wanted to set up the system again:

  • wipe again system, data, cache
  • restore the backup just created before
    Then this should have followed:
  • wipe system and cache, but this time not data
  • upgrade to LOS15.1, all apps and app data shold remain

But TWRP has given me error 255 for data partition. The only way I managed to get data partition again accesible was to format data,
But then all data from encrypted SD card was gone.

Before continuing tests, I would be good to now how to safely backup/restore between different versions.
Has anybody faced this also? Why this error 255 appears, how this can be avoided?

Pierre

1 Like

No. Lineage OS only tracks a single version at a time per device. You could stay on latest 14.1, though, there’s no major problem in delaying security updates some months.

2 Likes

I’ve been having a good time with my freshly installed Lineage 15.1, but when trying to update to the newest nightly (20180820) I get an install error from the Lineage OS updater.

Configuration:
I’m using a FP2 with the older camera modules. I did a complete wipe of my phone before installing 20180813. I’m using Open Gapps pico and haven’t rooted the phone. No encryption (yet).

What I’ve tried:
Deleting and redownloading the install 3 times. Restarting the phone of course. Charing the phone fully and then installing - without being connected to the charger.

Additional:
Probably not relevant, but the first time I tried to install the update, the install was denied because the battery level was <30%.

Is there any sort of error log that I can/should provide?

There is something wrong with the OTA but you can install it semi-automatically from Recovery:

  • download the update (same procedure as you have tried), but don’t try to install it
  • restart in recovery
  • install the file stored in the update folder (/data/lineageos_updates)
6 Likes

Are you using an encrypted phone? Sorry, seems you are not… ;-).

AFAIK this could fix the OTA updates in the next release: https://review.lineageos.org/225529

1 Like

I know I’m OT but why there are so many problems related to the new camera module?

1 Like

Thanks, worked perfectly :slight_smile:

1 Like

I have the same issue with regards to disconnects. On FP2, Bluetooth also says it is disabled when it is enabled. I use P2 and only have 1 device registered, but P2 is the only Pebble which only has BLE. On Gadgetbridge, IIRC there were 2 Bluetooth addresses with the P1 Classic (and should be with all non-P2).

I seem to have severe battery use ever since 20 august manual update but I am not sure what’s causing it. I hope up today and found my device was rebooting while it was on USB charge, meaning it was heavily discharged. Anyone also experiencing this?

You could investigate via GSam Battery Monitor for example, that App helped me discovering that WaveUp is draining my battery because of wakelocks (too sad… even with 15.1 I cannot use it).

Could it be linked to the absurd battery percentage used by Mobile Network standby as experienced by other FP2 users (which also affects other phones)?

Thanks for the suggestion. The device was extremely hot as well. I do have bad mobile reception in-house, but I had data usage off (since I was at home, I did have WiFi on but the device was 5 meters from the AP in pretty much a direct line so good 5 GHz reception). Bluetooth-wise perhaps it was in trouble given my smartwatch was on me in our bedroom. I did not see such absurdity when I checked the battery usage roundup (since yesterday morning my device was at 63% or so when I took it out, and it appeared to go down by 2% every few minutes until it reached 25% and the battery saver kicked in; so it appeared the battery saver saved me there but this even occurred whilst I was on the move and whilst I was gaining better reception). When I noticed it yesterday I had a powerbank w/me, but this morning I was too late since the device was already empty.

At lunch I’ll have a look with some other applications than Android’s stock battery analysis app (which appears quite useless to me the times I’ve used it).