Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Chris, you should perhaps also close that one, when fixed :):
https://jira.lineageos.org/browse/BUGBASH-2173

I have a similar issue: If my FP2 boots and I wait too long after the PIN entry appears, the primary SIM card is offline. I can only force PIN entry by switching the flight mode on and off.

1 Like

I’m this week not at home, I’ll provide it on Friday.

What audio format is that?
MP3

Hey,

does anyone else have problems with the cLock Widget. Mine is not showing the weather. It recognized that I have installed open weather, but when I click on the weather Provider it says “no weather Provider found”.

I now have reboot @work with Apple Router under Android 8. :slight_smile: (see this thread)
The file for the protocol “last_kmsg” has no read rights under Android 8.

greetz
Steven

Hold Vol + while rebooting and get the last_kmsg from TWRP as a workaround.

1 Like

I’ve just downloaded the 20th Aug nightly via the updater, but when I tap the Install option I get a triangle with exclamation on the status bar saying install error. It doesn’t try to validate the update or run through the usual procedure as it normally would do.

I’m upgrading from the 13th Aug nightly

Rebooting into recovery and installing the downloaded update from /data/lineageos_updates/ and has installed fine.

I’m still running without encryption at the moment, so not an issue with this.

And BTW @chrmhoffmann video recording is indeed fixed now :+1:

1 Like

LEDs with k9 work for me (2 accounts configured with different colors, although i have the impression LEDs don’t always work immediately with notification. But i didn’t observe this too closely up to now

Same issue for me, device encrypted (@ 14.1), LOS + microG.

Oh, so it wasn’t a LOS for microG issue:


Logcat here:

I had the same experience: The update didn’t work from the updater app but from TWRP.

After rebooting the device the touch input didn’t work which left me unable to decrypt my data partition. After another reboot (triggered by pressing the power button for 10 seconds) it worked as before.

Video recording also works as before. Good job and thank you!


Edit: Still the settings app crashes when I try to open the setting ‘Tasten’ (maybe ‘Buttons’ in English?).

3 Likes

I have managed the upgrade without any problems.
I came from 14.1. (microG). I did a twrp update to the latest version and then installed 15.1.
Great work! Thank you!

1 Like

Flashed the update via TWRP. Works so far. Thanks a lot.
By the way: Is there a possibility to delete system apps permanent? For example: I dont use the messaging app and i delete the folder in the root directory. But after the update it is still there.
So is there a way to delete the system apps, whithout “coming back” after every update?

1 Like

Could you explain, why it seems there is no solution to fixing the new cam module related bugs?

  • encryption not possible
  • reboot to recovery not possible
  • power off not possible

Was there any official Fairphone comment yet, as they seem to suffer from this also with their Android 7 FPOS.

Same here, updating through the app did not work, flashing went fine.
After the update my bluetooth devices were gone.
I do notice that some apps cannot download stuff: Firefox Focus cannot (where ‘normal’ Firefox can), the app from my provider (MijnSimpel). Anyone else experiencing problems with downloading?

I don’t know enough about the problems as to why they have not been fixed, but I suspect it is a hardware/software config based issue that would require FP to fix and once implemented can be incorporated into lineage.

@chrmhoffmann did indicate he’d got a patch for the bootloader that would resolve the issue of being unable to boot out of the battery charging screen whilst still charging (currently in android 7 (official), lineage 14.1/15.1 rebooting while on charging screen just reboots to the charging screen). So this makes me think (but don’t know) that we’re waiting for FP to implement these fixes.

4 Likes

Trying to flash the one from 13 august with the exact same one also didn’t work for me (not sure if it should but I though it was interesting mentioning it).

Do you think these fixes reside in modem.zip so that @chrmhoffmann can’t implement them in LOS directly?

Do you have a notification sound set? I had none set, as I don’t want to get disturbed when a new mail arrives. I read on GitHub in the K9 repo that it should work, when you set a notification sound. I tried it and indeed LED notification is working.

IMHO a K9 / Oreo related bug…