English

Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Seems there isn’t one … yet …

But there’s a setting to display the battery percentage in the status bar, I find that much more helpful (had to install an App for that otherwise) …

Settings

  • System (Languages, time, backup, updates)
    • Status bar
      • System icons (Control which status bar icons are shown)
        • Battery
          • Always show percentage / Show percentage when charging / Don’t show this icon

Settings

  • Security & privacy (Screen lock)
    • Trust
      • Privacy Guard
        • three-dot menu
          • Show notification (On/Off)

I had this, too … I think it was some permission thing … I can see that I did disable Privacy Guard for F-Droid, but I don’t know anymore whether that solved it.

Settings

  • Security & privacy (Screen lock)
    • Trust
      • Privacy Guard
        • (tap on App) (Privacy Guard On/Off)
4 Likes

Thanks alot… Guess i have to peruse the menu structure more intensive :slight_smile:
The only thing i found myself was being able to show battery percentage always… Thought it might use to much of screen estate, but trying it anyhow… .

Upgraded last week my tablet to 15.1 and now upgraded FP2 from 14.1 encrypted to 15.1.nightly with TWRP. I only wiped “System” partition (as far as i see from TWRP when selecting “wipe” System is also formated).
I did not loose any data!!! All apps are available.
Fairphone runs as it should be! Many thanks to all helping hands!

Only 1 remark:
TRUST is new in 15.1. and says that encryption is deactivated but under Encryption there is the indication that the phone is encrypted. This is a little bit confusing.

2 Likes

Hi. Happy to see LOS 15.1 is released :smiley:

Following the LOS upgrading guide, the method is different if I have official or unofficial version of LOS 14.1.
But how do I know which on I have ?

You’ll have the official build if you:

You’ll have an unofficial build if you:

  • installed Lineage OS for microG.
  • installed other 14.1 builds for debug/testing purposes that were distributed here in the forum long time ago.

Generally speaking, you’ll have an official build if you have been able to download and install OTA updates (Over-The-Air) with the built-in updater, and you’re sure to not use Lineage for microG.

There was an official build from June 20 filenamed lineage-14.1-20180620-nightly-FP2-signed.zip.

Apart from that, I guess everything not containing “unofficial” in Settings - About phone - LIneageOS-Version or “test-keys” in Settings - About phone - Build number would strongly hint to official … but in the end you would have to know what you are running on your own phone :wink: .

1 Like

Thanks for your help.

To be honest, i have no idea about OTA or MicroG.
I have never seen this before so I guess i didn’t use it.
I installed lineage following the links in this forum only.
But I can use the built in updater to update LOS and if the date of 20 June 2018 matches with an official build… It should be official.
Also is written unofficial nowhere.

Yes, release dates in the screenshot match with official ones, so you have an official build. Don’t forget to make a backup and store it in you computer before attempting the update. That way, you’ll be able to restore it if anything goes wrong in the process (shit happens).

do i have to wipe something before the update? backup apparently is obvious…

It is a issue with Android 8. Manually update to 1.3.x and you’ll fix it. I thought they already pushed that update as the recommended, but I was wrong.

1 Like

Installed latest TWRP 3.2.3, then flashed the Update, Pico GAPPS and addonsu without problems. Thanks a lot :slight_smile:

But i cant find point described underneath. Where exactly is the three-dot-menu?
Thanks in advance.

2 Likes

Okay, thanks. I wondered, because i already unchecked the point there but the Notifacations were still there. But after a reboot it seems to work.

What’s that status icon which tells you how much you’re up- and downloading? Kinda sad that with P they reserve that space due to notch (on all phones apparently :frowning: )

Settings

  • System (Languages, time, backup, updates)
    • Status bar
      • Network traffic monitor (Show current network traffic levels in the status bar)
3 Likes

I just installed the first official lineage OS 15.1 build via TWRP coming from not official build. However, now I can enable root only for ADB, the majority of apps do not work and I have to reinstall them manually via f-droid or yalp. I think it is a root related problem. Should I install suaddon?
Thank you

I had a similiar problem when updating from unofficial LineageOS 15.1 to the official build. There was a permission problem with some apps (aparrently some settings were lost, and PrivacyGuard also lost some granted permissions). As a result, most of the apps I had installed crashed.

 Caused by: java.lang.SecurityException: ConnectivityService: Neither user 10076 nor current process has android.permission.ACCESS_NETWORK_STATE

Reinstalling the problematic apps solved the problem for me (no need to delete data/cache).

Edit: I just started over, some system apps crashed as well.

Is it just me or maybe the “wrong” impression of the first fully charged battery or did I have some settings set in a wrong way in 14.1? I have the Impression that my full charged battery again is lasting longer than in 14.1!

The increase was incremental in my perception with every new Android:

  • FPOS/FPOOS Android 5: I was happy when my battery lasted 10-12 Hours.
  • FPOS/FPOOS Android 6: No big change except that the phone was less hot, maybe 14 hours possible .
  • Lineage14.1+microg Android 7.1: 20-24 Hours with Little use, 18-20 Hours on a regular basis.
  • Lineage 15.1+ microg Android 8.1: My phone is running now since 24 hours and the battery settings predict it would run 10 hours more. And this eventhough I didn’t use the lowest brightness level as I did the versions before.

If this performance would be lasting in the next weeks, I am pretty impressed and finally satisfied.

7 Likes

Yes, I have to reinstalled the majority of apps. However, I do not know why I can enable root only for ADB…

You probably need to flash the addonsu to enable root: https://download.lineageos.org/extras (be sure to check arm and 15.1 for the FP2)

2 Likes