Upgrading from *official* 14.1 to 15.1 (feedback/issues)

I had a similiar problem when updating from unofficial LineageOS 15.1 to the official build. There was a permission problem with some apps (aparrently some settings were lost, and PrivacyGuard also lost some granted permissions). As a result, most of the apps I had installed crashed.

 Caused by: java.lang.SecurityException: ConnectivityService: Neither user 10076 nor current process has android.permission.ACCESS_NETWORK_STATE

Reinstalling the problematic apps solved the problem for me (no need to delete data/cache).

Edit: I just started over, some system apps crashed as well.

Is it just me or maybe the “wrong” impression of the first fully charged battery or did I have some settings set in a wrong way in 14.1? I have the Impression that my full charged battery again is lasting longer than in 14.1!

The increase was incremental in my perception with every new Android:

  • FPOS/FPOOS Android 5: I was happy when my battery lasted 10-12 Hours.
  • FPOS/FPOOS Android 6: No big change except that the phone was less hot, maybe 14 hours possible .
  • Lineage14.1+microg Android 7.1: 20-24 Hours with Little use, 18-20 Hours on a regular basis.
  • Lineage 15.1+ microg Android 8.1: My phone is running now since 24 hours and the battery settings predict it would run 10 hours more. And this eventhough I didn’t use the lowest brightness level as I did the versions before.

If this performance would be lasting in the next weeks, I am pretty impressed and finally satisfied.


Yes, I have to reinstalled the majority of apps. However, I do not know why I can enable root only for ADB…

You probably need to flash the addonsu to enable root: https://download.lineageos.org/extras (be sure to check arm and 15.1 for the FP2)


Just updated. Runs very smoothly and no special issues on my side so far, except from the already known issues.

Many thanks to Lineage team for keeping us up to date !!! :smiley:

BTW I still wonder what is the point of app authorizations limitation on Oreo, since the apps refuse to start when they are limited :stuck_out_tongue:
So … back to Xposed and Xprivacy like always.

I guess that Xprivacy should be more usable, but Trust’s Privacy Guard (formerly just Privacy Guard) provides what you want. E.g. you can grant the “contacts” system permission to an app refusing to work without it but tell Privacy Guard to pass an empty list. I do that with a pretty known closed-source IM app the world just keep forcing me to use, no matter which media scandal, :wink:


I also upgraded successfully to 15.1 with a minor glitch: it didn’t recognize my 128 GB SD card which was formatted with exFAT. That worked fine with 14.1 but 15.1 said that the SD card was broken and needs to be formatted. So I checked the SD card on my PC where it worked fine, copied all the data and then reformatted with ext4 this time (I didn’t want to waste large blocks with FAT32). Now I am up and running again.
Thanks a lot for your work Chris!

1 Like

I had the same experience. My SanDisk 128 GB card was reported to be broken. In my windows 10 PC it was readable, albeit with a similar warning about being broken. Win 10 offered to fix it and that said it succeeded. Still no luck on the phone. I then copied everything to my PC, formatted the card on the PC and copied everything back. Again, no luck on the phone.
In the end I had to format the card on the phone and copy everything via MTP. Now it works.

1 Like

I noticed a little issue. When i use a secret chat in Telegram the word prediction from the stock keyboard doesn’t work. With another keyboard, AnySoftKeyboard for example, it works.

Great idea! What I’d love to see, is a way one can export such lists. So that those who are less good with making such rules, can import them. Pretty much like firewall rules, ACL, SELinux, Pledge, etc.

1 Like

Update went smooth from official nightly 14.1

  1. Installed latest TWRP 3.2.3
  2. Downloaded 15.1 nightly and OpenGAPPS Pico
  3. Made Backup within TWRP
  4. Queued LOS and OpenGAPPS, then flashed
  5. No wiping cache, etc then Reboot.
  6. Left it to load and is all working fine!

Great job everyone, especially @chrmhoffmann :fist_right::sparkles: :fist_left:


Not an issue, it is a privacy feature. A secret chat is meant to be secret. Keyboards have an incognito mode that could be enabled by applications, in which they (promise to) don’t log what you write. These keyboard apps need to read what you are typing to offer you useful suggestions. Signal enables this mode too, but for every chat.

@JeroenH Yeah, that’d be great, although I guess some rules are way personal.


What you can also do is just firewall the application. For example, SwiftKey (recently bought by Microsoft) has this feature as well, but if you put off cloud predictions its fine. You can also firewall the application.

Some rules might be personal but with adblockers (such as uBlock Origin) that’s also the case.

1 Like

Thanks to all who contributed to getting 15.1 to the FP2!!

The upgrade worked fine for me (on my second attempt; as I first did not wipe /system).
Hopefully exchange will be available soon, as I unfortunately need it for work.

Either way. Thanks to all for your great contributions to make LOS 15.1 work on FP2!


Thanks for the answer.
Two additional questions. Is there a possibility to deactivate the incognito mode of the keyboard?
And second: Do you have an explication for the fact that the incognito mode doesnt get enabled in my Signal app?

Oh, yeah. From Nougat onwards, in app’s settings you get an option to disable mobile data or WiFi per-app, so it doesn’t connect at all. Quite useful for privacy/untrust reasons. Before Nougat I used NetGuard (same author than Xprivacy), but I have a real VPN now that conflicts with the local VPN NetGuard’s create (VPN connections cannot be chained, unfortunately).

Look in each app settings. Beware that your keyboard will log whatever you type meant to be confidential and probably send it to thousand third-party bussinesses and goverment agencies, depending on their privacy policy and applicable law.

1 Like

Thanks a lot everyone that helps on Oreo, great job :smiley:

I did a factory reset, upgrade Twrp, then use it to instal Lineage, Gapps pico and Su. Everything works well!

The only two problems I have are known bugs: Exchange that is missing, and the camera (Open Camera for me) that cannot record video. Appart from this, it is perfect :slight_smile:

Than again :slight_smile:

1 Like

A post was merged into an existing topic: Easy info about LineageOS 14.1 features not working in 15.1 (e.g. Exchange)?

I upgraded tonight, it seems to work properly. I flashed su-addon and F-Droid privileged extension (was that necessary after wiping system partition?) right after the Oreo image.

Boot time has improved a lot.