Upgrade to Kola Nut 1.8.5 doesn't work

The updater tells me to upgrade - I click “Install”, and it starts downloading. This takes a while.

Then, I can choose “Restart” or “Cancel”. I press “Restart”, and briefly I see an error message that /cache/<some_upgrade_name_etc>.zip can’t be found.

So nothing happens. After this, the updater wants me to go through the process of downloading etc. again, with the same results.

When initiating the upgrade, I’m nagged to install Google Apps, which I click away as I don’t want Google Apps, which is not free software. I don’t know it that has anything to do with the problem? Perhaps not.

1 Like

Do you have an official unified partition?
Many users who have the original FP1 “internal storage” and “phone storage” or a custom partitioning have this problem.
Since you don’t want GAPPS anyway you can do a manual update. But if people who want Google read this let me warn you again: DON’T do a manual update or you’ll be stuck in a googleless loop.


I haven’t changed the partition since I got the phone, so I assume I have an official partition.

HOWEVER, I do have an SD card plugged in. Maybe I should remove the SD card to do the upgrade?

If that doesn’t work, I’ll look into the manual update - thanks for the tip!

1 Like

I do have the same problem. Did you manage to fix it?

I face the same problem. I changed the partition in January, but the update is still not working…Tried a lot…Deleted all the cache and even the data of the update app… space is there…And since I started the download for the first time all Google apps were deleted…

Would be great, if you can fix this.

Same here. Tried everything from the Wiki post. Now ALL my pictures are deleted. A notice of backup would have been nice - in the Wiki post and not somewhere in one of the million messages which I do not have time to read.
I am a thorough fan of fairphone but I am neither a tech nerd nor do I want to be one. So please, I would really appreciate if you could provide solutions for people who have other things to do besides updating their phone.

You are so right! Sorry for that. I updated the Wiki post now.

To everybody here:
The Fairphone Team is working on a solution for this problem. So hopefully there will be a fix soon.

Ok thank you Paul.
However, I now cannot download anything like the Titanium Backup in order not to loose more data like contacts now, because I cannot reinstall the google apps.

Titanium Backup can be downloaded directly from their site, so you don’t need Google for that.

1 Like

Could you provide a download link? I can’t find it… :frowning:

Yes I tried that, but all I get is a note saying that the browser is not being supported anymore. It asks me to use the Google Play App Store, which I do not have anymore.
I would send you a screenshot but I have no wifi connection because of the unsuccessful update and due to other issues with o2 and FP, discussed in another forum part, my mobile network is not working well either…


This is the direct download link

Or you can try via evozi:


Does any of that work for you?

1 Like

Yes I could download it now. However, I do not understand how it works, and it keeps asking me for superuser access, accepting access for unknown sources etc.
Maybe I will try to figure it out later but I do not really feel comfortable doing things to my phone that I do not understand.

Thank you, evozi worked.

1 Like

Thanks so much for that link. I have now got my gmail and other google apps back . I still haven’t got 1.8.5 but I am going to leave it for now as the phone works again as I wish - so I don’t have to get a new one.

1 Like

I moved a post to an existing topic: New software update Kola Nut 1.8.5 is ready