Kola Nut 1.8.5 manual update

Hi all,

As we mentioned yesterday the update is ready but we’re getting the release infrastructure in place. If you can’t wait installing the update through the Fairphone Updater app (the automatic process that will be ready next week), you can get the Kola Nut 1.8.5 update here to install it manually on your device. Please note, this version is for FUSE devices only, i.e. users who have the FP1U or FP1 users who performed the Storage Upgrade.

If you still use the old partition layout on your Fairphone you can also get the Kola Nut 1.8.5 version, though we highly recommend you to make your storage unified by performing the Storage Upgrade.

EDIT: click here for more information on how to install the update manually




I just updated, everything works like a charm :smile:

In the past what I disliked the most about os updates was loosing all custom system apps but now that microg UnifiedNLP can be installed as a non-system app the only ones I use are Xposed and GravityBox and they can be reinstalled within seconds by the Xposed Installer. So just one reboot and everything is back to normal.
All together it took less than a minute! :smiley:


Uhm, maybe it’s just me, but… how do you do it? I mean, do I just unzip the file to my Fairphone or…?

I simply opened the link on my fairphone. It took a few seconds to download and then the Installation started.

Btw, I always keep my phone plugged in during a software update and leave the “stay awake” setting on (developer options in settings) because for some beta versions updating didn’t work otherwise.

You can copy the file onto the SD card and in the recovery menu you should be able to flash from the sdcard.
If I remember correctly, also some time ago, when I didn’t have an sdcard yet, I copied the zip file onto the /cache partition to be able to flash it

read more here

1 Like

Thx all for your advice and especially Rick for the ultra-user-friendly step-by-step :smiley:


Hey @rick
just so you know:
I don’t think it’s really necessary to have a SD card and to uninstall the custom launcher!
I installed the update by just downloading the .zip via the link you provided with Mobile Firefox onto the internal storage of the FP and I installed it while Buzz Launcher was my default launcher. No problems at all.

1 Like

Uhm, I’ve upgrade, but I constantly get the message (NE) Android-toetsenbord (AOSP) is gestopt. …

I’ve installed google apps again and now everythint seems fine :smile:

1 Like

If toetsenbord means keyboard then I think it’s “normal” that this might happen before you reinstall Google.
Although @ben just mentioned in the beta category that this doesn’t happen to him for the first time with this update…

Problem — SOLVED##

I tried to follow your guideline
Before I get to step 3.3 I get a screen stating that I have to ‘Select Boot Mode’ I can choose between [Recovery Mode], [Fastboot Mode] and [Normal Boot] . Please note that only in this screen you choose [VOLUME_UP to select. VOLUME_DOWN is OK.]
Then I get step 3.3 resting robot.
After applying step 5 I get “Installation aborted” “error”.

I also tried @paulakreuzer suggestion ‘Btw, I always keep my phone plugged in during a software update and leave the “stay awake” setting on (developer options in settings) because for some beta versions updating didn’t work otherwize.’ but that didn’t help.

I am a FP1 user who performed the Storage Upgrade and I managed to upgrade to v1.8 when v1.8 was released. And I used FP1_KolaNut_v1_8_5_OTA (~200 MB), md5sum check was oke.

CHANGING the zipfile from FP1… to the FP1U… did the trick.


Did you also try the first part of my suggestion?

That way the whole installation was faster than it’d take me to even read that friggin’ 7-step guide!

same here … :frowning:
trying to fix…

Edit Are the links correct? Is FP1-Fairphone_OS_1G13G_v1_8_5_OTA_2015-05-07.zip for the first batch?

No. I downloaded the zip-file on my PC, checked the md5sum and copied the file to my sd-card.

The links are wrong.
Just used the FP1-Fairphone_OS_v1_8_5_OTA_2015-05-07.zip to update my 1st batch FP v1.8 with unified storage.

1 Like

Yap, but only because i forgot to “Wipe cache”. :slight_smile:

Oh, btw, the update wiped the laucher, as expected :smiley:

I do not know why, but it seems the descriptions of the links on the Website are really wrong as @HackAR suggests. The version provided for FP1 is only the one for FP without storage upgrade! @anon12454812, you might want to fix that. I also used FP1-Fairphone_OS_v1_8_5_OTA_2015-05-07.zip on my FP1 with unified storage.

Can you still boot the FP? If not, you could use your pc and an adapter to put the zip on the SD-Card and reinstall using recovery.

It’s correct. If you have a first batch FP1 with unified storage, you have the same layout as an FP1U.