Upgrade problem - Installation aborted

My updater App tells me, I had Koala Nut 1.8 and offers me a “Pre-update Koala Nut 1.8.7”

however, no matter which way I choose (tried: the updater, ADP sideload, direct upload to main memory) the phone shows the update-screen but keeps the V1.8 system.

In recovery mode it tells me “Installation aborted”

I even tried a factory reset but with no success.

Last thing I tried was to update to 1.8.5 instead of 1.8.7 but with the same result.

It’s my wifes phone. Mine (first batch) works flawlessly, hers keeps having strange issues.

I’m not sure what the underlying problem is, but just three thoughts:

  • Has your wife’s FP1 a unified partition? If its storage includes no “phone storage”, then the answer is yes. If it still includes a phone storage, then I recommend to do the storage upgrade first (!).
  • Have you tried the manual installation of Kola Nut 1.8.7?
  • Did you do the factory reset through the regular Fairphone user interface or did you do a full hard reset? (Click at the blue words to find instructions)

I don’t know if your mother tongue is German or Dutch or English, so I’ll just recommend the easy step-by-step tutorials provided by Fairphone. You will find instructions both for the storage upgrade and for manual installation there.

My mother tongue is German …

as far as I understood, the FP1U does naturally come with unified storage.
In the File Manager I ONLY see a “Phone storage” of 12.98GB total space (avail. 5.2GB)
well …
seems to be core of my problem.
I just checked within the preferences section and found “internal storage” AND “phone storage”.
So I see, that FP1U also comes with split storage model.
There is no hint to that in the upgrade tutorials.

The factory reset was done via recovery mode.

FAQ - test for storage upgrade - German helped me to find the clue.

From Upgrade files I coose the FP1-Fairphone_OS_1G13G_v1_8_7_OTA_2015081400.zip to upgrade and succeeded!

Than I upgraded the storage layout (the file FP1-Fairphone_OS_v1_8_7_Partition_upgrade_2015-08-17.zip seems to be for V1.8.7) and succeeded again.
My wifes phone is equipped with V1.8.7 in unified storage layout now.

Thank you for your hints!

1 Like

Glad to have been able to help.

I’d investigate further what FP1 model your wife’s phone really is. I have never heard of a FP1U with a split partition before. You probably know that the FP1 and the FP1U have different chips. As far as I remember, the FP1 can only record 720p video whilst the FP1U records 1080p video.

Under the Battery it tells me: “Fairphone Model FP1U …”

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.