UpdateProcess from FPOS/Android5 --> LineageOS14/Android7

Lastly I want to finally shortly report about my UpdateProcess from FPOS/Android5 –> LineageOS14/Android7, promised one month ago some posts above:

Here we go:

  • My starting point was: FPOS 1.12 / Android5.1 / rooted with SU manager app / TWRP already installed / working ADB (from root process some time ago) with ADB Minimal (and now again tested for emergency cases :wink: )
  • First I did a backup:
    • Choosing “Backup” in TWRP (Boot, System & Data), to ext. SD card
      • using TitaniumBackup for all Apps and their settings
      • using EasyBackup (4.9) for Call logs, SMS, contacts, calendars)
      • copied all data from internal storage to PC
    • During update I kept external SD Card inside FP2 (data should be copied to a PC).
  • I downloaded and saved to external SD card:
  • addonsu-14.1-arm-signed.zip (For superuser / root access)
  • latest modem files ZIP
  • OpenGApps pico (which I did not used at all, thus having still a google-service-free FP2)
  • TitaniumBackup as APK
  • basically I followed the official instructions of the LOS-wiki:
    • inclusive the “swipe cache” point
    • I put all ZIPs in the install queue of TWRP and let it work (~2 min)
    • queue order: LOS-nighlty.zip → addonsu.zip → modem.zip
    • reboot took some minutes but could already watcht the LOS boot logo :slight_smile:
  • Funny fact: all my data in the internal storage survived. I thought with “wiping” in TWRP they should be gone…but they wasn’t
  • After first boot I restored my data:
    • installed TitaniumBackup and tried to recover as much as Apps & App-data as possible. Not worked with TitaniumBackup the restore of:
      • Contacts, SMS, call logs
      • Calender settings of DAVDroid (I had to manually re-create them)
      • Conversations with XMPP and OMEMO encryption account: I forgot to first deactivate my account before creating the backup (as stated in ReadMe). If I would have made this, the move of the data had been no problem!
  • Contacts and SMS I restored with EasyBackup (contacts directly to Phone Storage without any Google Account, which was much more difficult in FPOS-Android5.1! )

After all this in principle very easy procedur if one once figured out how it works, I was very happy wiht a nicely running LOS, that:

  • provides nearly all features which I loved in GravitiyBox before directly built in
  • additionally:
  • finally the bug of the disconnecting WiFi after 10mins in Sleep mode is gone
  • I finally found and successfuly uses the app “Battery Charger Limit” to stop charging automatically at a certain value (e.g at 90%). FP support told me once, that this is not even feasable - but it is!
  • finally, the delay between dialing a number and the establishing of the caller signal-beep-beep is very small (~1-2 seconds) in comparison to FPOS before (5-10s).
  • It was not neccassary to install any SuperUser-Manager (seems to be built-in in LOS already).
  • Activating the root access was easy (in developer options, which you active by tapping 5 times onto „Build number“ in “About Phone”)
  • I installed the bare GoogleMaps APK and have a working google maps, without the need of first installing GApps!
  • But until now AFAIK it is not possible to install XPosed Framework.

Bottom line: moving to LineageOS was much easier than I expected and makes much more fun than I hoped :slight_smile:

After that gigantic post…I have to stop now :wink:

Cheers, Robert


Because of splitting the post here are the other crosslinks as a follow up of mysuccessful update process:

However i’m stuck for now in the step where i have to restore my TitaniumBackup backup.
The application says it can’t access the backup directory. Also i have no options to set the backup directory in the app, but i had in OpenOS.
No troubles for you about this when you switched?

I managed to solve the problem by tricking the os and installing the backup directory in yoursdcard*/Android/data/com.keramidas.TitaniumBackup/ as detailed here : https://androidforums.com/threads/titanium-backup-pro-wont-use-external-sd.936278/

It seems there are permission problems with sdcard in nougat.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.