Update kills Google

Updated FP OS today - no more google - nothing - no gmail, no app store, no google nothing - google app installer oif course doesn’t work either.

nice job

no, really

No reason to be so rude :wink: We can try and find a solution together.
Answer me the following two questions.


what’s rude about my post? Ironic I would of course accept “ironic” but “rude”? I find your insinuation, how should I put it without offending your sensitivity, overinterpretative?

<•Is there a Google Apps Installer on your home screen?
Something like this: https://forum.fairphone.com/uploads/default/285/6c16a147ae984c5b.png>

Not to appear rude but I have posted one single sentence, have you read the second half of it?

Thank you ever so very much for your most appreciated help to the first half of my sentence, for the second half, don’t bother, I’ll figure out something.

Again, do please excuse me if my English appeared rustic on first reading, no wonder you stopped in mid-sentence offended as you were, my deepest apologies for my unpolished style, thank you again and have a nice Christmas.

Oh, BTW, and I hope you don’t take this sideways but I do mind mimosas in help centers. Overall, such a juxtaposition is mutually exclusive, and specifically, I’m allergic to the perfume. Pollen you see.

Ah yes, I forget. The kind of problem I describe is usually part of inhouse beta testing. Especially since Google features so prominently in Androïd-bases systems. So the first thing to ensure is that Google runs perfectly.

To put out an update that overlooks this essential pillar of smartphone operation is, ah, not to be sarcastic/dissing/aloof, erm, strange?

And before you fire at me from the hip again, do-gooder company or not, if you work in the kitchen you must be prepared for slightly higher temperatures as in the restaurant where the customers sit.

Jempix, you were sarcastic from the off, and there’s absolutely no call for it. Get a grip.

Now, just reboot your phone and go into the Fairphone updater and then out of it. Kill it from your recent apps drawer or the applications manager in settings, then use the Google apps installer again. It should work - has for me and a couple of other people whose posts I’ve read.

Well I dit read your post. It said

google app installer oif course doesn’t work either

So just answering my question would’ve been easier, but since that seems to be quite a hassle I assume the answer is yes. However, due to your sarcastic and idiotic answer, I’m no longer willing to help you.


nice job
no, really

Is rude (towards the developers) because of its sarcasm. If you wish to have something smooth, nicely working, without any malfunctions or side effects, switch to one of the Android giants like HTC or Samsung and you wouldn’t have to bother being so sour. Assuming you’re a smart guy/girl (after reading your ‘intelligent’ answer), you would’ve done your research about Fairphone. You would’ve known that Fairphone is a small team of developers and mostly community-driven. But sure, you would’ve known.

Same problem here, and same sarcastic feelings on my end. How could roll out an update that basically bricks the phone? I have done the “Clear Data” of FairphoneOS several times, restarted even more times, the installer stays grey.

Rude or not, you rolled out an OS update that bricks some phones. = Fail

I don’t think you guys understand what bricking means. Your phone is still useable, and since these are two occurences of such a malfunction I don’t think your in your right to call out anyone. Let’s just try the most applied hint in the history of anything technical: have you tried turning it off and on again ? (Soft/hard reboot, close/relaunch fairphone app … ) If anything else fails: you can always downgrade and re-update manually.

EDIT: The fact that it’s grayed out is probably for a reason, probably something preventing something else and thus intentional, to protect you.

But then in fact giving comments from behind a computer instead of actually trying something, is a lot easier :wink:

1 Like

It still runs but is unusable? Semantics. Great job, really.
Btw. adding smilies does not make you less sarcastic. I have tried all possible restarts, relaunches, clear datas, so what’s your problem accusing me of trying nothing?

Well, I’m giving up as the only thing you seem to be enjoying is ‘studying’ my sentences/vocabulary/way of putting things. And yeah @Jan_Zuppinger you could always contact support directly. Perhaps your problem is specific for your device.

Regardless of any sarcasm, the update has given me the exact same problem. Hopefully someone will provide us with a solution?


Have you tried re-opening the Fairphone Updater app and completely re-installing the update?

Also, after the update the Fairphone OS is getting updated in the background. Maybe this is causing the Google Apps widget to be grayed-out.

I assume some of you have already tried this, if not, please do.

Another possible solution: delete and re-add the widget from the widgets menu.

1 Like

Yes, already tried the advice from the site (several times). It hadn’t occurred to me to try the updater again. I’ve just done so, and it says I’m still on Cherry Pie so I’m running it again. Update to follow…

Well, that for one, could be causing the issue: an incomplete install of the update.

Can I remind everyone that the Community Moderators are not employees of Fairphone, so we have no control over how the update works or performs.

This whole forum is in fact a community led forum - so if you do not want help from the community please go to Fairphone directly - otherwise please be respectful here.

Can any of you post a screenshot of your issue? When you say the google installer is not working - are you saying that you cannot click on it, or are you getting an error when trying to run it etc?

Trying to run the update again may be necessary if it hasn’t installed correctly in the first place and if you are prompted to allow superuser access you also need to make sure this is granted otherwise the update won’t work correctly.

1 Like

Bingo! Running the updater a second time worked for me. Thanks @Robin and I hope this works for others too.


Same thing has happened to me. Am trying the install again.

I’ve run the updater again, and I’m in the same position. Clearly the update doesn’t seem to have installed properly, as my phone still looks the same before, just that all my google apps don’t work. I don’t understand a word of the “tutorial” and am somewhat lost. I seem not to have an update, nor the old system working…