Update failed, stuck in TWRP mode and not enough space to download zip file

Please help! The latest update didn’t work and took me to TWRP when I restarted. Now I can’t download the zip file (I suspect because there’s not enough space on my phone) and if I try to reboot it tells me there’s no OS installed. All suggestions gratefully received. Thank you!

19.11.2? Are you under Fairphone OS or Fairphone Open?

Can’t you download it on your computer and from here do an adb sideload (download it on your computer, in TWRP go in Advanced, ADB sideload and on your computer run adb sideload [filename].zip

Try nevertheless. Sometimes it’s just a false alert and at worse you’ll just end up on Fastboot mode or TWRP.


Thanks Alex! How do I know if I’m OS or Open? And how do I download the update file to my computer?

PS tried rebooting anyway and ended up back in TWRP

1 Like

PS worked out how to download zip file to computer but when I try to run it, windows says it can’t find adb.

If you didn’t make the change to FPOpen yourself then you’re under FPOS.
Did you install TWRP yourself?

You have to:

  • Download the Android SDK Platform Tools
  • Extract the downloaded ZIP file to somewhere you can find it
  • Open a Windows command prompt (cmd) or a Linux/MacOS shell and change into the platform-tools directory, which got extracted from the archive

(instructions taken from here)

Now when in TWRP try adb devices, you should get a device.
Then try again the instructions given above.

Otherwise you might find the zip file in the cache of your phone, then you can just flash it from TWRP (in TWRP go in Install, find the cache directory - I don’t remember where it is anymore - and see if the update is here).

1 Like

Thanks so much for your help Alex. It’s a second hand phone so I’m not sure what’s been done to it. I didn’t install TWRP so I guess the previous owner did.
I am making progress and have installed the sideload software but the phone is telling me that it was unable to find partition for path ‘/system’ and that the zip verification failed. It seemed to be downloading a file called package.zip, which isn’t the one on my computer. I’m not sure I’m doing things in the right order - do I need to swipe to turn on sideload on the phone then run the zip file on my computer?
Also when you said ‘when in TWRP try adb devices’, I didnt’ have a devices option, it only offers adb sideload. Thanks again for your help!

I believe your problem is the same (or very similar) as this one:

Please have a look and try what I and others have suggested over there. You might have to manually reinstall FPOS (:warning: in this case please do a #twrpbackup before, you will lose all your data!).

Yes. You first swipe to sideload on TWRP and then run the adb sideload [zip file] command from the computer.

Sorry, I have not been explicit enough: I meant enter adb devices in the terminal or cmd on your computer, and see if it outputs a device connected (just when being in TWRP).

1 Like

Alex, good news! I tried the cache on my phone as you also suggested earlier and it worked (I think I tried it before but checked the verify the zip file box and it didn’t like that). So my phone is back in the room. Thank you so much for your help, you are indeed an angel :slight_smile: angel emoji (not even tech literate enough to find an angel emoji…)


You’re welcome!

And if you want information about who #fairphoneangels are, just follow the link :wink:


Not relevant here anymore, but perhaps reassuring to others running into similar problems:

After manual installation of an earlier FPOS, all my data were still there - to my relief.
Always better to have a backup, of course.

Now I see that Alex’s link leads to a rather drastic installing from scratch. For (“just”) manual installation of the OS, see the FP support pages, and threads in this forum.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.