Update Aug 0129 Ambient light | Adaptive brightness

Terrible behavior! The Auto brightness feature is totally unusable this way. Why are things messed up with updates? I hate buying problems with others being solved. Can I downgrade?

1 Like

Hi Yes you can downgrade but it’s not automatic, you have to install an older version manually.

The downloads are available via


Ok the good news is that this morning the auto brightness seems fine.

I can cover the ambient light sensor and the screen is very usable, darkish as I would expect but would be good for the night.

Maybe the phone does have a brain or it just mine getting to see the light.

I am interested in what your phone does after a restart … Are the set values ​​saved?

1 Like

I haven’t restarted my phone for days, since I wanted to mess with formatting SD cards and had to remove the battery.

As things seem to be improving I’ll see if in another few days all has stabilised and then I’ll do a restart and update here.

I think sometimes it’s better to face the truth…

The problem with the truth is that it is relative to the enquirer. It is true for some that it is now daytime, for some it is night, for some twilight and for someone off planet they can see that each is true and false and not something they can decide or experience and hence know.

OK There is an official response to the issue that it is being looked into.


I have started getting this in daylight and artificial light. Most annoying. I will try turning it off and see what happens.

1 Like

Turning off the Auto brightness does avoid the problem, but is is being officially looked at.

However after 5 days mine has been stable for since yesterday evening. So hopefully there is some algorithm that I have managed to force into a useable function.

I should wary of speaking too soon, roll on the evening when the light dims.

1 Like

I don’t know what that’s supposed to do?
I’m waiting for a official fix …

1 Like

unfortunately that doesn’t fix the problem for me. :unamused:


Nice! :blush:
Then we have to wait and see first.


1 Like

Maybe solved in LineageOS 18.1, but it is just a guess:


1 Like


I have the same issue, and I only have it since the last update.

All workarounds I read here, are working for a day at the most on my Fairphone. The next day it re-appears at some moment. Especially, switching auto brightness off doesn’t help because my phone now adjusts its brightness even when I switch auto brightness off.

It’s annoying because it prefers to happen in dark on the go when I quickly want to look something up or call someone. Having to go to the settings and to find the brightness slider in the dark in order to see something at all, is a bummer.

I really hope they roll back this “improvement” as soon as possible.


The brightness is two fold.

The sensor takes a reading of the incident or refracted light and this is used by the Auto Brightness algorithm to decide how bright the screen should be.

There seems to be a problem with the interaction.
a) The ambient light sensor has been reading
b) The Auto brightness setting is over-riden somehow

Hi welcome to the forum

Yes that’s the most difficult part :slight_smile:

Yes, thats my favorite.

1 Like

Just had to do that again, so much for my previous optimism that I was it beginning to work :frowning:

Update: 4 hours later and is back to black


Thank you! I just applied you trick and it seems to work. :+1:

And now to something completely different. I tested you trick at 10:00 am. That gives me enough light to see every corner of my room. The Sensor reads 0. IMHO Fairphone needs better sensors.

1 Like