Unreliable notification LED

I love the FP3 notification LED, but I find it quite unreliable. Half the time I turn on the device to find I have notifications and the LED is been blank.

Is this a common issue? Any ideas how to solve it?

Is your phone up to date?
Otherwise, did you configure specific settings about the notification led?
Check this topic about notification led not working, though I’m not sure you’ll find anything interesting:

Thanks for the reply, Alex. Yes the phone is up to date and I haven’t changed any notification LED settings. (I didn’t know there was any.) The original FP3 notification thread (pre-notification LEDs) seems to go cold with the same issue… Maybe it’ll be fixed with Android 10?

Sorry to insist, but are you sure about that? There were some phones that didn’t show the update though there was one. The last update is A.0134.

You could check in Settings→Apps & Notifications, there you will find the settings, perhaps something was changed, you never know. Did you notice the problem with specific apps or with all of them?

I check and I’m on A.0134. Like the previous thread, it happens intermittently - for example WhatsApp will only work a third of the time.

1 Like

I’m the guy who wrote about the unreliable notifications in the original thread. The problem seems to have solved itself for me, the LED now works 100% as it’s supposed to. I don’t know why, there hasn’t been another OS update since then, I’m still on A.0124. Maybe all that was needed was a reboot; I’ve had other problems with the phone that a reboot solved. I now reboot the phone at least once a week just to be sure.


Thanks for the reply. I had rebooted it over the weekend, but I did so again today, and it does seem a bit better. I’m going to reboot regularly and will update this thread if I have any issues.

There is some stale LED notification related data somewhere. I upgraded to Android 10. The last LED notification before the upgrade was from WhatsApp (green). After the upgrade, Facebook Messenger would use green as LED notification color, even if befrore it was blue.

I did this as I responded to the thread:
I went to the LED notification settings for Messenger, turned it off and on again, some new notifications came and now it was blue again. Cleared the new notifications, some new ones came and now the LED doesn’t light up.

Stuff is wonky. ¯\(ツ)

Edit: Well, apparently enabling the light in the app settings and enabling the light in the general settings is not enough. I had to enable the blinker for each type of notification. And now the light is green again.

Are you sure LED notifications are enabled following the upgrade? I did a factory reset and I found it was not on by default.

Settings -> Apps and notifications -> Notifications -> Advanced -> Blink light

1 Like

Here we are!

I had the same problem, the LED not blinking, and I found this setting was OFF.

Thanks for solving my problem without I even asked for it.