English

Unknown Caller, unless 4G disabled

I have seen numerous threads reporting this issue dating from September 2020.

Now it hit me with the latest Fairphone update: No more incoming callers are displayed, unless I disable 4G/LTE. But this cannot be seriously the solution since 1 year ago for people experiencing this problem.

Especially since Vodafone currently offers to me (in my hometown Dusseldorf) only 4G or 2G. When I disable 4G I would have to use EDGE!

Any other workaround?

1 Like

No workaround yet except what you’ve already done.
See here and following: Software Update: 3.A.0129.20210805 - #59 by Sauerkraut

3 Likes

The same here since sept 10th. Tried several setting-changes with no result. I work with two sim cards. One shows the name/number of the caller, the other doesn’t. What can I do???

I’m closing this topic to keep all information in one place (which Volker linked to).

1 Like