English

UnifiedNLP (Gapps) appeared in Fairphone Open 21

On my Google-free Fairphone 2 with Fairphone Open OS, i had microG UnifiedNLP (no- GAPPS) installed and, as far as i know, it worked.
Now i found that ‘the system did not bind the UnifiedNLP service’ (a bug in FP Open that should be solved now) so i tried to re-install it. But that failed because there is already a 'UnifiedNLP (GAPPS) that cannot be uninstalled. And it even looks like this GAPPS version works.

Was this UnifiedNLP (GAPPS) installed by an update or did do it myself?
Does this mean that Google Application were installed as well?

I can confirm UnifiedNLP is now installed with FPOOS since android 9 (I have it under FP Open although I never installed it).

GAppS were not installed if you don’t have them in the list of your applications (Settings→Apps and Notifications→Show all xxx apps→(Three dots→Show system), you can check yourself).

2 Likes

Hi Alex,
Thanks for the confirmation that it was installed automatically. Fortunately, i still don’t see any Google apps installed. Actually, what i worried about was not the apps but Googles Services, but i guess it would have shown up in the list as well.
Maybe i misinterpreted the two versions of UnifiedNLP. I read “UnifiedNLP (GAPPS)” as a version that depends on Google Services as a location provider, but it could also be a version that is able to serve Google Apps. In that case, it is explicable that the GAPPS version was installed and that it works without Google Services being available.

1 Like