English

"Unfortunately, System UI has stopped" - what next?

My phone has been in a random reboot cycle, but I can’t do any of the suggested checks to the software etc (after having already removed cards etc to check if they were causing the random reboots) because it now is stuck on the error message “Unfortunately, System UI has stopped” with no way to go past that

Even when starting in safe mode it remains stuck with this error message
…any suggestions?

as said, I’ve done all I can from the troubleshooter, except for clean the contacts - as I feel this has to do more with a software issue than a hardware issue (see my previous post about trying to migrate whatsapp history - i.e. I think my model is flawed, but wanted to check here if there have been any evidenced based fixes to this system UI issue - in the meantime I’ve reached out to FP to ask for a replacement, based on this and my previous post…fingers crossed)

I’d try clearing the system cache in #dic:recoverymode and if that doean’t help I’d manually reinstall the OS. Both shouldn’t delete any userdater, but a #dic:backup is always a good idea.

1 Like

Thanks Paula, I’ve managed to enter discovery mode but wasn’t sure which option was for clearing the system cache… nevertheless, still stuck on the same error message when I restart the phone.
Are they any other options within discovery mode worth exploring?

Otherwise - can you advise how to manually reinstall the OS? I can only find articles to the FP1 in the support section of the site.

Thanks!

What options are there. I have to admit I haven’t seen standard FP2 recovery mode for a long long time.

A guide to reinstalling the OS can be found here:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Hello Fairphoners,

Today I have tried to update my Fairphone 2 to the new 19.08.1 version, but after the installation (with the terminal method in Ubuntu) it could not start properly. The animation is shown, and after a minute it goes into a continuous loop of ‘System UI has stopped’ messages with apart from that just a black screen. I have also tried installing the 19.05.3 and 19.02.1 versions, but I have the same issues with those as well.

On the forum I found this post, in which it was suggested to clear the cache in recovery mode. The described method suggested there does not work on mine. I get a screen with ‘teamwin Recovery Project 3.1.1-0’ and the device does not react to any buttons (or the touchscreen). I have tried to open the manual on recovery mode, but when I try to open it, I am told I am not authorized to see it.

I tried finding out if I can somehow clear the cache via terminal on my computer, but as far as I have found it was only possible in the settings of Fairphone OS (which I couldn’t access because the System UI could start). At this point I thought backing up and a factory reset would be the best option, so I tried to backup with TWRP using the ‘How to use TWRP without flashing it (e.g. for Backup)’ method (sorry I can only put in two links), I used the signed img file and got it to start with fastboot. However, even though I had it constantly hooked up to my 2.4A charger, or my laptop, it turned off. The charge it had when I started the backup first was 77%, after about three hours this was down to 1-5% based on the red LED. Miraculously, it rebooted normally into Fairphone Open OS 19.08.1 after it had charged enough power again. Everything is still there, however I now also have a Google play store now. Probably still a good idea to make a backup now anyway…

Something must have happened during the last step, I’m sure because I accidentally forgot to press volume down before powering it up for fastboot, and it went into the System UI not working loop.

The troubleshooting took me about four hours, but even though I solved it myself (apart from the Google infiltration now, but that’s after my phone’s and my own overnight charging) I thought it’d be better to make a post about it on this forum anyway so it can maybe help others :slight_smile: