Unfortunately, Fairphone Updater has stopped

Hello, I delayed installing the latest version of FP1 OS, & now I keep getting the message “Unfortunately, Fairphone Updater has stopped”. So it seems I can’t now do the update.

I found a query on just this topic &, as suggested with the clear instructions, I cleared the cache. This doesn’t seem to have been enough. Hugo_Buddelmeijer, who asked about this before, said he had to clear data as well. I’d just like to check what this does before doing it: I’m nervous when I get messages saying:
“All this app’s data will be deleted permanently. This includes all files, settings, accounts, databases etc

I have Fairphone OS version 6 (FP 1.8.4)
Fairphone Updater version 27 (FP 1.8.4)

I’ll be very grateful for any help so I can get the latest OS installed before its lack causes any problems. Many thanks, Andrea

You could try to manually install the update.

1 Like

Thanks Paul. I’ve now been going through the procedure to manually install the OS. I have downloaded the files to my computer; but when I connected my FP & tried to copy the files to it, I get a message saying:
“Cannot copy: the device has either stopped responding or has been disconnected. The camera may not support copying files from your computer”
& in fact, the symbol on my file manager made me think it didn’t recognise my FP as a phone but thought it was just a camera.

Again, really grateful for any help - many thanks,

When you connect your phone to your computer there should be a notification (slide from the top down to get to it) which will let you choose USB connection methods. Connecting as a camera is one option but you should choose MTP.

1 Like

Many thanks again Paul. I have now downloaded the file to my phone & gone through the procedure for manually installing OS 1.8.7 as far as reinstalling Google Apps.
When I try to drag the widget to the home screen, I get a message saying “there is no room on the home screen” even though it looks to me virtually empty. How do I resolve this: are there perhaps widgets tagged to the screen somehow without me realising, in which case, how do I rationalise them?

Many thanks again.
PS I was puzzled also that when I checked (under settings) what version of the OS the phone thought it had, it was still saying 1.8.4
Also, the Fairphone updater is still not working, though perhaps Google Apps sorts this out?

By long tapping on a widget on your screen you can change its size. But you can also drag the Google Apps installer widget to another screen with more empty space.

Also reinstalling GAPPS now works without the widget: Just open the updater app and navigate to advanced mode > App stores.

Many thanks Irina & Paul: step by step I’m getting there, so thanks for your patience!
In fact, when my phone switched on this morning, the widget had arrived on the home screen, so when I had WiFi available, I selected it, then got the message:
Unfortunately, Fairphone Updater has stopped.

So, it seems having the new OS installed hasn’t got the updater working again; & it seems Fairphone updater is needed to reinstall Google Apps.

Also, when I switch my phone on, I now also get the message:
Unfortunately, Google Play Services has stopped.

Any ideas about how to get both Fairphone updater & Google Services operational again will be greatly appreciated.
Thanks so much,

You might have a look at this topic: Google Apps can’t be reinstalled. I’m not really sure if there’s the solution in it, but I think it’s worth a try.

Many thanks, Irina & I’ve now had a good look through this.

It seems my basic problem is that Fairphone Updater stopped updating & even after manually installing the newest version of the OS, FP Updater is still not working, so I can’t get Google Apps working.

Does anyone have any ideas as to how I can get Fairphone Updater working again?
Many thanks.

Normally I’d say installing the OS manually should do the trick, but since you already did that you may need to make a hard reset after doing a thorough backup.

So sorry to be taking ages over this: I’m not technically adept & really busy workwise…

I have now loaded Titanium & done some of the backups. When I start Titanium, however, I get a message:
Warning - System
Your system settings may cause problems. To correct this, go to your phone’s Settings, then in “Applications” then in “Development” and tick the “USB debugging” checkbox.

Problem is, I go into Settings, then Apps, but can’t then find “Development” as an option on my Fp. Does it go by another name on Fairphone?
Thanks again.

In order to enable the developper options, you have to tap 7 times on the build number (settings>about the phone).

Thanks so much Irina. What shall I do to exit developer mode when I’ve completed all the Titanium backups?

Nothing. It’s not necessary to disable it. Just don’t play around with the new options, unless you know exactly what you’re doing…

1 Like

I’m ecstatic! I did a hard reset of my phone; after which not only was Fairphone Updater working but it indicated I now have the up to date OS - 1.8.7! I thought I’d have to install this separately.

As Updater is now working, I have also been able to install Google Apps.

Next thing is to do a system restore from the backups I created before the hard reset. I had manually backed up files to my PC but had also done backups via Titanium. So, I downloaded Titanium to my phone again, but when I try to do the restore, it is saying against every app that there is “No backup yet”. I’m really puzzled as I did a comprehensive Titanium backup to my SIM, which I wouldn’t think would have been affected by the hard reset, so I would have expected to do a restore from the SIM.

Is it because I had to reload Titanium that it doesn’t have a pathway to the backups? If so, how can I direct it to the backups which I presume are still on the SIM?

Thanks as ever.

On the SIM? I guess you mean on the external SD card…

I think the best thing will be to find out on the Titanium Backup web site how and where the app stores its files.

Yes, sorry, the backups are done to the SD card. Does the Fairphone hard reset wipe the SD card?