"Unfortunately, clock has stopped" and clearing cache doesn't help

Hey all, posting here because I’ve seen some similar posts (other apps stopping), but not this one, and the suggested solution doesn’t work.

Open OS 17.06.04, installed after a clean reset due to the same problems everyone had when upgrading, on FP2.

Occurs when:
Open clock, tap onto globe icon at the bottom, which should normally allow the user to select other locations.

Suggested solution:
The suggestion usually given is to clear the rogue app’s cache by accessing Settings -> Apps -> All apps -> *Rogue app -> Clear cache (see here ).

1- Settings -> Apps -> Clock -> Storage, and from there, since “clear cache” was unresponsive, I hit “Clear data”.
2- Tried again to launch clock, tap globe. Same problem.
3- Restarted. *(which, since the reboot button was removed - why??? - now requires turning off, waiting, and then turning on.
4- Tried again, same as 2. Same problem.

Anyone have suggestions?

Please continue the discussion in the topic linked above…