English

Unexpected reboots and dual SIMs

Hi all,

I bought my FP3 for Christmas 2020 and since the beginning I had a problem of unexpected reboots (around 5-6 times a week).

I opened a ticket but after three months and a half of testing (and one pit stop in the Fairphone technical lab) I realised the problem depends on having two SIMs in the phone.

There is another topic similar to this in:

https://forum.fairphone.com/t/fp2-reboot-due-to-dual-sim-cards/28608

but it’s closed and it relates to FP2.

I’ve tried many combination of SIMs and slots and these are the results (below I’ve named my two SIMs, “SIM1” and “SIM2”):

Slot1: SIM1
Slot2: SIM2
around one reboot a day

Slot1: SIM2
Slot2: SIM1
around one reboot a day

Slot1: SIM1
Slot2: empty
no reboots

Slot1: SIM2
Slot2: empty
no reboots

Slot1: empty
Slot2: SIM1
no reboots

Slot1: empty
Slot2: SIM2
no reboots

So I’m pretty sure the problem is linked to having two SIMs in the phone at the same time.

In the thread I linked above apparently the problem was solved configuring SIMs to only use 3G instead of 4G. However, I don’t want to loose the possibility to use 4G and I’m not sure that a FP2 workaround could work on FP3 as well.

Did anybody experience the same issue? If so, have you find a way to solve it?

Thanks.

Regards,
Massimiliano

1 Like

Thanks for your data. I don’t use two sims but am interested. I imagine you have to select which sim to use, so is there more data to be discovered/shown depending upon which sim and slot is being used?

or are both sims active ?

In the configuration menu you can enable mobile data on both SIMs but I don’t know how it works (it would be nice to know) as I only use one SIM for network connection.

At the moment I can’t experiment because I’m trying to figure out how using 3G or 4G impacts on my problem but I’ll give it a try sooner or later.

I’m now playing with the “preferred network type” parameter (in “Network & Internet” → “Mobile network” → “Advanced”).

I can update above data about when reboots occur.

The tests above with two SIMs were carried on setting both SIMs with “preferred network type” to “2G/3G/4G auto” (and I had reboots, as I wrote in my first post).

Following a suggestion from the quoted FP2 thread I tried using two SIMs setting “preferred network type” set to “2G/3G/4G auto” on first SIM and “preferred network type” to “3G only” on the second SIM and with this configuration I didn’t have reboots.

So apparently the workaround found on FP2 works on FP3+ also (which also could mean the problem experienced on the FP2 is still around, despite the time that is passed).

So, a better workaround than removing a SIM is setting one SIM in “3G only” mode. This way I can connect to the internet in 4G through the first SIM and have both SIMs available for voice communication (without having reboots).

I’ll go on testing and posting results.

Ciao,
Max

1 Like