Unable to install Nova Launcher on FP5

Hello,

I have recently bought FP5 and so far I am setting it up. I don’t like the google search bar on the home screen, so I was looking to install different launcher. I wanted to install Nova launcher, but in Google play store I am unable to find it (when using my FP5). I can find it when accessing play store from PC, but here it says I can only install it on some of my devices (I have Nokia 5, which apperently works and Samsung S10e which also shows not possible to install there).

I can find Nova launcher Prime, but I would prefer to try it first before spending any money on it.

The same issue I have is for Lawnchair, which was my second option.

I can read here in forum that lot of FP5 users use Nova, so probably won’t be a compatibility issue.

Anyone have any idea on that situation plase?

Thank you

2 Likes

Hi,
I use Nova Launcher and I can also find it in the Play Store.

You could try the Google Play link on https://novalauncher.com

On this page you can download Nova apk for side loading (both the stable and the beta apk, not just beta) Beta | Nova Launcher

on my FP5 not problem with find/install/use Nova Launcher or find Lawnchair (not think be stable as old from 2019, maybe this newer alpha )

EDIT: maybe you can’t install to your FP5 because combination of some limitation in your country? you can try find/install over wifi with mobile data disabled (maybe for sure whole sim disabled)?

let me just confirm that I also cannot install it directly from the google store. It says my device is incompatible.

Maybe you try the beta program. I guess Nova is just not marked to be A13 ready. The last regular update is from 2021. So it might just be necessary to find a new replacement for the launcher. This is really sad as I use it from day one on Android (back then I had a Samsung Galaxy S)

I tried the link directly from their website, it only redirects me to google play and the issue is still the same.

Will try the sideloading though, I thought the link is just for beta version .apk. How is it with updates, will it go through google play, or I’ll have to update it manually?

There might be some limitation, but I can not find out what these are (if any). I don’t have any SIMs in the FP5 yet, so downloading through wi-fi.

It makes no sense to me why there would be any such restrictions, but probably they are. Thanks

you right, i’m in Nova Launcher Play Beta where is 7.x and next sideloaded 8.x which is not yet in Play bete, only on Nova Beta homepage 8.x is still in development, but only problem i have with it is in Landscape is Dock on side, but Dock-Background keep on bottom, and also swipe for open drawer on Dock icon is problematic as swipe is wrong coordinate/direction, in Portrain is all ok

No on that beta page there is a link ‘download the stable apk’ which downloads the current stable version, 7.0.57

1 Like

this i know, i mean beta 8.x is only avaiable via beta (with stable) page, and on oficial PlayStore Beta channel for Nova Launcher is beta 7.x (not sure if actually is any 7.x beta > stable verstion avaiable) :slight_smile:

1 Like

yeah I was answering @Broupal who said they thought the link was just “for beta version .apk”.

First of all, as far as I’m aware, you can get rid of the search bar by disabling the google app and the reboot the phone! (The last step is important)

Your other problem is quite weird. Since lots of fairphone owners had no problem installing nova launcher, the problem might be with you specific. Some apps can be region locked, I doubt nova launcher would be, but might be a possibility.

Otherwise I’d maybe either reset your phone completely or maybe even reflash the original operating system, if that is a possibility. Weird issues like these, could indicate that someone messed with the device before you got it. Also pretty unlikely, but a possibility.

I think one option would be to use the Aurora Store app to anonymously download Nova Launcher from Google Play when you fake your phone model in the settings of Aurora. That way I was able to download some game that officially was incompatible with my FP3 but ran ok once installed. Had to try different fake model settings before I found one that worked.

Of course that would only help if it’s actually the phone model causing the incompatibility and not something else like regional restrictions.

If you have a (64 bit) smartphone where Nova can be installed, you could also pull the install file with adb from that other phone and install the APK on the FP5.

Not sure if Google would ever answer but you could write them and ask why you can’t install the app when you know of other FP5 users who don’t have this problem.

Why don’t you directly install it from the website?

Hello and thanks for all advices,

I downlodaded and installed .apk from from their website and it works.

4 Likes