Unable to download or save photos + screen flickering issue

Hi, my FP2 is playing up, yet again.

After having my 3rd bottom module installed in less than 18 months, after 2, possibly unrelated weeks, I cannot save or download photos. At first I was getting a USB Storage error (my phone was not connected via USB to anything) and this error would come and go.

At present, if I take a photo (I use Open Camera) I get a message on screen saying ‘Failed to save photo’

If I try and download or take a photo in WhatsApp I get a message saying ‘Download Failed - Can’t download because no internal storage is available. Please unmount it as a disk drive, and try again’

I am using LineageOS 16.0 (just updated to 13 February 2020 to see if that fixed it, no) - lineage_FP2-userdebug 9 PQ3A.190801.002 59db936275

I honestly seem to go from one issue to the next and I’ve had enough messing around now. I want to do the right thing and support FP2 and the sustainable, modular approach but I am spending more time trying to fix issues than actually use my phone at present.

Addendum +30 mins from post:
The storage function no longer works, if I go to Settings, Storage it keeps closing. Cleared cache/data, restarted phone. Same thing

If anyone can please help?

Thanks

Did you keep your SD card as external storage when changing to LineageOS, or did you incorporate it into Internal Storage again?

The card might be failing, and in case it is as a part of Internal Storage the
whole Internal Storage could be failing now.

1 Like

The thing is, I have NEVER set my SD card as internal storage, every time I’ve had to set it up I have ALWAYS set it as portable storage. Hence my surprise last year when I had to repurpose it from internal to external…I hadn’t set it as internal in the first place.

I’ve had lots of issues with SD card and to be honest, because of the other issues I’ve had, I assumed it was the phone causing the issue - which may well be the case because how could my SD card be set as internal when I would and never have set it up that way?

To also add that I have used a different SD card and have the same issue too. Again, I set this to external storage as I always do. Is this an unrecoverable error or would I need to do a full wipe and install to fix this?

Thanks - really confused

S

Ok, so it doesn’t seem to be the SD card.

I think you need to do a full wipe and install to further diagnose this. If the issue remains after that, this would hint at hardware trouble. If the issue would be fixed after that, it would have been software, which would be the lesser evil now.
Be sure to format Data in the process … (and install your LineageOS ZIP file instead of the Fairphone OSes referred to in the guide) …
If you really want to exclude a software problem, I think it would be a good idea to format System, too … I wrote a little Addendum to the guide on how to do that in TWRP …

Thanks @AnotherElk I am now back up and running but lost all my data as I could not back anything up! SD card has stayed showing as portable for now so fingers crossed.

Screen still flickers occasionally so will see how that goes.

The issue I have now is I cannot install Titanium Backup and other apps that require root access as it says my device isn’t rooted. I have enabled developer options, selected allow root (adb only) and have also installed SuperSU but when I try to give root access to the app it says phone isn’t rooted.

If I search for the SuperSU app it says it isn’t installed even through TWRP says it installed successfully - any ideas?
Thanks

s

I have no experience with SuperSU.

Up to 16.0 LineageOS provides addonsu, which I always used to root without a problem. For LineageOS 16.0 on the Fairphone 2 this would be addonsu-16.0-arm-signed.zip, which can be installed with TWRP.

From 17 on, LineageOS will refer to Magisk for rooting …

Thank you, had just found that - installed Magisk, must have been as you were typing! Also updated to latest version of Lineage as the version from 4 days ago wasn’t letting me install any zips from within TWRP

All done - thanks as always for your help

S

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.