UBports works or not? - Problems with installation

Hi folks!
I have the Fairphone2 with Android 6.0.1. I would like to install the UBport, but I didn’t manage, the phone frooze and I had to install the Android 6.0.1.

I didn’t find if it possible to install the UBport or not!

Does anybody now…?



1 Like

Did you try this:


or this:

It definitely is. 1240+ FP2 users are running ubuntu:


Hi @raphael68 !
Yes indeed UBports is working fine on my FP2 :slight_smile:

As I already mentioned here, I had trouble with the UBports-installer so I used the CPT alternative installer.

Do you have a recent FP2 (shipped in or after summer 2017) with the new screen ? If this is the case, you’ll have to install the devel channel as the fix are not yet pushed to stable OTA-2… (or wait for OTA-3 as it will come soon :slight_smile: )

If you need any help the UBports community can help you on their Telegram group !


Hi @oli.sax!
Thanx for your reply, I tried it with the CPT, but the install-process it last too long (downloading …) and nothing happened. Is it normal that it lasts so long?

1 Like

To install UBPorts, you can choose between three tools : UBPortsInstaller/CPT/MDT.

However, a common prerequisite is (1) to enable developer mode/ADB debugging on device and (2) to install ADB drivers on computer.

(1) Go to settings, scroll all the way down to About this device (or about this phone) select that, scroll down to build number, and start tapping that fast over and over until it says you’ve unlocked developer
Then go back up one level and now there is a new menu option called options for developers. Select that, then scroll down to USB debugging, switch that on.
Now adb should work on your phones side.

(2) To get adb on your linux pc working with FP2, follow those instructions:
sudo apt-get install android-tools-adb android-tools-fastboot
First you have to install ubuntu-phablet-tools:
sudo apt-get install phablet-tools
Than you have to add your device to your desktop. In my case for the Fairphone 2:
echo "0x2ae5" > ~/.android/adb_usb.ini
Then you have to kill the adb server:
adb kill-server
And than with adb devices you get your adb device listed.

(2b) To get adb on your windows pc working with FP2, follow this other guide.

1 Like

Hi again and thanx for your patience!

I did the adb-things you suggested, the system says at the end:
List of devices attached
20ecb6ec unauthorized

Then I started cpt, cpt told me to connect the device and to boot in fastboot
mode, what I did. The result is as before: The Phone is wiped, and then the process stacks like you see on the

What did I wrong?
Regards again


Hey there,

sorry to hear you’re experiencing problems. Could i ask you to try again using the UBports Installer, since i worked on that and it’s a little more sophisticated than CPT and MDT, it’s easier for me to support you. You can download the latest version here: https://github.com/ubports/ubports-installer/releases/latest. On the first screen, it will ask you to enable developer mode on your device, make sure you follow the instructions carefully.

If you continue to experience issues, please keep us in the loop.

When you plug the USB cable, look at your device screen : you should see a pop-up asking if you trust the fingerprint of your computer. After accepting that, it shouldn’t be “unauthorized” anymore :slight_smile:

1 Like

Hi! Thanx for your advice, but the same problem as before: UBports Installer was started, all instructions I followed carefully. And then:

The phone was connected of course with USB, but nothing happened during the next hour …
But luckily the phone was not wiped like with the cpt before. What I do not unterstand: When I made a setup (after wipe) with the script out of FP2-gms-17.11.2-manual.zip (I did it in windows) , this worked…

Thanks, I did it. And now?
I don’t want to use the CPT again, because until now it didn’t work, wiped the phone and I had to set up it again and again and again with the script inside FP2-gms-17.11.2-manual.zip (I did it on a Windows System…)

I just suggest to authorize first, check that adb see your device correctly, then try UBports Installer again.
Hopefully UBports Installer will detect your device then!

Hi again!

That’s what I did, but the same: Device is detected by UBPortsInstaller, but then again (see Picture above): more than one hour an no result…

I’d use the RC channel, because the devel one is too much pain for a daily use :wink: By the way, for more informations about channels, you can visit this page @raphael68 : https://wiki.ubports.com/wiki/Release-Channels

I just tried with the Windows installer 0.1.9-beta from https://github.com/ubports/ubports-installer/releases and successfully installed the 15.04 RC channel.

Basically these were all the steps I took:

  • Enabled developer mode
  • Enabled USB Debugging
  • Connected the FP2 via USB
  • Allowed my PC to access the device and marked the checkbox to always allow it
  • Changed the USB mode to MTP (default was charge only)
  • Started the UBPorts installer and followed the instructions

A small video of the result is here: https://twitter.com/Ingo_FP_Angel/status/940683079047360513


Glad you succeeded @Ingo !
Did you also installed ADB drivers for Windows or it was not necessary ?

1 Like

I already had them installed previously to install LineageOS. So I can’t say if it would have worked without them.


Hooray it worked!

I made the whole thing on another Laptop (same ubuntu configuration) with the adb-things and the ubport-Installer…


Hallo I also need Help with installing Ubuntu touch on my new Fair-phone 2 with 12mp Camera Module.
I tried to install it several times did not work out. I did in on a win 7 system with CPT Installer but the installation went wrong (aborted at maybe 30 % of precess. Now I’m not able to start android or ubuntu or anything else. I think it only starts in bootloader mode but I’m not sure. There are two modes fist is the logo as in bootloader mode and second is black screen with only flashing a little red LED when I try to activate bootloader mode whit pushing Vol. down and Power button an same time.
Now I’m on a ubuntu running laptop tried UBports, CPT and magic device tool but all 3 are not able to detect the phone (in bootloader mode)

Can anyone help me, please?

I moved your post here as - even though the title doesn’t suggest it - this is a more recent topic discussing the same. Maybe you find some answers in the posts above.

I’m not sure I can help. First thing I would try is to check if in either of those two modes your FP 2 is seen by one of the following commands

adb devices
fastboot devices

How to set up those if youi haven’t yet can be found at https://wiki.lineageos.org/devices/FP2/install