UBPorts 16.04 updates + feature tests

I finally installed the Ubuntu Touch on my FP2. I have been wanting to do this for ages.
I installed it through my mac through the ub ports installer. it was easy.

I am coming from Lineage OS 16.0. During the installation proces, I wiped the storage and continued with the installation.

The system reacts slow…I will keep testing it.
Do I need to install anything else? like modem files? or some other thing?

Thanks for your answers


The latest real update to the modem files was April 2018 IIRC so I guess you already have those(?).

And yeah, compared to Android, UT feels rather slow, especially app startup times.

1 Like

Ubuntu Touch OTA-11 is out, featuring the most natural text manipulation you’ll ever use on a phone.


#UBports #UbuntuTouch #OTA11 #Blog

1 Like

The new Mir and Unity8 should come for OTA12 :smiley:

Edge Successfully Merged Into Development Channel

In the last few days the Edge channel has been successfully merged with Development bringing the future Ubuntu Touch ever closer.

If you want to try Mir 1.x and Unity8 (2017) on your device then update to Dev using System Settings Update or the UBports Installer.

Please remember this is not suitable for your daily device yet, but by trying and reporting any issues you help make that happen.

Further info here:

Issue Reporting here: https://github.com/ubports/ubuntu-touch

#UBports #UbuntuTouch #Edge #OTA12 #Ubuntu


I switched to the dev channel and now have the new launcher, it’s pretty cool. I don’t have more bugs than on the stable channel at the moment (one day test only). I use this phone as my primary device because YOLO.


After ten days of use, I can confirm than the switch to the last Mir + Unity isn’t less stable that what we currently have in stable or release candidate. So if you’re curious, jump ahead, you should be fine.


People in the UBPorts telegram group and forum are asking about Spotify a lot and I had it running on my FP2 once with anbox. But I either uninstalled it or did a fresh OS install, don’t remember. At least I didn’t have it on the phone anymore.

The problem now is that Spotify is a split APK and IIRC it used to be a single file when I last got it to run with anbox on UT. It’s less straightforward than before but it still works:

1. Pull the APKs of your Android phone
Connect your Android phone with USB debugging enabled.

Get the package name of Spotify:

> adb shell pm list packages | grep spotify

Get the file location of the APK:

> adb shell pm path com.spotify.music

Pull all the files to your computer:

adb pull /data/app/com.spotify.music-PrDoHptneXuzOEGlVbRlqg==/base.apk spotify.base.apk
adb pull /data/app/com.spotify.music-PrDoHptneXuzOEGlVbRlqg==/split_config.armeabi_v7a.apk spotify.split_config.armeabi_v7a.apk
adb pull /data/app/com.spotify.music-PrDoHptneXuzOEGlVbRlqg==/split_config.de.apk spotify.split_config.de.apk
adb pull /data/app/com.spotify.music-PrDoHptneXuzOEGlVbRlqg==/split_config.xxhdpi.apk spotify.split_config.xxhdpi.apk

2. Push the APK files to the UT phone
Now disconnect your Android phone and connect your UT phone with USB debugging enabled.

Push the files to the phone:

adb push spotify* /home/phablet/Downloads

3. Install the APK files on the UT phone
While the UT phone is still connected via USB, first open a shell on the phone:

adb shell

Next commands are executed on the phone!

cd Downloads
adb install-multiple -p spotify*

That’s it!

Unfortunately the new app drawer (which has replaced the old app scope) doesn’t refresh and I don’t know how to refresh the installed app icons manually.
So it seems you have to reboot the UT phone before you can tap on the Spotify icon and start listening to music.


You should probably add that to docs.ubports.com too :wink:

I’ve posted it to their forum, too. Should be sufficient IMHO.

1 Like

News from the UBports Q&A 66 (around minute 21) : Halium 7.1 is progressing on Nexus 5 and FP2 (Ratchanan is working on it :slight_smile:), going towards a better hardware compatibility (a.o. proper support for the new selfie-module) :smiley:

Flo showed a Nexus 5 running Halium 7.1! That is of course a core device. Some things are not fixed yet but it is well under way. It will mean better drivers and APIs for the camera etc so some big improvements can be expected. Ratchanan is doing something similar for FP2.

EDIT: you can follow his progress here:

EDIT2: There is also a post on the UBports forum:


Just wanted to say that I have been following UBports for some time now and wanted to try it on the FP2. I just had the opportunity to buy a very cheap Nexus 5 to play around. I will do that to check if I could depend live with Ubuntu touch.
I have installed 16.04 dev very easily with the installer (only one problem: the phone kept disconnecting. A message from the installer advised to change the cable, which I did, and it was actually caused by the original Nexus 5 cable).
I have played a bit with it: apps from the open store, messaging (Teleports), email (Dekko), calendar (Owncloud account), maps (uNav, haven’t checked Pure maps, have you?), … I have no SIM yet, only Wifi.
Now I am on stage 2: I installed Anbox and will test some apk. The installation didn’t work at once following the official documentation. I lost the wifi signal and couldn’t update the list of packages available (sudo apt update). But I managed to install Anbox following this video (someone from the UBPorts’ forum).
I managed to install F-droid. Nothing more yet, it was late… I will have to wait until the week-end. F-droid works, I have installed an app (Aurora), which didn’t work well. I have successfully deleted it then. I will now try to install apk’s from my FP2.
Did someone try to use F-droid’s nearby function?

Didn’t work for me either. It only updated after reboot.



Most of the times it is sufficient to restart unity8, you can use the UT Tweak Tool from [http://open-store.io], you’'ll find this in “System -> Tools ->services(? Dienste in german)”, it will refresh the App Drawer icons an make new ones visible…

Thanks for the tip! Would disabling Anbox and enabling it again also work? I don’t use the phone that much, but if I used it as a primary phone, I think that I would disable Anbox when I’m not running Android apps to save the battery.


Well, I don’t know. Actually, apps installed via f-Droid in Anbox show up immediately on my phone, it runs the rc-channel-version 66. I had this problem with Libertine programmes.

Disabling Anbox when not in use is a good idea - I just published a neat way to do it with an Icon in the App Drawer to dis-/enable it again on https://wiki.ubuntuusers.de/Ubuntu_Touch/Anbox/#Automatisches-Umschalten-per-Icon. Is it german though, but I guess you could get the hang on it by reading the code - if not, just drop a line here, and I’ll try to lend a hand…

1 Like

Hi, Thanks for the tips.
When I enable/Disable from the terminal, it works.
I have tried your script but had many problems. I forgot to think by myself, so I made all mistakes that could be done…

  1. I did a copy-paste of your codes, but you made a mistake for the file name: " anboxtoogle.sh" instead of “anboxtoggle.sh
  2. then I failed to make the script executable from my mac so I had to do it on the phone, in the terminal, to be able to see the icon in the app scopes
  3. the image name is Anbox_logo.png, but in desktop-file it is Anbox_logo.png. After changing the capital on the phone using the terminal, I could see the icon (before there was only the name of the app in my drawer, but it was still clickable).

Everything should work now, but it wasn’t conclusive. Anbox is always enabled. When I click the icon, a black screen appears with “Anboxtoggle” as a name, and it closes directly afterwards. Launching F-droid works. In the terminal Anbox-tool status shows that everything runs. I tried several times. I even restarted.
Can you think of something I did wrong? The script launches, but it fails to disable Anbox apparently.

btw using the terminal to enable and disable is not that hard, so no hurry!

1 Like

Ooops, sorry about the typos, corrected those on our website…

The behavior you describe sounds like being correct; the black screen disappears as soon as the script is executed, and that takes only a short time…

The desktop file is executable as well?
Could you post your version of the script and the desktop file here? - with their respective names? Perhaps it’s just a little thing…

I tried to toggle the icon as well, but seem like it doesn’t work out… Perhaps someone at UBports knows about that: https://forums.ubports.com/topic/3943/refresh-icon-view-in-app-drawer-in-real-time

As a workaround you could use two different icons, with the scripts attached to it just enabling or disabling Anbox,

1 Like

Thanks for the help!
I forgot to make the desktop file executable…:sleeping:
Now I could do something… but not the right thing. Anbox didn’t work anymore, but I couldn’t turn it back on with the script. The terminal showed:

Kernel: OK
System: OK
Enabled: YES
Running: NO

So I tried to disable and enable Anbox directly from the terminal and I had to give my password. I guess this is the solution, isnt’ it? The problem is that I need to root the phone permanently because the script can’t put the password by itself.
If so, and as I don’t really need to root the phone for anything else right now, I guess I will leave it that way and use the Terminal to temporary disable Anbox if I need to.

Thanks for your time and sorry to have bothered you because I didn’t read everything corretly.


No sweat, fiddeling with Ubuntu Touch is about all I do these days :wink:
It probably is a rights issue - I actually do have r/w access enabled on my phone permanently. So I’ll try if it works without it and if it doesn’t I’ll add that to the description. I guess that is more or less the equivalent to having a rooted phone on android…

EDIT : Looks like it works without r/w access as well.

I’ve seen that you’ve fixed it. I just installed if anew and everything works. I don’t have the root-problem anymore.
I guess that I did something wrong the first time.
But everything works now and I like the color change!
Thanks for all the work!

1 Like

Hello, I am thinking of installing Ubuntu Touch in a few days. How well does the system work in FP2?