TWRP for Fairphone 4

Hi and welcome, no answer to your question, however:
I dont see the FP4 officially supported on the official TWRP page?

So what is your information based upon?

https://twrp.me/

It isn’t. (Currently.)

So, this would be a question for an alternative solution?

Open Android Backup or ABRT perhaps?

If so I think we should just move it into another topic, as its not really related to TWRP which its still not officially available for the FP4 which was what I was wondering, as sure TWRP 3.7 itself is there, however this topic here is about TWRP for the FP4.

I’d like to report… that fastboot isn’t working on TWRP 3.6.2 20220602!

I does boot into fastboot but via USB, there isn’t anything happening…
I can switch to ADB, which works but fastboot doesn’t…

So, as i understand, the /data folder isn’t encrypted on my FP2. What would happen, if i overwrite my /data folder on my FP4 with that of my FP2 using TWRP? Would this work or do i get problems because of the absent encryption?

Either it get’s encrypted or will be unreadable for Android

That depends on how you do it. If you do a clean flash and copy the data then. It could only get encrypted, however, probably won’t boot if you have different ROMs on the phones. If you have a running FP4 and copy the data, I think it won’t get encrypted and will just stop working.

I have ‘some’ experiences with porting TWRP on MTK devices… would it be possible to port a TWRP image of another QCM 750G device to FP4?

I ask because I never faced fastbootd before and I think, that just porting TWRP to FP4 wouldn’t help about /data encryption or the issue I had that fastboot wasn’t detected on PC…

My fastboot is detected without a problem. I think porting might help if the ported device got encryption working. But MTK devices are entirely different. I only have experience with compiling ROMs and playing around, but I never accomplished something unfortunately…

BTW… why isn’t a recovery partition present in fstab? Does every a/b device only have a boot partition with recovery implemented?! :scream:

Also I see that /data is formated in f2fs… and maybe… TWRP doesn’t (still) fully support f2fs … last time I ised that was with my Galaxy Nexus i9250 … 10 years ago…

The internet has references to devices with “recovery_a” and “recovery_b”.

But if those are not there, embedding TWRP into the boot partition(s) it is, it seems (like e.g. on the Fairphone 3, too).

I just reflashed TWRP with MD5 check and still fastboot isn’t working :confused:

But while playing with the hardware buttons, I discovered the QLM recovery mode, something I only knew from MTK!

1 Like

Guys, just saw that the Galaxy M23 5G have the same SoC like Fairphone 4 and is officially supported by TWRP!

You might want to take a look into it and try to port it for the FP4, I’ll try that too later this day!

Edit: Nevermind, my port get into a black screen, TWRP IS RUNNING and fastboot is still… nope… BUT bootloader accepts fastboot commands :slight_smile:

1 Like

I’m happy to announce that you can now find TWRP builds directly on twrp.me! No change in supported features or known issues though.

Initial post has been update to point there :slight_smile:

6 Likes

Any changes that make it viable or should we stick with LOS recovery d/t TWRP not able to access the storage of the device?

2 Likes

Hello friends!

I’m currently doing some tests with linux-based alternatives OS on my FP4, Ubuntu Touch and Sailfish OS.
I wanted to try TWRP backup and restore, and share here my experience :slight_smile:
NOTE: those two OS are not encrypted so it’s ok for me.

On my FP2 I have a long and successful story of using TWRP to switch between alternative OSes.
It consists of backup and restore of 3 partitions : Boot/System/Data

Here on FP4 partitions are slightly different (A/B device), I found here that one can do:

  • Data Backup: select only the Data partition.
  • System Backup: select partitions
    • Boot
    • DTBO
    • Super which contains the logical system, system_ext, odm, product, and vendor partitions

I tried with Ubuntu Touch, however I have those red error message:

failed to mount '/system_ext' (Block device required)
failed to mount '/product' (Block device required)

and I’m only able to backup Data

NOTE that this could be already useful, in this case the restore process is:

  • Erase the previous OS
  • Fresh install of UT
  • TWRP restore of /Data partition, and reboot :slight_smile:

I then tried with SailfishOS and, even if there is no red messages, backing up of Super partition failed at 67% (4215Mo of 6264Mo).
Looking at the recovery.log, there is this error message:

Backing up Super (system system_ext product vendor)...
I:Reading '/dev/block/by-name/super', writing '/external_sd/TWRP/BACKUPS/xxx super.emmc.win'
I:Error writing destination fd (Operation not permitted)
Backup Failed. Cleaning Backup Folder.

Searching for a solution, I found here that this could be due to a FAT32 SD Card (and indeed my SD card is formatted in FAT32 filesystem)
I tried again on Internal Storage… and it worked :smiley:

[BACKUP COMPLETED IN 80 SECONDS]

I have now a full backup of SailfishOS 4.5.0.24.
In the backup folder (total size 7.73 Go), the file super.emmc.win is 6.00 Go big!

Could you try again? it could be the same issue :wink:

2 Likes

You are right, that might very well be the case, but I don’t think I have time to test that any time soon.

super isn’t really all that interesting to me since we have factory images now and I can just get it from there, data still can’t be decrypted so at least for Android backups TWRP isn’t all that useful at the moment.

But there will come a time when I switch my FP4 to proper Linux, so I’m closely following your discoveries :nerd_face:

1 Like

Hey you! That sounds awesome. Is there any update if accessing userdata with TWRP will be possible in the nearer future?

1 Like