TWRP for Fairphone 3

I have no idea.

Working perfectly, thanks a lot :slight_smile:

Hello all,

this TWRP version can / should be installed only on FP3, right?
And not on FP2?

I’m not up to date at this moment, my last bit of information was that the official TWRP version for FP2 is not able to decrypt data partition, while this TWRP version for FP3 obviously can do this.
If this FP3 TWRP version can’t be used on FP2, is there a version for FP2 able to decrypt data partition?

Absolutely not on the Fairphone 2.

Not with Android 8+ encryption.
Official TWRP 3.2.3-0 was able to handle up to Android 7 encryption.
Current official TWRP 3.3.1-1 should be able to handle up to Android 7 encryption again after decryption somehow broke inbetween (I didn’t check myself anymore, though).

For Android 8+ you can try your luck with this custom TWRP build here, it may or may not decrypt for you … Custom TWRP 3.2.3 to decrypt Android 8/9 encryption.

Ok, than it’s confirmed that still there is nothing available for my use case for FP2.
When having installed LOS17 few days ago I’ve already checked the TWRP versions you mentioned above if they are capable to decrypt, but none worked.
Only when having seen now this thread, there was a glimpse of hope that it also might have been a solution for FP2.

Thanks for the info,

1 Like

It’s a pitty that decryption of /data on FP2 is not possible :-(.

When I try to make backups with twrp, it always says “backup failed” (although I cannot see anything wrong before that). Any idea how to get more information? Is logcat relevant here?

here is the recovery.log of the failed backup https://trancart.eu/pastebin/?e25509700e252074#GKDtmgkEfeDZt23ThDGzU7MiWJnXv1AyGuuqdGtNE8Ln

ok problem solved, I actually need to uncheck sd-ext partition in “partitions to backup” :slight_smile:

2 Likes

Thanks for the great work!
Is there the idea of getting official Maintainer for the Fairphone 3 of TWRP?
https://twrp.me/faq/OfficialMaintainer.html

I was planning to work on that once the new TWRP version is out (which will probably happen in a few days)

9 Likes

As promised TWRP 3.4.0 has just been released:
https://twrp.me/site/update/2020/06/24/twrp-3.4.0-0-released.html

And with its release FP3 is now officially supported:
https://twrp.me/fairphone/fairphone3.html

Unfortunately for some reason I am unable to edit the OP (It just shows me the post history)
If anyone knows what’s up with that?

10 Likes

The edit icon is below the post (perhaps you have to use the three dot icon there to make it visible), the post history icon is above the post and a different thing :wink: .

Thanks for the great work.

Unfortunately there is no edit-icon under the post (even when using the three dots):
edit-icon

Probably you can’t edit posts older than a certain age. I’ve edited it for you, if you aren’t happy with it feel free to reply here or by PM.

1 Like

@moderators:

Can something be done about this?

2 Likes

I made it into a wiki.

@k4y0z if that is not the ideal solution (others can edit now too) I can undo it when you’re done editing and re-wikify again if you need to edit again. :slight_smile:

2 Likes

Thank you @paulakreuzer and @AlbertJP
I guess a wiki works for now, if I see any problems with it, I’ll contact you again.

Although generally it would be nice not to have a time-limit on editing normal posts (or at least increase the time, if that’s possible).

2 Likes

I just joined the forum and wanted to send a big Thank You :partying_face: for creating the TWRP version for FP3! I got my Fairphone in February and was able to run Resurrection Remix thanks to your work. Great to see your stuff got merged into upstream and also that it enabled other people to create more custom ROMs for the FP3 (I’m now running LineageOS :slight_smile: ).

5 Likes

I can’t get to twrp on my phone. Maybe a stupid question, but do you get into twrp in the same way as in the PF2?

‘2. Start TWRP by keeping volume up and power pressed for 10s or so during power on. If you boot it for the first time, it asks to enable write permission for the system partition, which is not needed for updating TWRP.’

And if so, does this mean that twrp is not permantly installed on my phone?

tnx!