TWRP for Fairphone 3

When I try to make backups with twrp, it always says “backup failed” (although I cannot see anything wrong before that). Any idea how to get more information? Is logcat relevant here?

here is the recovery.log of the failed backup

ok problem solved, I actually need to uncheck sd-ext partition in “partitions to backup” :slight_smile:


Thanks for the great work!
Is there the idea of getting official Maintainer for the Fairphone 3 of TWRP?

I was planning to work on that once the new TWRP version is out (which will probably happen in a few days)


As promised TWRP 3.4.0 has just been released:

And with its release FP3 is now officially supported:

Unfortunately for some reason I am unable to edit the OP (It just shows me the post history)
If anyone knows what’s up with that?


The edit icon is below the post (perhaps you have to use the three dot icon there to make it visible), the post history icon is above the post and a different thing :wink: .

Thanks for the great work.

Unfortunately there is no edit-icon under the post (even when using the three dots):

Probably you can’t edit posts older than a certain age. I’ve edited it for you, if you aren’t happy with it feel free to reply here or by PM.

1 Like


Can something be done about this?


I made it into a wiki.

@k4y0z if that is not the ideal solution (others can edit now too) I can undo it when you’re done editing and re-wikify again if you need to edit again. :slight_smile:


Thank you @paulakreuzer and @AlbertJP
I guess a wiki works for now, if I see any problems with it, I’ll contact you again.

Although generally it would be nice not to have a time-limit on editing normal posts (or at least increase the time, if that’s possible).


I just joined the forum and wanted to send a big Thank You :partying_face: for creating the TWRP version for FP3! I got my Fairphone in February and was able to run Resurrection Remix thanks to your work. Great to see your stuff got merged into upstream and also that it enabled other people to create more custom ROMs for the FP3 (I’m now running LineageOS :slight_smile: ).


I can’t get to twrp on my phone. Maybe a stupid question, but do you get into twrp in the same way as in the PF2?

‘2. Start TWRP by keeping volume up and power pressed for 10s or so during power on. If you boot it for the first time, it asks to enable write permission for the system partition, which is not needed for updating TWRP.’

And if so, does this mean that twrp is not permantly installed on my phone?



I had the same error-code as Stefan
(FP3,root,TWRP3.4) I choose every partition to be backedup except “SD-EXT”

I:Find_File: Error opening ‘/sys/class/backlight’

I:Failed to load image from indeterminate013, error -1

I:addFile ‘/data/misc_ce/0/BIRNXu6JStT9PesVZ0YvWD/KQ9WYK8AIVcD9C63IZLfWB’ including root: 1
==> set selinux context: u:object_r:storaged_data_file:s0
I:Error adding file ‘/data/misc_ce/0/BIRNXu6JStT9PesVZ0YvWD/KQ9WYK8AIVcD9C63IZLfWB’ to ‘/external_sd/TWRP/BACKUPS/A209JDY40201/1969-12-31–20-23-03_89012A011020200109/data.ext4.win000’
Error creating backup.
I:ERROR tarList for thread ID 0
Error creating backup.
I:InfoManager saving ‘/external_sd/TWRP/BACKUPS/A209JDY40201/1969-12-31–20-23-03_89012A011020200109/’
createTarFork() process ended with ERROR: 255
Backup Failed. Cleaning Backup Folder.

I checked and the filesystem on the SD-Card is exFAT, and there is enough free space.
Any idea what’s wrong?

For comparison I tried a backup without the Partition “Data (excl. storage)” which got through without an error.

It looks like your data wasn’t decrypted properly and can therefore not be backed up.
Did you decrypt successfully?
Are you using multiple user-profiles or apps, that would create a separate user-profile?


That indeed looks like the problem I had here: TWRP for Fairphone 3

TWRP 3.4.0 should support multi-user decryption, although I haven’t tested it myself.
AFAIK you need to decrypt additional profiles separately via the menu.
If you want to give that another go, and let us know if that works.

Yes, that was the issue, when I tried another time, TWRP opened a prompt for the pw, decrypted the int. storage and the backup went smoothly.