English

Turn off vibration when connecting via USB on Android 10

Hi all, hoping someone can help. Since the recent Android 10 update, the FP3 is vibrating very strongly each time you connect it to a USB port. Is there any way to disable this? I’m using the phone daily for app development and the phone and/or cable suffer from a loose connection, so it sometimes ends up vibrating in a way that its mimicking an incoming call, super annoying! I’ve checked StackOverflow for related ADB commands, went through the whole lot of system settings as well as Developer Options, no luck :frowning:

If there is a loose connection, test another cable or another bottom module (you can contact a local #fairphoneangel for this) and #contactsupport if it’s under warranty.
Otherwise you can just put the phone on silent mode or Do Not Disturb on as a workaround.
Under Lineage OS on my FP2 I have an option to disable charging vibration, search for “charging sounds” in the settings. Though you may not have it.

2 Likes

Nice, thanks! The “charging sounds and vibration” setting does exist, and turning it off worked perfectly. Also thanks for the warranty suggestion, I’ll check if it’s really the phone that has the loose connection or just the cable.

2 Likes