English

Trouble rooting Fairphone 2 with Fairphone OS 21.08.1

Hello,

I’ve got a clean installation of Fairphone OS 21.08.1 on my Fairphone 2, and I want to follow the instructions in this forum post to root my Fairphone 2.

The first step in those instructions is to install TWRP via a fastboot command which ran successfully, but after doing that I tried booting into recovery only to see a black screen with an Android robot lying down with the words “No command”.

How do I troubleshoot this so that I can root my Fairphone 2 running Fairphone OS 21.08.1? Thank you.

P.S. I am running Fairphone OS 21.08.1 because I need Google Play services to install a use a few apps.

Are you sure you tried at once after installing TWRP to boot into recovery?
If you install TWRP, boot your system and then try to reboot (again) into recovery it sometimes returns to stock recovery system (which is the robot you’ve mentioned).

Once TWRP runs you just have to download magisk and install it using TWRP install function to root the phone.

4 Likes

Aha!!

I tried what you said twice but somehow that didn’t help, but it worked for my third attempt. I guess third time really is the charm.

Thank you for your help! I’ve got Magisk 23 up and running now.

3 Likes