Trapped in fastboot mode with locked bootloader and corrupted custom ROM

I submitted my support ticket on friday night and did get an answer this afternoon. Currently I’m waiting for the shipping labels and instructions.
They acknowledged my situation:

Our Software team has identified the root cause of this issue. We now provide an updated package for manual installation which addresses this cause.

The problem is, this is the exact version that I was using. The checksum of the .zip-file I downloaded is identical to the the one in the article…

Perhabs somebody of you can tell me what I could’ve done wrong:
I installed calyxos several times because everytime that I locked flashing I got the Message that my device is corrupted. After that I unlocked it and installed it again.
I tried this several times until I just let it be open.

After reinstalling FPOS I did the same thing with the only difference, that i wasn’t able to unlock flashing again.

Additional information:
For the installation of calyx I unlocked only flashing.
After the first try of installing FPOS again the script failed because critical was locked, so I unlocked it and tried again. After installing and booting into the configuration wizard, I locked critical and flashing again. After doing that it prompted the message again that my device is corrupted and won’t boot.


As from my understanding the root cause is that. If you flash back the FPOS it does have a bug. That the Switch under Developer Options for “OEM Unlocking” is greyed out and turned off. So unlocking is not allowed. But you cannot turn it on as well. If you then go ahead and lock the bootloader you’re stuck in the loop. I still did not get an answer and everytime I call it says no agent is available right now… But nice that you received a response that fast!


BTW the german number there leads to nowhere, when I call there it just hangs up immediately. I tried to call the Netherlands one several times, where no agents where available unfortunately. Thanks a lot though :slight_smile:

I have to ask: Did you submit a official ticket?
I did get an answer within 2 business days.

Yes. Via the official zendesk tool.

Expect using the (not that easy) workaround mentioned further above:


Yeah, I fell into this trap as well.
Trying to revert back to FpOS using FP4. Install Fairphone OS offline after attempting installing /e/os.
I’m have a feeling the issue was using a built image of /e/os that didn’t match the current security patch level
I updated the phone earlier today to “FP3V.A.116.20220414” (released April 25, 2022) before trying to flash “IMG-e-0.23-r-20220413178020”.
Trying to lock the bootloader as instructed gave me a corrupted OS message as mentioned throughout this post, but it didn’t reset my unlock ability to 0.

However, following Fairphones own guide FP4. Install Fairphone OS offline and locking the bootloader “corrupted” the OS and set my unlock to 0.
Can I somehow see what version is used in that “factory reset Fairphone OS” kit that you download through the link above? I have a gut feeling it’s not up to date to the current security patch level

Welcome to the community :wave:

The latest factory images are based on the A.107 release, so the one before the current version (A.116).

Yeah, you reckon that could of been the problem? :thinking:

It really is on me at the end of the day for attempting something I knew little about (after all, it’s on your own risk), but I think it would be a good idea to really emphasise the importance of finding out the correct versions in all relevant documents.
The documentation with important version numbers gets outdated pretty quickly, so next time I’ll make sure not to rely on those and try to double-check everything myself :thinking:

Hoping to get this restored by sending it off to support like the people further up in the thread did, but if this happens often enough I think it should be in everyone’s interest to make these steps a bit more “fool-proof”.

I don’t think so, I flashed a FP4 running A.107 with those factory images based on the same version and get_unlock_ability was reset to 0 as well.

But at this point I’d be willing to try anything, as long as we finally get this resolved somehow.

For now, the most important part is to check fastboot flashing get_unlock_ability before locking the bootloader again.

Good luck with support, hopefully you can get this resolved quickly :crossed_fingers:


Support did help me with my Fastboot Loop:
First contact: April 29th after Work hours
First respond: May 3rd (reaction time 1.5 work days)
Mailed the phone to the repair center: May 5th
Received the phone back: May 11th

Support was very kind and helpful. Didn’t even had to pay anything because it was within warranty. Couldn’t ask for more.



1 Like

I’ve gotten a reply back on the support ticket I sent in describing the issue reverting back to FairphoneOS and being locked out that way (this is not addressing the /e/OS lockout):

Dear ****,

Thanks for confirming!

I’m sorry to hear your phone is unable to boot normally. Our Software team has identified the root cause of this issue. We now provide an updated package for manual installation which addresses this cause.

Unfortunately, the previous manual installation has damaged critical system files on your Fairphone. Now that the bootloader is locked, standard commands cannot be used to unlock it or install new software.

The good news is that we can fix this in our repair center in France. We have access to special tools which allow us to install new software even on a locked device.

Let me know if you wish to proceed with repair and I’ll be happy to share further instructions with you.

Have a lovely day and take care.


This is the same answer that I did get.
I was in the same situation: locked out after flashing back to FPOS. I guess it is under warranty if you tried to follow the official instructions…


Yes, it would seem like it may be under warranty if you get locked out with FairphoneOS as the corrupt OS, but I would not tempt my luck again if I could avoid it :weary:

I would never say i bricked it with a custom ROM :wink:

As far as I can tell (hashes are the same) there hasn’t been a new release since the one in April and from what I’ve seen on this forum, that one didn’t resolve this issue…

Or do they mean that one of the previous manual installations (first FPOS factory images, /e/, iode, Calyx) damaged some critical system files irreversibly and once a phone went through that process it can’t be fixed by a newer release? :thinking:

1 Like

No, no, they mean it, but they don’t…

Crazy how fast this has been for you. It’s great to see that seems to be just me they “forgot” about :smiley:

First contact: April 13th
First response: April 22th
Next response with detailed instructions on how to return it: May 09th
Getting the shipping label: May 10th
Mailed the phone to the repair center: May 11th
Received the phone back: We’ll see

I don’ t want to brag about it too much as I still have my old phone more or less working and I’m running with that right now. Just unfortunate I guess.

EDIT: And like I said great to see that it seems to be just me :slight_smile:

Well, what are 8-12 weeks compared to eternity…
But it has a certain impudence already…