Trapped in fastboot mode with locked bootloader and corrupted custom ROM

I just got mine back. Kudos to the repair center they received, repaired and shipped it back in just 1 day. Everything is working now, I only need to find a way to use Calyx with root :stuck_out_tongue:


Any updates from FP support on this one? An ETA or anything like that?

I think they consider this fixed with the April release… :thinking:

…but at least that part should probably be fixed at some point:

I can’t say that I have seen many bricks in the past few weeks, so either everyone who had that specific problem bricked their phone already or this is indeed fixed.
I’m still not sure if this problem only ever affected people who flashed those initial factory images before there was a fix. Since then all the custom ROMs have updated their source to the newer ones as well, maybe that’s why we don’t see it anymore? :thinking:

All in all an open and honest postmortem from the dev team would be nice, this did cause a lot of pain for the people who where affected.

Update: Well someone just showed up in the Calyx Matrix channel with a bricked FP4 after flashing from Calyx back to FPOS. So it’s definitely still happening…


probably Calyx was flashed with old instructions which included unlocking ciritical I guess? I read somewhere Calyx now has a warning in the installtion guide to not unlock critical…

It’s still in the latest instructions

  • Unlock the bootloader using
  1. fastboot flashing unlock_critical
  2. fastboot flashing unlock

…and I’m not sure that’s causing it. What’s the point of shipping critical partitions when you don’t flash them to the device? :thinking:

We need some definitive answers from a qualified (Fairphone) dev here, it’s been long enough :roll_eyes:


ok maybe the warning was about locking critical?.. and yes Fairphone has to get this sorted out and provide some information…

1 Like

That has been mentioned before by cde (Calyx dev), yes:

Not exactly.
It was caused by a combination of

  1. older firmware had the bug, latest does not.
  2. from what I can tell lock_critical caused it, we don’t mention that, simply lock

The most recent case doesn’t mention fastboot flashing lock_critical but that might well have played a roll here, you are right :+1:

Vice versa
The unlock the critical but mention NOT to lock it again

Preparing your device

Fairphone 4 “FP4”

Get code to enable unlocking from Fairphone, and follow their instructions

Unlock the bootloader using

fastboot flashing unlock_critical

fastboot flashing unlock

Follow installation steps below

CalyxOS Installation

For now installation has to be performed manually, by downloading, unzipping, and then running either flash-all.bat on Windows, or on Linux or MacOS. The latest version of fastboot needs to be installed

Re-lock the bootloader using fastboot flashing lock

DO NOT lock critical DO NOT

1 Like

My phone has now arrived for pickup for me.
Sounds like I should wait until we know for certain what’s causing it before attempting again :thinking:
Anything I could do to help the situation in any way?

The safest path is to either stay on stock FPOS or don’t lock the bootloader when flashing a custom ROM. I still don’t feel confident enough to recommend anything else.

You’ve probably already seen it on Calyx’s Matrix as well, but the most recent case didn’t involve fastboot flashing lock_critical. There goes that theory :roll_eyes:


I think you’re still quite safe as long as you make sure OEM unlock is enabled when locking the bootloader.


What would be the dangers of leaving the bootloader unlocked? Could you potentially be hacked or vulnerable in any way?
The phone was working just fine when I was playing around with it with a custom ROM flashed and bootloader left open, but is it safe enough to operate the phone like that?

If nobody will get physical access, nothing can happen.
Some apps, especially banking apps, will not work with a open bootloader. But none of the apps, I’ve ever used, had issues…

1 Like

Not entirely true. Some malware likes to hide in those partitions protected by secure boot. Let’s say malware is nested in there and from there installs the malware into the OS at every boot. You can reinstall your ROM and remove stuff as much as you like, it won’t protect you at that point. Secure boot is essential for a trusted OS. I would not recommend keeping your bootloader unlocked.


Had I read this beforehand, I could have saved myself a lot of trouble. I’ll wait and see what support says. There doesn’t seem to be a real solution.

Update on my side:
After I contacted Fairphone support the device was send to Cordon for a repair.
This company replied immediately after getting the device that repair cost is 649€ (lol)
After a few more weeks (Fairphone support was not answering) I called Fairphone and they intervened at Cordon and one day later the device was fixed for free and now I have it back.

So please don’t get trolled by Cordon and call Fairphone directly. This is much faster than my text mail. I had a very nice chat on the phone :slight_smile:


Faced with the same problem after moving back from /e/os. There was a similar issue when I was trying to lock the bootloader on /e/os, but I was able to unlock critical clear the data and, lock critical back again and run the devices.

Just to be sure – the only way I can get my device working is to contact support and send it for repair, right?

I’m very happy for you! But I really don’t understand FairPhone’s policy: some had to pay 29€, for you it was free… While the problem comes from a bug in the system software :thinking:


If you are not able to boot (corrupted system?) AND not able to unlock the bootloader again (flag get_unlock_ability set to 0) then yes, that’s the only thing to do!


Just curious: why locking the bootloader corrupts the system that worked perfectly fine?