Trapped in fastboot mode with locked bootloader and corrupted custom ROM

Hey all,

I have the same problem.
I have contacted Fairphone support, maybe they can help me.

Same here,
no flashing/boot/erase commands possible since Bootloader is locked, recovery unavailable.
oem unlock likewise disabled. On boot it always goes directly to bootloader, even if I try to go to recovery.
I haven’t tried the edl stuff you mentioned, but everything else (including hours of googling) didn’t work.
I also contacted support and am waiting for their reply.

Hello,

has anyone received any feedback from Fairphone support?
Unfortunately I do not receive any feedback on my request.

If you are using eOS then your port of call would be e-foundation. Fairphone supports only those phones running the default Android OS.

I think it depends on where/with which OS you bought the phone.

5 Likes

I bought it with the Fairphone OS directly from the Fairphone Shop.

1 Like

Fairphone wouldn’t help with your use of eOS. Their free help/warranty only covers FOS so in any case you would have to revert to that before asking Fairphone for assistance.

Although I agree it’s no warranty case I’d still get in contact with Fairphone support here. I assume Murena support is less appropriate.

3 Likes

Hello,

I have purchased the Fairphone 4 with the FairphoneOS in the Fairphone Shop.
On the phone I have not installed any costum rom like /e/ or lineageos. I had problems with the OTA update, so I tried the offline update and ended up in fastboot lock. As described here at the beginning.

I thought I could ask my question in this thread, since the actual problem is identical, without creating a new one.

I do think it is an issue for Fairphone support.

3 Likes

Yeah, I have the same problem. I’m in touch with support and I’ll have to send my phone in for them to fix it.

Out of interest, did you check that your phone was booting after installing the factory image and before locking the bootloader?

What kind of problems did you have with OTA updates?
Was the installation failing or did you phone not find any updates?

Did you do anything prior to the OTA updates failing like unlocking the bootloader/flashing a (custom) kernel?

1 Like

I do also. As long as there is no way to fix it for yourself you have to send it in…
as already mentioned in other threads, it is round about 30,-€ (I think plus shipping costs)

1 Like

Maybe a new topic. I notice this one has the eOS tag and implies it is not for the default OS

but with the same consistency
A case for the Fairphone Lab :wink:

1 Like

The OTA problem was that the download always stopped. I live in an area of Germany with very poor internet.
Then I tried to download the offline update to update the Fairphone 4.

I have performed the installation according to instructions. The Fairphone rebooted and was directly in fastboot lock without me having to enter the command.
Maybe the download was faulty or something like that.

No, I have not installed a custom rom/kernel.

Without entering which command? If you did not lock the bootloader you should be fine. Does it say DEVICE STATE - locked?

3 Likes

Let’s not be too strict either, the eOS tag implies it is linked in some way with /e/OS, it doesn’t mean one’s not allowed to talk about a similar problem, even with a different cause.

2 Likes

Very good point!
If the bootloader is still unlocked, please try:

4 Likes

so far I have no answer from support either.
What I find strange, that in the fastboot at the bootloader and baseband is nothing behind. So he would have nothing more what he could start. But where does he get the lock status?!

$ fastboot --set-active=a
Setting current slot to ‘a’
FAILED (remote: ‘Slot Change is not allowed in Lock State’)
fastboot: error: Command failed

$ fastboot flashing unlock
FAILED (remote: ‘Flashing Unlock is not allowed’)
fastboot: error: Command failed

Same issue here. I tried to install iodéOS and /e/OS, but after relocking the bootloader, it would show that the phone is corrupt. I could still unlock and try again to no avail.

I figured I’d reinstall the stock OS to try relocking that way, but it still showed that it’s corrupt and now I can’t even unlock the bootloader. Guess I’ll contact support as well.

1 Like

what exactly?
What have you done in which order?

First iodé?
Later /e/OS

What worked?
And when have you re-locked your bootloader? after whih OS installation?

Please a little mor precise.